From: Vitaly Kuznetsov <vkuznets@redhat.com>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: Jim Mattson <jmattson@google.com>,
Sean Christopherson <sean.j.christopherson@intel.com>,
Wanpeng Li <wanpengli@tencent.com>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH v3 0/2] KVM: VMX: cleanup VMXON region allocation
Date: Fri, 6 Mar 2020 14:02:13 +0100 [thread overview]
Message-ID: <20200306130215.150686-1-vkuznets@redhat.com> (raw)
Minor cleanup with no functional change (intended):
- Rename 'kvm_area' to 'vmxon_region'
- Simplify setting revision_id for VMXON region when eVMCS is in use
Changes since v1:
- Pass 'enum vmcs_type' parameter to alloc_vmcs() too [Sean Christopherson <sean.j.christopherson@intel.com>]
Vitaly Kuznetsov (2):
KVM: VMX: rename 'kvm_area' to 'vmxon_region'
KVM: VMX: untangle VMXON revision_id setting when using eVMCS
arch/x86/kvm/vmx/nested.c | 2 +-
arch/x86/kvm/vmx/vmx.c | 44 ++++++++++++++++++---------------------
arch/x86/kvm/vmx/vmx.h | 12 ++++++++---
3 files changed, 30 insertions(+), 28 deletions(-)
--
2.24.1
next reply other threads:[~2020-03-06 13:02 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-03-06 13:02 Vitaly Kuznetsov [this message]
2020-03-06 13:02 ` [PATCH v3 1/2] KVM: VMX: rename 'kvm_area' to 'vmxon_region' Vitaly Kuznetsov
2020-03-06 22:05 ` Krish Sadhukhan
2020-03-06 13:02 ` [PATCH v3 2/2] KVM: VMX: untangle VMXON revision_id setting when using eVMCS Vitaly Kuznetsov
2020-03-06 22:20 ` Krish Sadhukhan
2020-03-06 23:07 ` Sean Christopherson
2020-03-06 23:57 ` Krish Sadhukhan
2020-03-07 0:28 ` Sean Christopherson
2020-03-07 1:34 ` Krish Sadhukhan
2020-03-09 9:31 ` Vitaly Kuznetsov
2020-03-18 17:17 ` Vitaly Kuznetsov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200306130215.150686-1-vkuznets@redhat.com \
--to=vkuznets@redhat.com \
--cc=jmattson@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=sean.j.christopherson@intel.com \
--cc=wanpengli@tencent.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®