From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
Cc: mazziesaccount@gmail.com, Sebastian Reichel <sre@kernel.org>,
Rob Herring <robh+dt@kernel.org>,
Mark Rutland <mark.rutland@arm.com>,
"Rafael J. Wysocki" <rafael@kernel.org>,
Liam Girdwood <lgirdwood@gmail.com>,
Mark Brown <broonie@kernel.org>,
linux-pm@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org,
Markus Laine <markus.laine@fi.rohmeurope.com>,
Mikko Mutanen <mikko.mutanen@fi.rohmeurope.com>
Subject: Re: [PATCH v4 3/9] drivers: base: add linear ranges helpers
Date: Wed, 18 Mar 2020 14:08:38 +0100 [thread overview]
Message-ID: <20200318130838.GB2769584@kroah.com> (raw)
In-Reply-To: <01ac2439f9d33ae405999065c5d28c368bad4a28.1582617178.git.matti.vaittinen@fi.rohmeurope.com>
On Tue, Feb 25, 2020 at 10:53:01AM +0200, Matti Vaittinen wrote:
> Many devices have control registers which control some measurable
> property. Often a register contains control field so that change in
> this field causes linear change in the controlled property. It is not
> a rare case that user wants to give 'meaningful' control values and
> driver needs to convert them to register field values. Even more
> often user wants to 'see' the currently set value - again in
> meaningful units - and driver needs to convert the values it reads
> from register to these meaningful units. Examples of this include:
>
> - regulators, voltage/current configurations
> - power, voltage/current configurations
> - clk(?) NCOs
>
> and maybe others I can't think of right now.
>
> Provide a linear_range helper which can do conversion from user value
> to register value 'selector'.
>
> The idea here is stolen from regulator framework and patches refactoring
> the regulator helpers to use this are following.
>
> Signed-off-by: Matti Vaittinen <matti.vaittinen@fi.rohmeurope.com>
> ---
>
> Changes since rfc-v3:
> - Kerneldoc fixes
> - Corrected commit message typo meaningfull => meaningful
>
> drivers/base/Kconfig | 3 +
> drivers/base/Makefile | 1 +
> drivers/base/linear_ranges.c | 246 +++++++++++++++++++++++++++++++++++
Why in drivers/base/ ?
Why not in lib/ ?
> include/linux/linear_range.h | 48 +++++++
> 4 files changed, 298 insertions(+)
> create mode 100644 drivers/base/linear_ranges.c
> create mode 100644 include/linux/linear_range.h
>
> diff --git a/drivers/base/Kconfig b/drivers/base/Kconfig
> index 5f0bc74d2409..636b6fa8e499 100644
> --- a/drivers/base/Kconfig
> +++ b/drivers/base/Kconfig
> @@ -209,4 +209,7 @@ config GENERIC_ARCH_TOPOLOGY
> appropriate scaling, sysfs interface for reading capacity values at
> runtime.
>
> +config LINEAR_RANGES
> + tristate
No help text at all???
> +EXPORT_SYMBOL(linear_range_values_in_range);
EXPORT_SYMBOL_GPL() for all of these? I have to ask...
> @@ -0,0 +1,48 @@
> +/* SPDX-License-Identifier: GPL-2.0-or-later */
Are you sure about the "or later"? Again, I have to ask.
> +/* Copyright (C) 2020 ROHM Semiconductors */
> +
> +#ifndef LINEAR_RANGE_H
> +#define LINEAR_RANGE_H
> +
> +#include <linux/types.h>
Why is this needed?
thanks,
greg k-h
next prev parent reply other threads:[~2020-03-18 13:08 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-02-25 8:51 [PATCH v4 0/9] Support ROHM BD99954 charger IC Matti Vaittinen
2020-02-25 8:52 ` [PATCH v4 1/9] dt-bindings: battery: add new battery parameters Matti Vaittinen
2020-03-02 22:00 ` Rob Herring
2020-02-25 8:52 ` [PATCH v4 2/9] dt_bindings: ROHM BD99954 Charger Matti Vaittinen
2020-03-02 22:07 ` Rob Herring
2020-03-03 6:30 ` Vaittinen, Matti
2020-02-25 8:53 ` [PATCH v4 3/9] drivers: base: add linear ranges helpers Matti Vaittinen
2020-03-18 13:08 ` Greg Kroah-Hartman [this message]
2020-03-18 13:42 ` Vaittinen, Matti
2020-03-18 13:50 ` gregkh
2020-03-23 15:39 ` Vaittinen, Matti
2020-02-25 8:53 ` [PATCH v4 4/9] power: supply: bd70528: rename linear_range to avoid collision Matti Vaittinen
2020-02-25 8:53 ` [PATCH v4 5/9] regulator: rename regulator_linear_range to linear_range Matti Vaittinen
2020-02-25 8:54 ` [PATCH v4 6/9] regulator: use linear_ranges helper Matti Vaittinen
2020-02-25 8:54 ` [PATCH v4 7/9] power: supply: bd70528: use linear ranges Matti Vaittinen
2020-02-25 8:55 ` [PATCH v4 8/9] power: supply: add battery parameters Matti Vaittinen
2020-02-25 8:55 ` [PATCH v4 9/9] power: supply: Support ROHM bd99954 charger Matti Vaittinen
2020-02-25 16:21 ` Randy Dunlap
2020-02-26 7:58 ` Vaittinen, Matti
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200318130838.GB2769584@kroah.com \
--to=gregkh@linuxfoundation.org \
--cc=broonie@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=markus.laine@fi.rohmeurope.com \
--cc=matti.vaittinen@fi.rohmeurope.com \
--cc=mazziesaccount@gmail.com \
--cc=mikko.mutanen@fi.rohmeurope.com \
--cc=rafael@kernel.org \
--cc=robh+dt@kernel.org \
--cc=sre@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®