From: Oscar Carter <oscar.carter@gmx.com>
To: Forest Bond <forest@alittletooquiet.net>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Oscar Carter <oscar.carter@gmx.com>,
Malcolm Priestley <tvboxspy@gmail.com>,
Quentin Deslandes <quentin.deslandes@itdev.co.uk>,
Amir Mahdi Ghorbanian <indigoomega021@gmail.com>,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH v2 0/2] staging: vt6656: Refactor the vnt_get_phy_field function
Date: Sat, 11 Apr 2020 14:26:08 +0200 [thread overview]
Message-ID: <20200411122610.7901-1-oscar.carter@gmx.com> (raw)
This patch series makes a refactor of the vnt_get_phy_field function
through two patches.
The first one refactors the assignment of the "phy->signal" variable
using a constant array with the correct values for every rate.
The second patch removes duplicate code for the assignment of the
"phy->service" variable by putting it outside the if-else statement due
to it's the same for the two branches.
Changelog v1 -> v2:
- Remove one dimension from the constant array for the "phy->signal"
values and use an OR mask instead of the second array dimension as
Malcolm Priestley has suggested.
Oscar Carter (2):
staging: vt6656: Refactor the assignment of the phy->signal variable
staging: vt6656: Remove duplicate code for the phy->service assignment
drivers/staging/vt6656/baseband.c | 108 ++++++++----------------------
1 file changed, 27 insertions(+), 81 deletions(-)
--
2.20.1
next reply other threads:[~2020-04-11 12:26 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-11 12:26 Oscar Carter [this message]
2020-04-11 12:26 ` [PATCH v2 1/2] staging: vt6656: Refactor the assignment of the phy->signal variable Oscar Carter
2020-04-13 12:56 ` Greg Kroah-Hartman
2020-04-13 14:25 ` Oscar Carter
2020-04-13 14:32 ` Greg Kroah-Hartman
2020-04-13 14:43 ` Oscar Carter
2020-04-11 12:26 ` [PATCH v2 2/2] staging: vt6656: Remove duplicate code for the phy->service assignment Oscar Carter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200411122610.7901-1-oscar.carter@gmx.com \
--to=oscar.carter@gmx.com \
--cc=devel@driverdev.osuosl.org \
--cc=forest@alittletooquiet.net \
--cc=gregkh@linuxfoundation.org \
--cc=indigoomega021@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=quentin.deslandes@itdev.co.uk \
--cc=tvboxspy@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®