From: Oscar Carter <oscar.carter@gmx.com>
To: Forest Bond <forest@alittletooquiet.net>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Oscar Carter <oscar.carter@gmx.com>,
Quentin Deslandes <quentin.deslandes@itdev.co.uk>,
Malcolm Priestley <tvboxspy@gmail.com>,
Dan Carpenter <dan.carpenter@oracle.com>,
Amir Mahdi Ghorbanian <indigoomega021@gmail.com>,
"John B. Wyatt IV" <jbwyatt4@gmail.com>,
Colin Ian King <colin.king@canonical.com>,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH 3/5] staging: vt6656: Use define instead of magic number for tx_rate
Date: Tue, 14 Apr 2020 17:38:47 +0200 [thread overview]
Message-ID: <20200414153849.5785-4-oscar.carter@gmx.com> (raw)
In-Reply-To: <20200414153849.5785-1-oscar.carter@gmx.com>
Use the define RATE_11M present in the file "device.h" instead of the
magic number 3. So the code is more clear.
Reviewed-by: Dan Carpenter <dan.carpenter@oracle.com>
Signed-off-by: Oscar Carter <oscar.carter@gmx.com>
---
drivers/staging/vt6656/baseband.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/vt6656/baseband.c b/drivers/staging/vt6656/baseband.c
index e0352405e4cf..149c9bba7108 100644
--- a/drivers/staging/vt6656/baseband.c
+++ b/drivers/staging/vt6656/baseband.c
@@ -24,6 +24,7 @@
#include <linux/bits.h>
#include <linux/kernel.h>
+#include "device.h"
#include "mac.h"
#include "baseband.h"
#include "rf.h"
@@ -221,7 +222,7 @@ unsigned int vnt_get_frame_time(u8 preamble_type, u8 pkt_type,
rate = (unsigned int)vnt_frame_time[tx_rate];
- if (tx_rate <= 3) {
+ if (tx_rate <= RATE_11M) {
if (preamble_type == PREAMBLE_SHORT)
preamble = 96;
else
--
2.20.1
next prev parent reply other threads:[~2020-04-14 15:40 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-14 15:38 [PATCH 0/5] staging: vt6656: Rebase all rejected patches Oscar Carter
2020-04-14 15:38 ` [PATCH 1/5] staging: vt6656: Return error code in vnt_rf_write_embedded function Oscar Carter
2020-04-14 15:38 ` [PATCH 2/5] staging: vt6656: Use BIT() macro instead of bit shift operator Oscar Carter
2020-04-14 15:38 ` Oscar Carter [this message]
2020-04-14 15:38 ` [PATCH 4/5] staging: vt6656: Refactor the assignment of the phy->signal variable Oscar Carter
2020-04-14 15:38 ` [PATCH 5/5] staging: vt6656: Remove duplicate code for the phy->service assignment Oscar Carter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200414153849.5785-4-oscar.carter@gmx.com \
--to=oscar.carter@gmx.com \
--cc=colin.king@canonical.com \
--cc=dan.carpenter@oracle.com \
--cc=devel@driverdev.osuosl.org \
--cc=forest@alittletooquiet.net \
--cc=gregkh@linuxfoundation.org \
--cc=indigoomega021@gmail.com \
--cc=jbwyatt4@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=quentin.deslandes@itdev.co.uk \
--cc=tvboxspy@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®