mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dejin Zheng <zhengdejin5@gmail.com>
To: Markus Elfring <Markus.Elfring@web.de>
Cc: Mark Brown <broonie@kernel.org>,
	linux-kernel@vger.kernel.org, kernel-janitors@vger.kernel.org
Subject: Re: [PATCH v1 1/2] regmap: redefined regmap_read_poll_timeout to simplify code
Date: Mon, 20 Apr 2020 21:30:23 +0800	[thread overview]
Message-ID: <20200420133023.GB8103@nuc8i5> (raw)
In-Reply-To: <3376dcba-4285-c894-915e-2f41cbf23caa@web.de>

On Sun, Apr 19, 2020 at 07:09:14PM +0200, Markus Elfring wrote:
> > use read_poll_timeout macro to redefined regmap_read_poll_timeout
> > and also remove the duplicate code.
> 
> How do you think about a wording variant like the following?
> 
>    Subject:
>    [PATCH 1/2] regmap: Simplify implementation of the regmap_read_poll_timeout() macro
> 
>    Change description:
>    Simplify the implementation of the macro “regmap_read_poll_timeout”
>    by using the macro “read_poll_timeout”.
>
Good, I will send the patch v2.
> 
> …
> > +++ b/include/linux/regmap.h
> …
> > @@ -122,26 +123,10 @@ struct reg_sequence {
> >   */
> >  #define regmap_read_poll_timeout(map, addr, val, cond, sleep_us, timeout_us) \
> >  ({ \
> …
> > +	int __ret, __tmp; \
> > +	__tmp = read_poll_timeout(regmap_read, __ret, __ret || (cond), \
> > +			sleep_us, timeout_us, false, (map), (addr), &(val)); \
> > +	__ret ?: __tmp; \
> >  })
> 
> * Can this macro work also with variable names which do not contain
>   double underscores?
>
Yes, this is to avoid using the same variable with its caller.

> * Can the tag “Fixes” be relevant for such an adjustment?
>
I think It is not relevant and we don't need add it.

BR,
Dejin

> Regards,
> Markus

  reply	other threads:[~2020-04-20 13:30 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-19 17:09 Markus Elfring
2020-04-20 13:30 ` Dejin Zheng [this message]
  -- strict thread matches above, loose matches on Subject: below --
2020-04-19 13:51 [PATCH v1 0/2] use read_poll_timeout macro " Dejin Zheng
2020-04-19 13:51 ` [PATCH v1 1/2] regmap: redefined regmap_read_poll_timeout " Dejin Zheng

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200420133023.GB8103@nuc8i5 \
    --to=zhengdejin5@gmail.com \
    --cc=Markus.Elfring@web.de \
    --cc=broonie@kernel.org \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®