From: Ira Weiny <ira.weiny@intel.com>
To: Dave Chinner <david@fromorbit.com>
Cc: "Darrick J. Wong" <darrick.wong@oracle.com>,
linux-kernel@vger.kernel.org, linux-xfs@vger.kernel.org,
Al Viro <viro@zeniv.linux.org.uk>, Jan Kara <jack@suse.cz>,
Dan Williams <dan.j.williams@intel.com>,
Christoph Hellwig <hch@lst.de>,
"Theodore Y. Ts'o" <tytso@mit.edu>,
Jeff Moyer <jmoyer@redhat.com>,
linux-ext4@vger.kernel.org, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH V9 10/11] fs/xfs: Update xfs_ioctl_setattr_dax_invalidate()
Date: Tue, 21 Apr 2020 14:43:29 -0700 [thread overview]
Message-ID: <20200421214328.GD3372712@iweiny-DESK2.sc.intel.com> (raw)
In-Reply-To: <20200421213049.GC27860@dread.disaster.area>
On Wed, Apr 22, 2020 at 07:30:49AM +1000, Dave Chinner wrote:
> On Tue, Apr 21, 2020 at 01:31:40PM -0700, Darrick J. Wong wrote:
> > On Tue, Apr 21, 2020 at 12:17:52PM -0700, ira.weiny@intel.com wrote:
> > > From: Ira Weiny <ira.weiny@intel.com>
> > >
> > > Because of the separation of FS_XFLAG_DAX from S_DAX and the delayed
> > > setting of S_DAX, data invalidation no longer needs to happen when
> > > FS_XFLAG_DAX is changed.
> > >
> > > Change xfs_ioctl_setattr_dax_invalidate() to be
> > > xfs_ioctl_dax_check_set_cache() and alter the code to reflect the new
> > > functionality.
> > >
> > > Furthermore, we no longer need the locking so we remove the join_flags
> > > logic.
> > >
> > > Signed-off-by: Ira Weiny <ira.weiny@intel.com>
> > >
> > > ---
> > > Changes from V8:
> > > Change name of function to xfs_ioctl_dax_check_set_cache()
> > > Update commit message
> > > Fix bit manipulations
> > >
> > > Changes from V7:
> > > Use new flag_inode_dontcache()
> > > Skip don't cache if mount over ride is active.
> > >
> > > Changes from v6:
> > > Fix completely broken implementation and update commit message.
> > > Use the new VFS layer I_DONTCACHE to facilitate inode eviction
> > > and S_DAX changing on drop_caches
> > >
> > > Changes from v5:
> > > New patch
> > > ---
> > > fs/xfs/xfs_ioctl.c | 108 +++++++++------------------------------------
> > > 1 file changed, 20 insertions(+), 88 deletions(-)
> > >
> > > diff --git a/fs/xfs/xfs_ioctl.c b/fs/xfs/xfs_ioctl.c
> > > index 104495ac187c..b87b571a6748 100644
> > > --- a/fs/xfs/xfs_ioctl.c
> > > +++ b/fs/xfs/xfs_ioctl.c
> > > @@ -1245,64 +1245,26 @@ xfs_ioctl_setattr_xflags(
> > > return 0;
> > > }
> > >
> > > -/*
> > > - * If we are changing DAX flags, we have to ensure the file is clean and any
> > > - * cached objects in the address space are invalidated and removed. This
> > > - * requires us to lock out other IO and page faults similar to a truncate
> > > - * operation. The locks need to be held until the transaction has been committed
> > > - * so that the cache invalidation is atomic with respect to the DAX flag
> > > - * manipulation.
> > > - */
> > > -static int
> > > -xfs_ioctl_setattr_dax_invalidate(
> > > +static void
> > > +xfs_ioctl_dax_check_set_cache(
> >
> > That's a ... strange name. Set cache on what?
> >
> > Oh, this is the function that sets I_DONTCACHE if an FS_XFLAG_DAX change
> > could have an immediate effect on S_DAX (assuming no other users). What
> > do you think of the following?
> >
> > /*
> > * If a change to FS_XFLAG_DAX will result in an change to S_DAX
> > * the next time the incore inode is initialized, set the VFS
> > * I_DONTCACHE flag to try to hurry that along.
> > */
> > static void
> > xfs_ioctl_try_change_vfs_dax(...)
>
> That doesn't seem any better. This is a preparation function now, in
> that it can't fail and doesn't change the outcome of the operation
> being performed. So, IMO, calling it something like
> xfs_ioctl_setattr_prepare_dax() would be a better name for it.
But it does potentially (after a check) set I_DONTCACHE.
What about?
xfs_ioctl_dax_check_set_dontcache()?
Ira
>
> Cheers,
>
> Dave.
> --
> Dave Chinner
> david@fromorbit.com
next prev parent reply other threads:[~2020-04-21 21:43 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-21 19:17 [PATCH V9 00/11] XFS - Enable per-file/per-directory DAX operations V9 ira.weiny
2020-04-21 19:17 ` [PATCH V9 01/11] fs/xfs: Remove unnecessary initialization of i_rwsem ira.weiny
2020-04-21 19:17 ` [PATCH V9 02/11] fs: Remove unneeded IS_DAX() check in io_is_direct() ira.weiny
2020-04-21 20:13 ` Darrick J. Wong
2020-04-22 8:37 ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 03/11] fs/stat: Define DAX statx attribute ira.weiny
2020-04-22 16:29 ` Darrick J. Wong
2020-04-22 18:51 ` Ira Weiny
2020-04-23 8:24 ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 04/11] fs/xfs: Change XFS_MOUNT_DAX to XFS_MOUNT_DAX_ALWAYS ira.weiny
2020-04-21 19:17 ` [PATCH V9 05/11] fs/xfs: Make DAX mount option a tri-state ira.weiny
2020-04-21 20:16 ` Darrick J. Wong
2020-04-21 21:06 ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 06/11] fs/xfs: Create function xfs_inode_should_enable_dax() ira.weiny
2020-04-21 19:17 ` [PATCH V9 07/11] fs/xfs: Combine xfs_diflags_to_linux() and xfs_diflags_to_iflags() ira.weiny
2020-04-21 19:17 ` [PATCH V9 08/11] fs: Lift XFS_IDONTCACNE to the VFS layer ira.weiny
2020-04-21 20:23 ` Darrick J. Wong
2020-04-21 21:12 ` Ira Weiny
2020-04-22 8:41 ` Jan Kara
2020-04-21 19:17 ` [PATCH V9 09/11] fs: Introduce DCACHE_DONTCACHE ira.weiny
2020-04-21 20:25 ` Darrick J. Wong
2020-04-21 21:15 ` Ira Weiny
2020-04-22 2:34 ` Al Viro
2020-04-22 3:46 ` Ira Weiny
2020-04-22 8:46 ` Jan Kara
2020-04-22 15:19 ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 10/11] fs/xfs: Update xfs_ioctl_setattr_dax_invalidate() ira.weiny
2020-04-21 20:31 ` Darrick J. Wong
2020-04-21 21:30 ` Dave Chinner
2020-04-21 21:43 ` Ira Weiny [this message]
2020-04-21 23:13 ` Dave Chinner
2020-04-21 23:24 ` Ira Weiny
2020-04-21 19:17 ` [PATCH V9 11/11] Documentation/dax: Update Usage section ira.weiny
2020-04-21 20:34 ` Darrick J. Wong
2020-04-21 21:49 ` Ira Weiny
2020-04-22 9:47 ` Jan Kara
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200421214328.GD3372712@iweiny-DESK2.sc.intel.com \
--to=ira.weiny@intel.com \
--cc=dan.j.williams@intel.com \
--cc=darrick.wong@oracle.com \
--cc=david@fromorbit.com \
--cc=hch@lst.de \
--cc=jack@suse.cz \
--cc=jmoyer@redhat.com \
--cc=linux-ext4@vger.kernel.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=tytso@mit.edu \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®