mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: Matt Helsley <mhelsley@vmware.com>,
	Peter Zijlstra <peterz@infradead.org>,
	linux-kernel@vger.kernel.org,
	Josh Poimboeuf <jpoimboe@redhat.com>,
	Sami Tolvanen <samitolvanen@google.com>,
	Borislav Petkov <bp@alien8.de>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Thomas Gleixner <tglx@linutronix.de>
Subject: Re: [PATCH 2/3] objtool: Rename elf_read() to elf_open_read()
Date: Wed, 22 Apr 2020 21:22:35 +0200	[thread overview]
Message-ID: <20200422192235.GA14331@gmail.com> (raw)
In-Reply-To: <20200422170048.GA9040@rlwimi.vmware.com>


* Matt Helsley <mhelsley@vmware.com> wrote:

> On Wed, Apr 22, 2020 at 04:22:35PM +0200, Ingo Molnar wrote:
> > 
> > * Peter Zijlstra <peterz@infradead.org> wrote:
> > 
> > > On Wed, Apr 22, 2020 at 12:32:04PM +0200, Ingo Molnar wrote:
> > > > 'struct elf *' handling is an open/close paradigm, make sure the naming
> > > > matches that:
> > > > 
> > > >    elf_open_read()
> > > >    elf_write()
> > > >    elf_close()
> > > 
> > > 
> > > > diff --git a/tools/objtool/check.c b/tools/objtool/check.c
> > > > index f2a84271e807..12e2aea42bb2 100644
> > > > --- a/tools/objtool/check.c
> > > > +++ b/tools/objtool/check.c
> > > > @@ -2614,7 +2614,7 @@ int check(const char *_objname, bool orc)
> > > >  
> > > >  	objname = _objname;
> > > >  
> > > > -	file.elf = elf_read(objname, orc ? O_RDWR : O_RDONLY);
> > > > +	file.elf = elf_open_read(objname, orc ? O_RDWR : O_RDONLY);
> > > 
> > > Note that I have a patch pending that makes that unconditionally O_RDWR,
> > > which sort of seems to suggest elf_open() might be the better name.
> > 
> > Ok, done!
> 
> It might be a better name but there could be a problem with it --
> see 8e144797f1a67c52e386161863da4614a23ad913
> "objtool: Rename elf_open() to prevent conflict with libelf from elftoolchain"
> 
> Unless I'm forgetting something I think that'd still be an issue.

Indeed, that's a good point - I'll move back to elf_open_read()! :-)

Thanks,

	Ingo

  reply	other threads:[~2020-04-22 19:22 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-22 10:32 [PATCH 0/3] objtool: Constify most of the instruction decoding loop Ingo Molnar
2020-04-22 10:32 ` [PATCH 1/3] objtool: Constify 'struct elf *' parameters Ingo Molnar
2020-04-23  7:49   ` [tip: objtool/core] " tip-bot2 for Ingo Molnar
2020-04-22 10:32 ` [PATCH 2/3] objtool: Rename elf_read() to elf_open_read() Ingo Molnar
2020-04-22 11:43   ` Peter Zijlstra
2020-04-22 14:22     ` Ingo Molnar
2020-04-22 17:00       ` Matt Helsley
2020-04-22 19:22         ` Ingo Molnar [this message]
2020-04-23  7:49   ` [tip: objtool/core] " tip-bot2 for Ingo Molnar
2020-04-22 10:32 ` [PATCH 3/3] objtool: Constify arch_decode_instruction() Ingo Molnar
2020-04-23  7:49   ` [tip: objtool/core] " tip-bot2 for Ingo Molnar
2020-04-22 20:49 ` [PATCH 0/3] objtool: Constify most of the instruction decoding loop Josh Poimboeuf

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200422192235.GA14331@gmail.com \
    --to=mingo@kernel.org \
    --cc=bp@alien8.de \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mhelsley@vmware.com \
    --cc=peterz@infradead.org \
    --cc=samitolvanen@google.com \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome