mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Lukas Wunner <lukas@wunner.de>
To: Syed Nayyar Waris <syednwaris@gmail.com>
Cc: akpm@linux-foundation.org, andriy.shevchenko@linux.intel.com,
	vilhelm.gray@gmail.com, linus.walleij@linaro.org,
	bgolaszewski@baylibre.com, yamada.masahiro@socionext.com,
	rui.zhang@intel.com, daniel.lezcano@linaro.org,
	amit.kucheria@verdurent.com, linux-gpio@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, linux-pm@vger.kernel.org
Subject: Re: [PATCH v2 3/6] gpio: thermal: Utilize for_each_set_clump macro
Date: Sat, 25 Apr 2020 21:26:07 +0200	[thread overview]
Message-ID: <20200425192607.qa2jr7ef2g726txr@wunner.de> (raw)
In-Reply-To: <66296904e2ffce670c14576dfc7ea56417c670ab.1587840668.git.syednwaris@gmail.com>

On Sun, Apr 26, 2020 at 12:35:02AM +0530, Syed Nayyar Waris wrote:
> This patch replaces all the existing for_each_set_clump8 and related
> function calls in the drivers (gpio and thermal) with the equivalent
> new generic for_each_set_clump macro.

Why are patches [3/6] and [4/6] included in v2 even though William
said they should be ignored?

Again, replacing for_each_set_clump8() with for_each_set_clump()
does not provide any benefit but may impact performance and makes
the code more difficult to follow.  So once more, please do not
change drivers which are known to work fine with 8 bit clumps,
specifically gpio-max3191x.c and gpio-74x164.c.

Please in the future include a list of the changes you've made
in the cover letter, not just in each individual patch.

Thanks,

Lukas

  reply	other threads:[~2020-04-25 19:26 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-25 18:59 [PATCH v2 0/6] Introduce the " Syed Nayyar Waris
2020-04-25 19:01 ` [PATCH v2 1/6] bitops: Introduce the " Syed Nayyar Waris
2020-04-25 19:03 ` [PATCH v2 2/6] lib/test_bitmap.c: Add for_each_set_clump test cases Syed Nayyar Waris
2020-04-25 19:05 ` [PATCH v2 3/6] gpio: thermal: Utilize for_each_set_clump macro Syed Nayyar Waris
2020-04-25 19:26   ` Lukas Wunner [this message]
2020-04-25 19:54     ` Syed Nayyar Waris
2020-04-25 19:05 ` [PATCH v2 4/6] bitops: Remove code related to for_each_set_clump8 Syed Nayyar Waris
2020-04-25 19:06 ` [PATCH v2 5/6] gpio: thunderx: Utilize for_each_set_clump macro Syed Nayyar Waris
2020-04-27 16:38   ` kbuild test robot
2020-04-27 18:27   ` kbuild test robot
2020-04-28  1:41   ` kbuild test robot
2020-04-25 19:06 ` [PATCH v2 6/6] gpio: xilinx: " Syed Nayyar Waris

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200425192607.qa2jr7ef2g726txr@wunner.de \
    --to=lukas@wunner.de \
    --cc=akpm@linux-foundation.org \
    --cc=amit.kucheria@verdurent.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=bgolaszewski@baylibre.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rui.zhang@intel.com \
    --cc=syednwaris@gmail.com \
    --cc=vilhelm.gray@gmail.com \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®