From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-9.7 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE,SPF_PASS, URIBL_BLOCKED,USER_AGENT_GIT autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 6DA79C38A24 for ; Thu, 7 May 2020 07:56:29 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 3FA212083B for ; Thu, 7 May 2020 07:56:29 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726950AbgEGH42 (ORCPT ); Thu, 7 May 2020 03:56:28 -0400 Received: from szxga07-in.huawei.com ([45.249.212.35]:43190 "EHLO huawei.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1726618AbgEGH4B (ORCPT ); Thu, 7 May 2020 03:56:01 -0400 Received: from DGGEMS406-HUB.china.huawei.com (unknown [172.30.72.60]) by Forcepoint Email with ESMTP id 6EC65A859BAE067234FF; Thu, 7 May 2020 15:55:58 +0800 (CST) Received: from DESKTOP-C3MD9UG.china.huawei.com (10.166.215.55) by DGGEMS406-HUB.china.huawei.com (10.3.19.206) with Microsoft SMTP Server id 14.3.487.0; Thu, 7 May 2020 15:55:47 +0800 From: Zhen Lei To: Minchan Kim , Nitin Gupta , "Sergey Senozhatsky" , Matthew Wilcox , Jens Axboe , Coly Li , Kent Overstreet , "Alasdair Kergon" , Mike Snitzer , linux-block , Andrew Morton , linux-mm , dm-devel , Song Liu , linux-raid , linux-kernel CC: Zhen Lei Subject: [PATCH v2 04/10] zram: abolish macro SECTORS_PER_PAGE_SHIFT Date: Thu, 7 May 2020 15:50:54 +0800 Message-ID: <20200507075100.1779-5-thunder.leizhen@huawei.com> X-Mailer: git-send-email 2.26.0.windows.1 In-Reply-To: <20200507075100.1779-1-thunder.leizhen@huawei.com> References: <20200507075100.1779-1-thunder.leizhen@huawei.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7BIT Content-Type: text/plain; charset=US-ASCII X-Originating-IP: [10.166.215.55] X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org The name of SECTORS_PER_PAGE_SHIFT is quite hard to read. So use sectors_to_npage() to replace ">> SECTORS_PER_PAGE_SHIFT" Suggested-by: Matthew Wilcox Signed-off-by: Zhen Lei --- drivers/block/zram/zram_drv.c | 4 ++-- drivers/block/zram/zram_drv.h | 1 - 2 files changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/block/zram/zram_drv.c b/drivers/block/zram/zram_drv.c index e2fbf7a847e7..918b77f9bce4 100644 --- a/drivers/block/zram/zram_drv.c +++ b/drivers/block/zram/zram_drv.c @@ -1549,7 +1549,7 @@ static void __zram_make_request(struct zram *zram, struct bio *bio) struct bio_vec bvec; struct bvec_iter iter; - index = bio->bi_iter.bi_sector >> SECTORS_PER_PAGE_SHIFT; + index = sectors_to_npage(bio->bi_iter.bi_sector); offset = (bio->bi_iter.bi_sector & (PAGE_SECTORS - 1)) << SECTOR_SHIFT; @@ -1644,7 +1644,7 @@ static int zram_rw_page(struct block_device *bdev, sector_t sector, goto out; } - index = sector >> SECTORS_PER_PAGE_SHIFT; + index = sectors_to_npage(sector); offset = (sector & (PAGE_SECTORS - 1)) << SECTOR_SHIFT; bv.bv_page = page; diff --git a/drivers/block/zram/zram_drv.h b/drivers/block/zram/zram_drv.h index 10fdf413dd6e..12309175d55e 100644 --- a/drivers/block/zram/zram_drv.h +++ b/drivers/block/zram/zram_drv.h @@ -21,7 +21,6 @@ #include "zcomp.h" -#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) #define ZRAM_LOGICAL_BLOCK_SHIFT 12 #define ZRAM_LOGICAL_BLOCK_SIZE (1 << ZRAM_LOGICAL_BLOCK_SHIFT) #define ZRAM_SECTOR_PER_LOGICAL_BLOCK \ -- 2.26.0.106.g9fadedd