From: Ard Biesheuvel <ardb@kernel.org>
To: linux-efi@vger.kernel.org, Ingo Molnar <mingo@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>
Cc: Ard Biesheuvel <ardb@kernel.org>,
linux-kernel@vger.kernel.org, Arnd Bergmann <arnd@arndb.de>,
Arvind Sankar <nivedita@alum.mit.edu>,
Guenter Roeck <linux@roeck-us.net>, Joe Perches <joe@perches.com>
Subject: [GIT PULL 00/15] More EFI changes for v5.8
Date: Fri, 8 May 2020 20:01:42 +0200 [thread overview]
Message-ID: <20200508180157.1816-1-ardb@kernel.org> (raw)
The following changes since commit 4da0b2b7e67524cc206067865666899bc02e1cb0:
efi/libstub: Re-enable command line initrd loading for x86 (2020-04-25 12:26:32 +0200)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/efi/efi.git efi-next
for you to fetch changes up to 4026229934f6ca0cb44af7b9df00e647b2f1f787:
efi/libstub: Correct comment typos (2020-05-06 11:27:55 +0200)
----------------------------------------------------------------
More EFI changes for v5.8:
- Rename pr_efi/pr_efi_err to efi_info/efi_err, and use them consistently
- Simplify and unify initrd loading
- Parse the builtin command line on x86 (if provided)
- Some fixes for issues introduced by the first batch of v5.8 changes
----------------------------------------------------------------
Ard Biesheuvel (2):
efi/libstub/x86: Work around LLVM ELF quirk build regression
efi/libstub: Make efi_printk() input argument const char*
Arvind Sankar (12):
efi/x86: Use correct size for boot_params
efi/libstub: Add a helper function to split 64-bit values
efi/libstub: Move pr_efi/pr_efi_err into efi namespace
efi/x86: Use efi_err for error messages
efi/gop: Use efi_err for error messages
efi/tpm: Use efi_err for error messages
efi/libstub: Upgrade ignored dtb= argument message to error
efi/x86: Move command-line initrd loading to efi_main
efi/libstub: Unify initrd loading across architectures
efi/x86: Support builtin command line
efi/libstub: Check return value of efi_parse_options
efi/libstub: Fix mixed mode boot issue after macro refactor
Joe Perches (1):
efi/libstub: Correct comment typos
arch/x86/include/asm/efi.h | 19 +++-
drivers/firmware/efi/libstub/Makefile | 1 +
drivers/firmware/efi/libstub/arm32-stub.c | 12 +--
drivers/firmware/efi/libstub/arm64-stub.c | 14 +--
drivers/firmware/efi/libstub/efi-stub-helper.c | 65 ++++++++++---
drivers/firmware/efi/libstub/efi-stub.c | 63 +++++++------
drivers/firmware/efi/libstub/efistub.h | 48 ++++------
drivers/firmware/efi/libstub/fdt.c | 16 ++--
drivers/firmware/efi/libstub/file.c | 12 +--
drivers/firmware/efi/libstub/gop.c | 16 ++--
drivers/firmware/efi/libstub/pci.c | 10 +-
drivers/firmware/efi/libstub/relocate.c | 4 +-
drivers/firmware/efi/libstub/secureboot.c | 4 +-
drivers/firmware/efi/libstub/tpm.c | 2 +-
drivers/firmware/efi/libstub/x86-stub.c | 122 +++++++++++--------------
15 files changed, 216 insertions(+), 192 deletions(-)
next reply other threads:[~2020-05-08 18:02 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-08 18:01 Ard Biesheuvel [this message]
2020-05-08 18:01 ` [PATCH 01/15] efi/x86: Use correct size for boot_params Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 02/15] efi/libstub: Add a helper function to split 64-bit values Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 03/15] efi/libstub: Move pr_efi/pr_efi_err into efi namespace Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 04/15] efi/x86: Use efi_err for error messages Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 05/15] efi/gop: " Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 06/15] efi/tpm: " Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 07/15] efi/libstub: Upgrade ignored dtb= argument message to error Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 08/15] efi/x86: Move command-line initrd loading to efi_main Ard Biesheuvel
2020-05-27 22:30 ` Williams, Dan J
2020-05-27 22:46 ` Arvind Sankar
2020-05-27 22:56 ` Dan Williams
2020-05-27 23:02 ` Arvind Sankar
2020-05-27 23:13 ` Dan Williams
2020-05-27 23:26 ` [PATCH] efi/x86: Don't blow away existing initrd Arvind Sankar
2020-05-28 6:34 ` Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 09/15] efi/libstub: Unify initrd loading across architectures Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 10/15] efi/x86: Support builtin command line Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 11/15] efi/libstub: Check return value of efi_parse_options Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 12/15] efi/libstub: Fix mixed mode boot issue after macro refactor Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 13/15] efi/libstub/x86: Work around LLVM ELF quirk build regression Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 14/15] efi/libstub: Make efi_printk() input argument const char* Ard Biesheuvel
2020-05-08 18:01 ` [PATCH 15/15] efi/libstub: Correct comment typos Ard Biesheuvel
2020-05-14 9:05 ` [GIT PULL 00/15] More EFI changes for v5.8 Ard Biesheuvel
2020-05-20 7:20 ` Ard Biesheuvel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200508180157.1816-1-ardb@kernel.org \
--to=ardb@kernel.org \
--cc=arnd@arndb.de \
--cc=joe@perches.com \
--cc=linux-efi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=mingo@kernel.org \
--cc=nivedita@alum.mit.edu \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome