From: Matt Helsley <mhelsley@vmware.com>
To: Josh Poimboeuf <jpoimboe@redhat.com>
Cc: <linux-kernel@vger.kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Steven Rostedt <rostedt@goodmis.org>
Subject: Re: [RFC][PATCH 1/3] objtool: Rename rela to reloc
Date: Thu, 28 May 2020 09:00:00 -0700 [thread overview]
Message-ID: <20200528160000.GV9040@rlwimi.vmware.com> (raw)
In-Reply-To: <20200528140444.lgphq6sicir2l7ws@treble>
On Thu, May 28, 2020 at 09:04:44AM -0500, Josh Poimboeuf wrote:
> On Wed, May 27, 2020 at 09:42:31AM -0700, Matt Helsley wrote:
> > Before supporting additional relocation types rename the relevant
> > types and functions from "rela" to "reloc". This work can largely
> > be done with the following regex:
> >
> > Notable exceptions include gelf_* library calls and
> > standard/expected section names which still use "rela" because
> > they encode the type of relocation expected. Also, keep "rela"
> > in the struct because it encodes a specify type of relocation
>
> Missing regex?
I briefly looked into it and went with a manual process instead. I can
try and work backwards to reproduce the patch with a regex though.
> BTW it would be really nice if the regex were exact if possible, for
> stable backporting reasons.
Agreed. I'll see what I can come up with and put it and any necessary
details in the commit message for the next posting.
Cheers,
-Matt Helsley
next prev parent reply other threads:[~2020-05-28 16:00 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-27 16:42 [RFC][PATCH 0/3] objtool: Support implicit addend relocations Matt Helsley
2020-05-27 16:42 ` [RFC][PATCH 1/3] objtool: Rename rela to reloc Matt Helsley
2020-05-28 14:04 ` Josh Poimboeuf
2020-05-28 16:00 ` Matt Helsley [this message]
2020-05-27 16:42 ` [RFC][PATCH 2/3] objtool: Find relocation base section using sh_info Matt Helsley
2020-05-28 14:09 ` Josh Poimboeuf
2020-05-28 16:02 ` Matt Helsley
2020-05-28 17:00 ` Josh Poimboeuf
2020-05-28 19:15 ` Matt Helsley
2020-05-27 16:42 ` [RFC][PATCH 3/3] objtool: Add support for relocations without addends Matt Helsley
2020-05-28 14:24 ` Josh Poimboeuf
2020-05-28 16:05 ` Matt Helsley
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200528160000.GV9040@rlwimi.vmware.com \
--to=mhelsley@vmware.com \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome