mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Valentin Schneider <valentin.schneider@arm.com>
Cc: linux-kernel@vger.kernel.org, mingo@kernel.org,
	vincent.guittot@linaro.org, dietmar.eggemann@arm.com,
	morten.rasmussen@arm.com
Subject: Re: [PATCH v3 3/7] sched/topology: Verify SD_* flags setup when sched_debug is on
Date: Thu, 2 Jul 2020 16:20:42 +0200	[thread overview]
Message-ID: <20200702142042.GI4817@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20200701190656.10126-4-valentin.schneider@arm.com>

On Wed, Jul 01, 2020 at 08:06:51PM +0100, Valentin Schneider wrote:

> @@ -29,6 +29,7 @@ static int sched_domain_debug_one(struct sched_domain *sd, int cpu, int level,
>  				  struct cpumask *groupmask)
>  {
>  	struct sched_group *group = sd->groups;
> +	int flags = sd->flags;

	unsigned long flags = sd->flags;

>  
>  	cpumask_clear(groupmask);
>  
> @@ -43,6 +44,22 @@ static int sched_domain_debug_one(struct sched_domain *sd, int cpu, int level,
>  		printk(KERN_ERR "ERROR: domain->groups does not contain CPU%d\n", cpu);
>  	}
>  
> +	for (; flags; flags &= flags - 1) {
> +		unsigned int idx = __ffs(flags);

	for_each_set_bit(idx, &flags, SD_MAX_BIT) {

Yes, it's a bit yuck, but far more readable imo.

> +		unsigned int flag = BIT(idx);
> +		unsigned int meta_flags = sd_flag_debug[idx].meta_flags;
> +
> +		if ((meta_flags & SDF_SHARED_CHILD) && sd->child &&
> +		    !(sd->child->flags & flag))
> +			printk(KERN_ERR "ERROR: flag %s set here but not in child\n",
> +			       sd_flag_debug[idx].name);
> +
> +		if ((meta_flags & SDF_SHARED_PARENT) && sd->parent &&
> +		    !(sd->parent->flags & flag))
> +			printk(KERN_ERR "ERROR: flag %s set here but not in parent\n",
> +			       sd_flag_debug[idx].name);
> +	}
> +
>  	printk(KERN_DEBUG "%*s groups:", level + 1, "");
>  	do {
>  		if (!group) {
> -- 
> 2.27.0
> 

  reply	other threads:[~2020-07-02 14:20 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-01 19:06 [PATCH v3 0/7] sched: Instrument sched domain flags Valentin Schneider
2020-07-01 19:06 ` [PATCH v3 1/7] sched/topology: Split out SD_* flags declaration to its own file Valentin Schneider
2020-07-01 19:06 ` [PATCH v3 2/7] sched/topology: Define and assign sched_domain flag metadata Valentin Schneider
2020-07-02 12:15   ` Quentin Perret
2020-07-02 14:31     ` Valentin Schneider
2020-07-02 15:45       ` Quentin Perret
2020-07-02 16:25         ` Valentin Schneider
2020-07-02 16:37           ` Quentin Perret
2020-07-02 16:49             ` Valentin Schneider
2020-07-01 19:06 ` [PATCH v3 3/7] sched/topology: Verify SD_* flags setup when sched_debug is on Valentin Schneider
2020-07-02 14:20   ` Peter Zijlstra [this message]
2020-07-02 14:32     ` Valentin Schneider
2020-07-01 19:06 ` [PATCH v3 4/7] arm, sched/topology: Remove SD_SHARE_POWERDOMAIN Valentin Schneider
2020-07-02 16:44   ` Dietmar Eggemann
2020-07-02 18:46     ` Valentin Schneider
2020-07-01 19:06 ` [PATCH v3 5/7] sched/topology: Add more flags to the SD degeneration mask Valentin Schneider
2020-07-02 18:28   ` Dietmar Eggemann
2020-07-01 19:06 ` [PATCH v3 6/7] sched/topology: Introduce SD metaflag for flags needing > 1 groups Valentin Schneider
2020-07-02 18:29   ` Dietmar Eggemann
2020-07-02 18:46     ` Valentin Schneider
2020-07-13 12:39   ` Peter Zijlstra
2020-07-13 13:25     ` Valentin Schneider
2020-07-01 19:06 ` [PATCH v3 7/7] sched/topology: Use prebuilt SD flag degeneration mask Valentin Schneider
2020-07-13 12:55   ` Peter Zijlstra
2020-07-13 13:28     ` Valentin Schneider
2020-07-13 13:43       ` Peter Zijlstra
2020-07-13 13:52         ` Valentin Schneider

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200702142042.GI4817@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=dietmar.eggemann@arm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=morten.rasmussen@arm.com \
    --cc=valentin.schneider@arm.com \
    --cc=vincent.guittot@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome