mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrzej Hajda <a.hajda@samsung.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Andrzej Hajda <a.hajda@samsung.com>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	Marek Szyprowski <m.szyprowski@samsung.com>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, andy.shevchenko@gmail.com,
	Mark Brown <broonie@kernel.org>,
	Russell King - ARM Linux <linux@armlinux.org.uk>,
	Neil Armstrong <narmstrong@baylibre.com>,
	Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
	Jonas Karlman <jonas@kwiboo.se>,
	Jernej Skrabec <jernej.skrabec@siol.net>,
	Daniel Vetter <daniel@ffwll.ch>,
	dri-devel@lists.freedesktop.org (open list:DRM DRIVERS)
Subject: [PATCH v8 0/5] driver core: add probe error check helper
Date: Fri, 10 Jul 2020 17:30:13 +0200	[thread overview]
Message-ID: <20200710153018.12226-1-a.hajda@samsung.com> (raw)
In-Reply-To: <CGME20200710153023eucas1p152c48e4208bff8c0ae9b8c734be45db2@eucas1p1.samsung.com>

Hi All,

Thanks for comments.

Changes since v7:
- improved commit message
- added R-Bs

Changes since v6:
- removed leftovers from old naming scheme in commit descritions,
- added R-Bs.

Changes since v5:
- removed patch adding macro, dev_err_probe(dev, PTR_ERR(ptr), ...) should be used instead,
- added dev_dbg logging in case of -EPROBE_DEFER,
- renamed functions and vars according to comments,
- extended docs,
- cosmetics.

Original message (with small adjustments):

Recently I took some time to re-check error handling in drivers probe code,
and I have noticed that number of incorrect resource acquisition error handling
increased and there are no other propositions which can cure the situation.

So I have decided to resend my old proposition of probe_err helper which should
simplify resource acquisition error handling, it also extend it with adding defer
probe reason to devices_deferred debugfs property, which should improve debugging
experience for developers/testers.

I have also added two patches showing usage and benefits of the helper.

My dirty/ad-hoc cocci scripts shows that this helper can be used in at least 2700 places
saving about 3500 lines of code.

Regards
Andrzej


Andrzej Hajda (5):
  driver core: add device probe log helper
  driver core: add deferring probe reason to devices_deferred property
  drm/bridge/sii8620: fix resource acquisition error handling
  drm/bridge: lvds-codec: simplify error handling
  coccinelle: add script looking for cases where probe__err can be used

 drivers/base/base.h                  |   3 +
 drivers/base/core.c                  |  46 +++++
 drivers/base/dd.c                    |  23 ++-
 drivers/gpu/drm/bridge/lvds-codec.c  |  10 +-
 drivers/gpu/drm/bridge/sil-sii8620.c |  21 +--
 include/linux/device.h               |   3 +
 probe_err.cocci                      | 247 +++++++++++++++++++++++++++
 7 files changed, 333 insertions(+), 20 deletions(-)
 create mode 100644 probe_err.cocci

-- 
2.17.1


       reply	other threads:[~2020-07-10 15:30 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20200710153023eucas1p152c48e4208bff8c0ae9b8c734be45db2@eucas1p1.samsung.com>
2020-07-10 15:30 ` Andrzej Hajda [this message]
     [not found]   ` <CGME20200710153023eucas1p1564ece8b49581616a5bfed978a5164f0@eucas1p1.samsung.com>
2020-07-10 15:30     ` [PATCH v8 1/5] driver core: add device probe log helper Andrzej Hajda
     [not found]   ` <CGME20200710153024eucas1p1b0686b4acce78838db93fddb3c23939c@eucas1p1.samsung.com>
2020-07-10 15:30     ` [PATCH v8 2/5] driver core: add deferring probe reason to devices_deferred property Andrzej Hajda
2020-07-10 17:15       ` Ruhl, Michael J
     [not found]   ` <CGME20200710153025eucas1p141ae47938b5f41c835759e7345f0e625@eucas1p1.samsung.com>
2020-07-10 15:30     ` [PATCH v8 3/5] drm/bridge/sii8620: fix resource acquisition error handling Andrzej Hajda
     [not found]   ` <CGME20200710153026eucas1p208e5850ddd9e7f376c4d56f892b05233@eucas1p2.samsung.com>
2020-07-10 15:30     ` [PATCH v8 4/5] drm/bridge: lvds-codec: simplify " Andrzej Hajda
     [not found]   ` <CGME20200710153027eucas1p1c893327b918e99a9b0cbd7b0a00af96b@eucas1p1.samsung.com>
2020-07-10 15:30     ` [PATCH v8 5/5] coccinelle: add script looking for cases where probe__err can be used Andrzej Hajda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200710153018.12226-1-a.hajda@samsung.com \
    --to=a.hajda@samsung.com \
    --cc=Laurent.pinchart@ideasonboard.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=b.zolnierkie@samsung.com \
    --cc=broonie@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=jernej.skrabec@siol.net \
    --cc=jonas@kwiboo.se \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=m.szyprowski@samsung.com \
    --cc=narmstrong@baylibre.com \
    --cc=rafael@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®