From: Steven Rostedt <rostedt@goodmis.org>
To: Sean Christopherson <sean.j.christopherson@intel.com>
Cc: Vitaly Kuznetsov <vkuznets@redhat.com>,
Wanpeng Li <wanpengli@tencent.com>,
Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Paolo Bonzini <pbonzini@redhat.com>
Subject: Re: [PATCH 6/7] KVM: x86: Use common definition for kvm_nested_vmexit tracepoint
Date: Tue, 21 Jul 2020 17:42:33 -0400 [thread overview]
Message-ID: <20200721174233.411fba7b@oasis.local.home> (raw)
In-Reply-To: <20200721193130.GH22083@linux.intel.com>
On Tue, 21 Jul 2020 12:31:30 -0700
Sean Christopherson <sean.j.christopherson@intel.com> wrote:
> +Steve
>
> Background: KVM has two tracepoints that effectively trace the same thing
> (VM-Exit vs. nested VM-Exit), but use completely different formatting and
> nomenclature for each of the existing tracepoints. I want to add a common
> macro to create the tracepoints so that they capture the exact same info
> and report it with the exact same format. But that means breaking the
> "ABI" for one of the tracepoints, e.g. trace-cmd barfs on the rename of
> exit_code to exit_reason.
Feel free to update it.
>
> Was there ever a verdict on whether or not tracepoints are considered ABI
> and thus must retain backwards compatibility?
>
> If not, what's the proper way to upstream changes to trace-cmd?
>
There's a kvm plugin in the libtraceevent code.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/tools/lib/traceevent/plugins/plugin_kvm.c
This overrides how the events are read. In the callback handler
(e.g. kvm_nested_vmexit_handle()), you can test if "rip" is there or
not. If it is not, you can do something different. For example:
struct tep_format_field *field;
field = tep_find_any_field(event, "rip");
if (field) {
tep_print_num_field(s, "rip %llx ", event, "rip", record, 1)
[..]
} else {
/* do something new */
}
You can test if fields exist and have the plugins do different things
depending on the format of an event. This is what I do in case an event
changes in the future.
-- Steve
next prev parent reply other threads:[~2020-07-21 21:42 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-07-18 6:38 [PATCH 0/7] KVM: x86: Tracepoint improvements and fixes Sean Christopherson
2020-07-18 6:38 ` [PATCH 1/7] KVM: x86: Add RIP to the kvm_entry, i.e. VM-Enter, tracepoint Sean Christopherson
2020-07-18 6:38 ` [PATCH 2/7] KVM: x86: Read guest RIP from within the kvm_nested_vmexit tracepoint Sean Christopherson
2020-07-18 6:38 ` [PATCH 3/7] KVM: VMX: Add a helper to test for a valid error code given an intr info Sean Christopherson
2020-07-18 6:38 ` [PATCH 4/7] KVM: x86: Add intr/vectoring info and error code to kvm_exit tracepoint Sean Christopherson
2020-07-18 6:38 ` [PATCH 5/7] KVM: x86: Add macro wrapper for defining " Sean Christopherson
2020-07-18 6:38 ` [PATCH 6/7] KVM: x86: Use common definition for kvm_nested_vmexit tracepoint Sean Christopherson
2020-07-20 16:52 ` Vitaly Kuznetsov
2020-07-21 0:27 ` Sean Christopherson
2020-07-21 13:59 ` Vitaly Kuznetsov
2020-07-21 19:31 ` Sean Christopherson
2020-07-21 21:42 ` Steven Rostedt [this message]
2020-08-12 18:10 ` Sean Christopherson
2020-07-18 6:38 ` [PATCH 7/7] KVM: nVMX: Read EXIT_QUAL and INTR_INFO only when needed for nested exit Sean Christopherson
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200721174233.411fba7b@oasis.local.home \
--to=rostedt@goodmis.org \
--cc=jmattson@google.com \
--cc=joro@8bytes.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=sean.j.christopherson@intel.com \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®