From: Christian Brauner <christian.brauner@ubuntu.com>
To: Kirill Tkhai <ktkhai@virtuozzo.com>
Cc: viro@zeniv.linux.org.uk, adobriyan@gmail.com,
davem@davemloft.net, ebiederm@xmission.com,
akpm@linux-foundation.org, areber@redhat.com, serge@hallyn.com,
linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH 02/23] uts: Use generic ns_common::count
Date: Thu, 30 Jul 2020 16:30:35 +0200 [thread overview]
Message-ID: <20200730143035.c4c2n3g25wm5u7bk@wittgenstein> (raw)
In-Reply-To: <159611037120.535980.13731766189011538488.stgit@localhost.localdomain>
On Thu, Jul 30, 2020 at 02:59:31PM +0300, Kirill Tkhai wrote:
> Convert uts namespace to use generic counter instead of kref.
>
> Signed-off-by: Kirill Tkhai <ktkhai@virtuozzo.com>
> ---
(sidenote: given that kref is implemented on top of refcount_t I wonder
whether we shouldn't just slowly convert all places where kref is used
to refcount_t and remove the kref api.)
Looks good!
Acked-by: Christian Brauner <christian.brauner@ubuntu.com>
> include/linux/utsname.h | 9 ++++-----
> init/version.c | 2 +-
> kernel/utsname.c | 7 ++-----
> 3 files changed, 7 insertions(+), 11 deletions(-)
>
> diff --git a/include/linux/utsname.h b/include/linux/utsname.h
> index 44429d9142ca..2b1737c9b244 100644
> --- a/include/linux/utsname.h
> +++ b/include/linux/utsname.h
> @@ -4,7 +4,6 @@
>
>
> #include <linux/sched.h>
> -#include <linux/kref.h>
> #include <linux/nsproxy.h>
> #include <linux/ns_common.h>
> #include <linux/err.h>
> @@ -22,7 +21,6 @@ struct user_namespace;
> extern struct user_namespace init_user_ns;
>
> struct uts_namespace {
> - struct kref kref;
> struct new_utsname name;
> struct user_namespace *user_ns;
> struct ucounts *ucounts;
> @@ -33,16 +31,17 @@ extern struct uts_namespace init_uts_ns;
> #ifdef CONFIG_UTS_NS
> static inline void get_uts_ns(struct uts_namespace *ns)
> {
> - kref_get(&ns->kref);
> + refcount_inc(&ns->ns.count);
> }
>
> extern struct uts_namespace *copy_utsname(unsigned long flags,
> struct user_namespace *user_ns, struct uts_namespace *old_ns);
> -extern void free_uts_ns(struct kref *kref);
> +extern void free_uts_ns(struct uts_namespace *ns);
>
> static inline void put_uts_ns(struct uts_namespace *ns)
> {
> - kref_put(&ns->kref, free_uts_ns);
> + if (refcount_dec_and_test(&ns->ns.count))
> + free_uts_ns(ns);
> }
>
> void uts_ns_init(void);
> diff --git a/init/version.c b/init/version.c
> index cba341161b58..80d2b7566b39 100644
> --- a/init/version.c
> +++ b/init/version.c
> @@ -25,7 +25,7 @@ int version_string(LINUX_VERSION_CODE);
> #endif
>
> struct uts_namespace init_uts_ns = {
> - .kref = KREF_INIT(2),
> + .ns.count = REFCOUNT_INIT(2),
> .name = {
> .sysname = UTS_SYSNAME,
> .nodename = UTS_NODENAME,
> diff --git a/kernel/utsname.c b/kernel/utsname.c
> index e488d0e2ab45..b1ac3ca870f2 100644
> --- a/kernel/utsname.c
> +++ b/kernel/utsname.c
> @@ -33,7 +33,7 @@ static struct uts_namespace *create_uts_ns(void)
>
> uts_ns = kmem_cache_alloc(uts_ns_cache, GFP_KERNEL);
> if (uts_ns)
> - kref_init(&uts_ns->kref);
> + refcount_set(&uts_ns->ns.count, 1);
> return uts_ns;
> }
>
> @@ -103,11 +103,8 @@ struct uts_namespace *copy_utsname(unsigned long flags,
> return new_ns;
> }
>
> -void free_uts_ns(struct kref *kref)
> +void free_uts_ns(struct uts_namespace *ns)
> {
> - struct uts_namespace *ns;
> -
> - ns = container_of(kref, struct uts_namespace, kref);
> dec_uts_namespaces(ns->ucounts);
> put_user_ns(ns->user_ns);
> ns_free_inum(&ns->ns);
>
>
next prev parent reply other threads:[~2020-07-30 14:30 UTC|newest]
Thread overview: 76+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-07-30 11:59 [PATCH 00/23] proc: Introduce /proc/namespaces/ directory to expose namespaces lineary Kirill Tkhai
2020-07-30 11:59 ` [PATCH 01/23] ns: Add common refcount into ns_common add use it as counter for net_ns Kirill Tkhai
2020-07-30 13:35 ` Christian Brauner
2020-07-30 14:07 ` Kirill Tkhai
2020-07-30 15:59 ` Christian Brauner
2020-07-30 14:30 ` Christian Brauner
2020-07-30 14:34 ` Kirill Tkhai
2020-07-30 14:39 ` Christian Brauner
2020-07-30 11:59 ` [PATCH 02/23] uts: Use generic ns_common::count Kirill Tkhai
2020-07-30 14:30 ` Christian Brauner [this message]
2020-07-30 11:59 ` [PATCH 03/23] ipc: " Kirill Tkhai
2020-07-30 14:32 ` Christian Brauner
2020-07-30 11:59 ` [PATCH 04/23] pid: " Kirill Tkhai
2020-07-30 14:37 ` Christian Brauner
2020-07-30 11:59 ` [PATCH 05/23] user: " Kirill Tkhai
2020-07-30 14:46 ` Christian Brauner
2020-07-30 11:59 ` [PATCH 06/23] mnt: " Kirill Tkhai
2020-07-30 14:49 ` Christian Brauner
2020-07-30 11:59 ` [PATCH 07/23] cgroup: " Kirill Tkhai
2020-07-30 14:50 ` Christian Brauner
2020-07-30 12:00 ` [PATCH 08/23] time: " Kirill Tkhai
2020-07-30 14:52 ` Christian Brauner
2020-07-30 12:00 ` [PATCH 09/23] ns: Introduce ns_idr to be able to iterate all allocated namespaces in the system Kirill Tkhai
2020-07-30 12:23 ` Matthew Wilcox
2020-07-30 13:32 ` Kirill Tkhai
2020-07-30 13:56 ` Matthew Wilcox
2020-07-30 14:12 ` Kirill Tkhai
2020-07-30 14:15 ` Matthew Wilcox
2020-07-30 14:20 ` Kirill Tkhai
2020-07-30 12:00 ` [PATCH 10/23] fs: Rename fs/proc/namespaces.c into fs/proc/task_namespaces.c Kirill Tkhai
2020-07-30 12:00 ` [PATCH 11/23] fs: Add /proc/namespaces/ directory Kirill Tkhai
2020-07-30 12:18 ` Alexey Dobriyan
2020-07-30 13:22 ` Kirill Tkhai
2020-07-30 13:26 ` Christian Brauner
2020-07-30 14:30 ` Kirill Tkhai
2020-07-30 20:47 ` kernel test robot
2020-07-30 22:20 ` kernel test robot
2020-08-05 8:17 ` kernel test robot
2020-08-05 8:17 ` [RFC PATCH] fs: namespaces_dentry_operations can be static kernel test robot
2020-07-30 12:00 ` [PATCH 12/23] user: Free user_ns one RCU grace period after final counter put Kirill Tkhai
2020-07-30 12:00 ` [PATCH 13/23] user: Add user namespaces into ns_idr Kirill Tkhai
2020-07-30 12:00 ` [PATCH 14/23] net: Add net " Kirill Tkhai
2020-07-30 12:00 ` [PATCH 15/23] pid: Eextract child_reaper check from pidns_for_children_get() Kirill Tkhai
2020-07-30 12:00 ` [PATCH 16/23] proc_ns_operations: Add can_get method Kirill Tkhai
2020-07-30 12:00 ` [PATCH 17/23] pid: Add pid namespaces into ns_idr Kirill Tkhai
2020-07-30 12:00 ` [PATCH 18/23] uts: Free uts namespace one RCU grace period after final counter put Kirill Tkhai
2020-07-30 12:01 ` [PATCH 19/23] uts: Add uts namespaces into ns_idr Kirill Tkhai
2020-07-30 12:01 ` [PATCH 20/23] ipc: Add ipc " Kirill Tkhai
2020-07-30 12:01 ` [PATCH 21/23] mnt: Add mount " Kirill Tkhai
2020-07-30 12:01 ` [PATCH 22/23] cgroup: Add cgroup " Kirill Tkhai
2020-07-30 12:01 ` [PATCH 23/23] time: Add time " Kirill Tkhai
2020-07-30 13:08 ` [PATCH 00/23] proc: Introduce /proc/namespaces/ directory to expose namespaces lineary Christian Brauner
2020-07-30 13:38 ` Christian Brauner
2020-07-30 14:34 ` Eric W. Biederman
2020-07-30 14:42 ` Christian Brauner
2020-07-30 15:01 ` Kirill Tkhai
2020-07-30 22:13 ` Eric W. Biederman
2020-07-31 8:48 ` Pavel Tikhomirov
2020-08-03 10:03 ` Kirill Tkhai
2020-08-03 10:51 ` Alexey Dobriyan
2020-08-06 8:05 ` Andrei Vagin
2020-08-07 8:47 ` Kirill Tkhai
2020-08-10 17:34 ` Andrei Vagin
2020-08-11 10:23 ` Kirill Tkhai
2020-08-12 17:53 ` Andrei Vagin
2020-08-13 8:12 ` Kirill Tkhai
2020-08-14 1:16 ` Andrei Vagin
2020-08-14 15:11 ` Kirill Tkhai
2020-08-14 19:21 ` Andrei Vagin
2020-08-17 14:05 ` Kirill Tkhai
2020-08-17 15:48 ` Eric W. Biederman
2020-08-17 17:47 ` Christian Brauner
2020-08-17 18:53 ` Eric W. Biederman
2020-08-04 5:43 ` Andrei Vagin
2020-08-04 12:11 ` Pavel Tikhomirov
2020-08-04 14:47 ` Kirill Tkhai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200730143035.c4c2n3g25wm5u7bk@wittgenstein \
--to=christian.brauner@ubuntu.com \
--cc=adobriyan@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=areber@redhat.com \
--cc=davem@davemloft.net \
--cc=ebiederm@xmission.com \
--cc=ktkhai@virtuozzo.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=serge@hallyn.com \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®