From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.3 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS, USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 64C32C433DF for ; Tue, 25 Aug 2020 17:10:06 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 44947207BC for ; Tue, 25 Aug 2020 17:10:06 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726541AbgHYRKE (ORCPT ); Tue, 25 Aug 2020 13:10:04 -0400 Received: from mx2.suse.de ([195.135.220.15]:33576 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726104AbgHYRKB (ORCPT ); Tue, 25 Aug 2020 13:10:01 -0400 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.221.27]) by mx2.suse.de (Postfix) with ESMTP id 02E9AAE68; Tue, 25 Aug 2020 17:10:28 +0000 (UTC) Date: Tue, 25 Aug 2020 19:09:55 +0200 From: Petr Mladek To: John Ogness Cc: Sergey Senozhatsky , Sergey Senozhatsky , Steven Rostedt , Linus Torvalds , Greg Kroah-Hartman , Thomas Gleixner , Peter Zijlstra , Andrea Parri , Paul McKenney , kexec@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH v2 1/7][next] printk: ringbuffer: rename DESC_COMMITTED_MASK flag Message-ID: <20200825170955.GX4353@alley> References: <20200824103538.31446-1-john.ogness@linutronix.de> <20200824103538.31446-2-john.ogness@linutronix.de> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20200824103538.31446-2-john.ogness@linutronix.de> User-Agent: Mutt/1.10.1 (2018-07-13) Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon 2020-08-24 12:41:32, John Ogness wrote: > The flag DESC_COMMITTED_MASK has a much longer name compared to the > other state flags and also is in past tense form, rather than in > command form. Rename the flag to DESC_COMMIT_MASK in order to match > the other state flags. I am not a native speaker. But the command form sounds a bit misleading to me. I see that the new name will make more sense after adding the state "FINAL". But "FINAL" will not be a command form either. I am fine with the change but I would prefer a better commit message. What about something like? "A comming support for continuous lines will allow to reopen records with DESC_COMMITTED_MASK set. As a result, the flag will not longer describe the final committed state. Rename it to DESC_COMMIT_MASK as a preparation step." With the updated commit message: Reviewed-by: Petr Mladek Best Regards, Petr