From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.2 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE, SPF_PASS,USER_AGENT_SANE_1 autolearn=ham autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id B2595C43464 for ; Fri, 18 Sep 2020 08:59:27 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 7641A21D43 for ; Fri, 18 Sep 2020 08:59:27 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726298AbgIRI70 (ORCPT ); Fri, 18 Sep 2020 04:59:26 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:33098 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726109AbgIRI7Z (ORCPT ); Fri, 18 Sep 2020 04:59:25 -0400 Received: from theia.8bytes.org (8bytes.org [IPv6:2a01:238:4383:600:38bc:a715:4b6d:a889]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 21174C06174A for ; Fri, 18 Sep 2020 01:59:25 -0700 (PDT) Received: by theia.8bytes.org (Postfix, from userid 1000) id C2B2D396; Fri, 18 Sep 2020 10:59:23 +0200 (CEST) Date: Fri, 18 Sep 2020 10:59:22 +0200 From: Joerg Roedel To: Alex Dewar Cc: iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] iommu: fsl_pamu: Replace use of kzfree with kfree_sensitive Message-ID: <20200918085922.GK31590@8bytes.org> References: <20200911135325.66156-1-alex.dewar90@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20200911135325.66156-1-alex.dewar90@gmail.com> User-Agent: Mutt/1.10.1 (2018-07-13) Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Sep 11, 2020 at 02:53:25PM +0100, Alex Dewar wrote: > kzfree() is effectively deprecated as of commit 453431a54934 ("mm, > treewide: rename kzfree() to kfree_sensitive()") and is now simply an > alias for kfree_sensitive(). So just replace it with kfree_sensitive(). > > Signed-off-by: Alex Dewar > --- > drivers/iommu/fsl_pamu.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Applied, thanks.