From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-9.7 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY, SPF_HELO_NONE,SPF_PASS,URIBL_BLOCKED autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 14E01C43464 for ; Fri, 18 Sep 2020 13:21:58 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id C34EF21D24 for ; Fri, 18 Sep 2020 13:21:57 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726776AbgIRNV4 (ORCPT ); Fri, 18 Sep 2020 09:21:56 -0400 Received: from vps0.lunn.ch ([185.16.172.187]:43334 "EHLO vps0.lunn.ch" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726121AbgIRNV4 (ORCPT ); Fri, 18 Sep 2020 09:21:56 -0400 Received: from andrew by vps0.lunn.ch with local (Exim 4.94) (envelope-from ) id 1kJGKh-00FElo-Rb; Fri, 18 Sep 2020 15:21:47 +0200 Date: Fri, 18 Sep 2020 15:21:47 +0200 From: Andrew Lunn To: Jisheng Zhang Cc: Heiner Kallweit , Russell King , "David S. Miller" , Jakub Kicinski , netdev@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH net-next] net: phy: realtek: enable ALDPS to save power for RTL8211F Message-ID: <20200918132147.GB3631014@lunn.ch> References: <20200918104756.557f9129@xhacker.debian> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20200918104756.557f9129@xhacker.debian> Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Sep 18, 2020 at 10:47:56AM +0800, Jisheng Zhang wrote: > Enable ALDPS function to save power when link down. Hi Jisheng It would be nice to give a hint what ALDPS means. It is not one of the standard acronyms i know of, so it could be Realtek specific. > > Signed-off-by: Jisheng Zhang > --- > drivers/net/phy/realtek.c | 8 ++++++++ > 1 file changed, 8 insertions(+) > > diff --git a/drivers/net/phy/realtek.c b/drivers/net/phy/realtek.c > index 95dbe5e8e1d8..961570186822 100644 > --- a/drivers/net/phy/realtek.c > +++ b/drivers/net/phy/realtek.c > @@ -39,6 +39,10 @@ > #define RTL8201F_ISR 0x1e > #define RTL8201F_IER 0x13 > > +#define RTL8211F_ALDPS_PLL_OFF BIT(1) > +#define RTL8211F_ALDPS_ENABLE BIT(2) > +#define RTL8211F_ALDPS_XTAL_OFF BIT(12) > + > #define RTL8366RB_POWER_SAVE 0x15 > #define RTL8366RB_POWER_SAVE_ON BIT(12) > > @@ -178,8 +182,12 @@ static int rtl8211f_config_init(struct phy_device *phydev) > { > struct device *dev = &phydev->mdio.dev; > u16 val_txdly, val_rxdly; > + u16 val; > int ret; > > + val = RTL8211F_ALDPS_ENABLE | RTL8211F_ALDPS_PLL_OFF | RTL8211F_ALDPS_XTAL_OFF; > + phy_modify_paged_changed(phydev, 0xa43, 0x18, val, val); Could we avoid some of these magic numbers? The datasheet seems to call 0x18 PHYCR1, etc. Andrew