From: Sean Christopherson <sean.j.christopherson@intel.com>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: Sean Christopherson <sean.j.christopherson@intel.com>,
Vitaly Kuznetsov <vkuznets@redhat.com>,
Wanpeng Li <wanpengli@tencent.com>,
Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH 0/4] KVM: VMX: Add helper+macros to do sec exec adjustment
Date: Wed, 23 Sep 2020 09:50:44 -0700 [thread overview]
Message-ID: <20200923165048.20486-1-sean.j.christopherson@intel.com> (raw)
Add a helper function and macro wrappers to consolidate code for adjusting
secondary execution controls based on guest CPUID. The adjustments are
effectively 10+ lines of copy+paste for each control, with slight tweaks
to account for annoying differences, e.g. XSAVES has additional checks.
Patches 1-3 are prep work to make INVPCID and RDTSCP align with the
"standard" nomenclature so that they don't require special casing.
Sean Christopherson (4):
KVM: VMX: Rename vmx_*_supported() helpers to cpu_has_vmx_*()
KVM: VMX: Unconditionally clear CPUID.INVPCID if !CPUID.PCID
KVM: VMX: Rename RDTSCP secondary exec control name to insert "ENABLE"
KVM: VMX: Add a helper and macros to reduce boilerplate for sec exec
ctls
arch/x86/include/asm/vmx.h | 2 +-
arch/x86/kvm/vmx/capabilities.h | 10 +-
arch/x86/kvm/vmx/nested.c | 4 +-
arch/x86/kvm/vmx/vmx.c | 150 +++++++-----------
.../selftests/kvm/include/x86_64/vmx.h | 2 +-
5 files changed, 64 insertions(+), 104 deletions(-)
--
2.28.0
next reply other threads:[~2020-09-23 16:51 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-23 16:50 Sean Christopherson [this message]
2020-09-23 16:50 ` [PATCH 1/4] KVM: VMX: Rename vmx_*_supported() helpers to cpu_has_vmx_*() Sean Christopherson
2020-09-23 16:50 ` [PATCH 2/4] KVM: VMX: Unconditionally clear CPUID.INVPCID if !CPUID.PCID Sean Christopherson
2020-09-23 17:15 ` Jim Mattson
2020-09-23 17:25 ` Paolo Bonzini
2020-09-23 16:50 ` [PATCH 3/4] KVM: VMX: Rename RDTSCP secondary exec control name to insert "ENABLE" Sean Christopherson
2020-09-23 17:10 ` Jim Mattson
2020-09-23 16:50 ` [PATCH 4/4] KVM: VMX: Add a helper and macros to reduce boilerplate for sec exec ctls Sean Christopherson
2020-09-23 17:20 ` Paolo Bonzini
2020-09-23 17:22 ` Sean Christopherson
2020-09-23 17:25 ` Paolo Bonzini
[not found] ` <20200925003011.21016-1-sean.j.christopherson@intel.com>
2020-09-25 20:21 ` [PATCH v2 " Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200923165048.20486-1-sean.j.christopherson@intel.com \
--to=sean.j.christopherson@intel.com \
--cc=jmattson@google.com \
--cc=joro@8bytes.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®