From: Sean Christopherson <sean.j.christopherson@intel.com>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: Sean Christopherson <sean.j.christopherson@intel.com>,
Vitaly Kuznetsov <vkuznets@redhat.com>,
Wanpeng Li <wanpengli@tencent.com>,
Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH v2 0/7] KVM: x86: Tracepoint improvements and fixes
Date: Wed, 23 Sep 2020 13:13:42 -0700 [thread overview]
Message-ID: <20200923201349.16097-1-sean.j.christopherson@intel.com> (raw)
Various improvements and fixes for the kvm_entry, kvm_exit and
kvm_nested_vmexit tracepoints.
1. Capture the guest's RIP during kvm_entry for obvious reasons.
2. Extend kvm_exit to report the same info as kvm_nested_vmexit, and
macrofy its definition to reuse it verbatim for nested exits.
3. Stop passing in params to kvm_nested_vmexit, and instead use the
same approach (and now code) as kvm_exit where the tracepoint uses a
dedicated kvm_x86_ops hook to retrieve the info.
4. Stop reading GUEST_RIP, EXIT_QUAL, INTR_INFO, and ERROR_CODE on
every VM-Exit from L2 (some of this comes in #3). This saves ~100
cycles (150+ with retpolines) on VM-Exits from L2 that are handled
by L0, e.g. hardware interrupts.
As noted by Vitaly, these changes break trace-cmd[*]. I hereby pinky
swear that, if this series is merged, I will send patches to update
trace-cmd.
[*] git://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git
v2:
- Fixed some goofs in the changelogs.
- Rebased to kvm/queue, commit e1ba1a15af73 ("KVM: SVM: Enable INVPCID
feature on AMD").
Sean Christopherson (7):
KVM: x86: Add RIP to the kvm_entry, i.e. VM-Enter, tracepoint
KVM: x86: Read guest RIP from within the kvm_nested_vmexit tracepoint
KVM: VMX: Add a helper to test for a valid error code given an intr
info
KVM: x86: Add intr/vectoring info and error code to kvm_exit
tracepoint
KVM: x86: Add macro wrapper for defining kvm_exit tracepoint
KVM: x86: Use common definition for kvm_nested_vmexit tracepoint
KVM: nVMX: Read EXIT_QUAL and INTR_INFO only when needed for nested
exit
arch/x86/include/asm/kvm_host.h | 7 ++-
arch/x86/kvm/svm/svm.c | 16 ++---
arch/x86/kvm/trace.h | 107 +++++++++++++-------------------
arch/x86/kvm/vmx/nested.c | 14 ++---
arch/x86/kvm/vmx/vmcs.h | 7 +++
arch/x86/kvm/vmx/vmx.c | 18 +++++-
arch/x86/kvm/x86.c | 2 +-
7 files changed, 86 insertions(+), 85 deletions(-)
--
2.28.0
next reply other threads:[~2020-09-23 20:14 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-23 20:13 Sean Christopherson [this message]
2020-09-23 20:13 ` [PATCH v2 1/7] KVM: x86: Add RIP to the kvm_entry, i.e. VM-Enter, tracepoint Sean Christopherson
2020-09-23 20:13 ` [PATCH v2 3/7] KVM: VMX: Add a helper to test for a valid error code given an intr info Sean Christopherson
2020-09-23 20:13 ` [PATCH v2 4/7] KVM: x86: Add intr/vectoring info and error code to kvm_exit tracepoint Sean Christopherson
2020-09-23 20:13 ` [PATCH v2 7/7] KVM: nVMX: Read EXIT_QUAL and INTR_INFO only when needed for nested exit Sean Christopherson
2020-09-25 21:46 ` [PATCH v2 0/7] KVM: x86: Tracepoint improvements and fixes Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200923201349.16097-1-sean.j.christopherson@intel.com \
--to=sean.j.christopherson@intel.com \
--cc=jmattson@google.com \
--cc=joro@8bytes.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®