From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.7 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE, SPF_PASS,UNPARSEABLE_RELAY autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 3DFA5C433DF for ; Sun, 18 Oct 2020 12:41:10 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 0404E208B8 for ; Sun, 18 Oct 2020 12:41:09 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726404AbgJRMlI (ORCPT ); Sun, 18 Oct 2020 08:41:08 -0400 Received: from out30-44.freemail.mail.aliyun.com ([115.124.30.44]:58668 "EHLO out30-44.freemail.mail.aliyun.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1725776AbgJRMlI (ORCPT ); Sun, 18 Oct 2020 08:41:08 -0400 X-Alimail-AntiSpam: AC=PASS;BC=-1|-1;BR=01201311R211e4;CH=green;DM=||false|;DS=||;FP=0|-1|-1|-1|0|-1|-1|-1;HT=e01e04423;MF=richard.weiyang@linux.alibaba.com;NM=1;PH=DS;RN=9;SR=0;TI=SMTPD_---0UCMqU.1_1603024864; Received: from localhost(mailfrom:richard.weiyang@linux.alibaba.com fp:SMTPD_---0UCMqU.1_1603024864) by smtp.aliyun-inc.com(127.0.0.1); Sun, 18 Oct 2020 20:41:05 +0800 Date: Sun, 18 Oct 2020 20:41:04 +0800 From: Wei Yang To: David Hildenbrand Cc: Wei Yang , linux-kernel@vger.kernel.org, linux-mm@kvack.org, virtualization@lists.linux-foundation.org, Andrew Morton , "Michael S . Tsirkin" , Jason Wang , Pankaj Gupta Subject: Re: [PATCH v1 20/29] virtio-mem: nb_sb_per_mb and subblock_size are specific to Sub Block Mode (SBM) Message-ID: <20201018124104.GD50506@L-31X9LVDL-1304> Reply-To: Wei Yang References: <20201012125323.17509-1-david@redhat.com> <20201012125323.17509-21-david@redhat.com> <20201016085319.GD44269@L-31X9LVDL-1304.local> <7b55ffe1-95fc-1e71-ea6b-82bd0a98a6b4@redhat.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <7b55ffe1-95fc-1e71-ea6b-82bd0a98a6b4@redhat.com> Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Oct 16, 2020 at 03:17:06PM +0200, David Hildenbrand wrote: >On 16.10.20 10:53, Wei Yang wrote: >> On Mon, Oct 12, 2020 at 02:53:14PM +0200, David Hildenbrand wrote: >>> Let's rename to "sbs_per_mb" and "sb_size" and move accordingly. >>> >>> Cc: "Michael S. Tsirkin" >>> Cc: Jason Wang >>> Cc: Pankaj Gupta >>> Signed-off-by: David Hildenbrand >> >> One trivial suggestion, could we move this patch close the data structure >> movement patch? >> >> I know this would be some work, since you have changed some of the code logic. >> This would take you some time to rebase. > >You mean after patch #17 ? Yes > >I guess I can move patch #18 (prereq) a little further up (e.g., after >patch #15). Guess moving it in front of #19 shouldn't be too hard. > >Will give it a try - if it takes too much effort, I'll leave it like this. > Not a big deal, while it will make the change more intact to me. This is a big patch set to me. In case it could be split into two parts, like bug fix/logic improvement and BBM implementation, that would be more friendly to review. >Thanks! > >-- >Thanks, > >David / dhildenb -- Wei Yang Help you, Help me