mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Nathan Chancellor <natechancellor@gmail.com>
To: Arnd Bergmann <arnd@kernel.org>
Cc: Christoph Hellwig <hch@infradead.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Tejun Heo <tj@kernel.org>,
	Alexander Viro <viro@zeniv.linux.org.uk>,
	Arnd Bergmann <arnd@arndb.de>,
	Nick Desaulniers <ndesaulniers@google.com>,
	linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	clang-built-linux@googlegroups.com
Subject: Re: [PATCH v3] seq_file: fix clang warning for NULL pointer arithmetic
Date: Tue, 27 Oct 2020 23:51:32 -0700	[thread overview]
Message-ID: <20201028065132.GA4099162@ubuntu-m3-large-x86> (raw)
In-Reply-To: <20201027221916.463235-1-arnd@kernel.org>

On Tue, Oct 27, 2020 at 11:18:24PM +0100, Arnd Bergmann wrote:
> From: Arnd Bergmann <arnd@arndb.de>
> 
> Clang points out that adding something to NULL is notallowed
                                                    not allowed
> in standard C:
> 
> fs/kernfs/file.c:127:15: warning: performing pointer arithmetic on a
> null pointer has undefined behavior [-Wnull-pointer-arithmetic]
>                 return NULL + !*ppos;
>                        ~~~~ ^
> fs/seq_file.c:529:14: warning: performing pointer arithmetic on a
> null pointer has undefined behavior [-Wnull-pointer-arithmetic]
>         return NULL + (*pos == 0);
> 
> Rephrase the code to be extra explicit about the valid, giving

                                                   valid what?

> them named SEQ_OPEN_EOF and SEQ_OPEN_SINGLE definitions.
> The instance in kernfs was copied from single_start, so fix both
> at once.
> 
> Fixes: 1da177e4c3f4 ("Linux-2.6.12-rc2")
> Fixes: c2b19daf6760 ("sysfs, kernfs: prepare read path for kernfs")
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>

Aside from the minor nits in the commit message, this should keep the
same behavior while eliminating the warning and making it a little
easier to understand.

Reviewed-by: Nathan Chancellor <natechancellor@gmail.com>

> ---
> v2: add the named macros after Christoph Hellwig pointed out
> that my original logic was too ugly.
> Suggestions for better names welcome
> 
> v3: don't overload the NULL return, avoid ?: operator
> ---
>  fs/kernfs/file.c         | 9 ++++++---
>  fs/seq_file.c            | 5 ++++-
>  include/linux/seq_file.h | 2 ++
>  3 files changed, 12 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/kernfs/file.c b/fs/kernfs/file.c
> index f277d023ebcd..5a5adb03c6df 100644
> --- a/fs/kernfs/file.c
> +++ b/fs/kernfs/file.c
> @@ -121,10 +121,13 @@ static void *kernfs_seq_start(struct seq_file *sf, loff_t *ppos)
>  		return next;
>  	} else {
>  		/*
> -		 * The same behavior and code as single_open().  Returns
> -		 * !NULL if pos is at the beginning; otherwise, NULL.
> +		 * The same behavior and code as single_open().  Continues
> +		 * if pos is at the beginning; otherwise, NULL.
>  		 */
> -		return NULL + !*ppos;
> +		if (*ppos)
> +			return NULL;
> +
> +		return SEQ_OPEN_SINGLE;
>  	}
>  }
>  
> diff --git a/fs/seq_file.c b/fs/seq_file.c
> index 31219c1db17d..6b467d769501 100644
> --- a/fs/seq_file.c
> +++ b/fs/seq_file.c
> @@ -526,7 +526,10 @@ EXPORT_SYMBOL(seq_dentry);
>  
>  static void *single_start(struct seq_file *p, loff_t *pos)
>  {
> -	return NULL + (*pos == 0);
> +	if (*pos)
> +	       return NULL;
> +
> +	return SEQ_OPEN_SINGLE;
>  }
>  
>  static void *single_next(struct seq_file *p, void *v, loff_t *pos)
> diff --git a/include/linux/seq_file.h b/include/linux/seq_file.h
> index 813614d4b71f..eb344448d4da 100644
> --- a/include/linux/seq_file.h
> +++ b/include/linux/seq_file.h
> @@ -37,6 +37,8 @@ struct seq_operations {
>  
>  #define SEQ_SKIP 1
>  
> +#define SEQ_OPEN_SINGLE	(void *)1
> +
>  /**
>   * seq_has_overflowed - check if the buffer has overflowed
>   * @m: the seq_file handle
> -- 
> 2.27.0
> 

      parent reply	other threads:[~2020-10-28 22:27 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-27 22:18 Arnd Bergmann
2020-10-28  6:23 ` Christoph Hellwig
2020-10-28  6:51 ` Nathan Chancellor [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201028065132.GA4099162@ubuntu-m3-large-x86 \
    --to=natechancellor@gmail.com \
    --cc=arnd@arndb.de \
    --cc=arnd@kernel.org \
    --cc=clang-built-linux@googlegroups.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@infradead.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ndesaulniers@google.com \
    --cc=tj@kernel.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®