From: James Morse <james.morse@arm.com>
To: x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Fenghua Yu <fenghua.yu@intel.com>,
Reinette Chatre <reinette.chatre@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
James Morse <james.morse@arm.com>,
shameerali.kolothum.thodi@huawei.com,
Jamie Iles <jamie@nuviainc.com>,
D Scott Phillips OS <scott@os.amperecomputing.com>,
lcherian@marvell.com
Subject: [PATCH v5 08/24] x86/resctrl: Add resctrl_arch_get_num_closid()
Date: Thu, 17 Jun 2021 17:58:04 +0000 [thread overview]
Message-ID: <20210617175820.24037-9-james.morse@arm.com> (raw)
In-Reply-To: <20210617175820.24037-1-james.morse@arm.com>
To initialise struct resctrl_schema's num_closid, schemata_list_create()
reaches into the architectures private structure to retrieve num_closid
from the struct rdt_hw_resource. The 'half the closids' behaviour
should be part of the filesystem parts of resctrl that are the same
on any architecture. struct resctrl_schema's num_closid should
include any correction for CDP.
Having two properties called num_closid is likely to be confusing when
they have different values.
Add a helper to read the resource's num_closid from the arch code. This
should return the number of closid that the resource supports, regardless
of whether CDP is in use. Once the CDP resources are merged,
schemata_list_create() can apply the correction itself.
Using a type with an obvious size for the arch helper means changing
the type of num_closid to u32, which matches the type already used by
struct rdtgroup.
reset_all_ctrls() does not use resctrl_arch_get_num_closid(), even
though it sets up a structure for modifying the hardware. This function
will be part of the architecture code, the maximum closid should be the
maximum value the hardware has, regardless of the way resctrl is using
it. All the uses of num_closid in core.c are naturally part of the
architecture specific code.
Reviewed-by: Jamie Iles <jamie@nuviainc.com>
Signed-off-by: James Morse <james.morse@arm.com>
---
Changes since v3:
* Fixed a spelling mistake, removed four spaces.
Changes since v2:
* Added comment in rdt_hw_resource
* Shuffled commit message,
Changes since v1:
* Rewrote commit message
* Whitespace fixes
* num_closid becomes u32 in all occurrences to reduce surprises
---
arch/x86/kernel/cpu/resctrl/core.c | 5 +++++
arch/x86/kernel/cpu/resctrl/internal.h | 8 ++++++--
arch/x86/kernel/cpu/resctrl/rdtgroup.c | 4 ++--
include/linux/resctrl.h | 6 +++++-
4 files changed, 18 insertions(+), 5 deletions(-)
diff --git a/arch/x86/kernel/cpu/resctrl/core.c b/arch/x86/kernel/cpu/resctrl/core.c
index c5b5c7227837..26e8d20cd072 100644
--- a/arch/x86/kernel/cpu/resctrl/core.c
+++ b/arch/x86/kernel/cpu/resctrl/core.c
@@ -450,6 +450,11 @@ struct rdt_domain *get_domain_from_cpu(int cpu, struct rdt_resource *r)
return NULL;
}
+u32 resctrl_arch_get_num_closid(struct rdt_resource *r)
+{
+ return resctrl_to_arch_res(r)->num_closid;
+}
+
void rdt_ctrl_update(void *arg)
{
struct msr_param *m = arg;
diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
index 74901c3db824..6c0d017dde0c 100644
--- a/arch/x86/kernel/cpu/resctrl/internal.h
+++ b/arch/x86/kernel/cpu/resctrl/internal.h
@@ -366,7 +366,11 @@ struct rdt_parse_data {
* struct rdt_hw_resource - arch private attributes of a resctrl resource
* @conf_type: The type that should be used when configuring. temporary
* @r_resctrl: Attributes of the resource used directly by resctrl.
- * @num_closid: Maximum number of closid this hardware can support.
+ * @num_closid: Maximum number of closid this hardware can support,
+ * regardless of CDP. This is exposed via
+ * resctrl_arch_get_num_closid() to avoid confusion
+ * with struct resctrl_schema's property of the same name,
+ * which has been corrected for features like CDP.
* @msr_base: Base MSR address for CBMs
* @msr_update: Function pointer to update QOS MSRs
* @mon_scale: cqm counter * mon_scale = occupancy in bytes
@@ -379,7 +383,7 @@ struct rdt_parse_data {
struct rdt_hw_resource {
enum resctrl_conf_type conf_type;
struct rdt_resource r_resctrl;
- int num_closid;
+ u32 num_closid;
unsigned int msr_base;
void (*msr_update) (struct rdt_domain *d, struct msr_param *m,
struct rdt_resource *r);
diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
index 2f29b7d7d602..09ffe9a4a32b 100644
--- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
+++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
@@ -104,7 +104,7 @@ int closids_supported(void)
static void closid_init(void)
{
struct resctrl_schema *s;
- int rdt_min_closid = 32;
+ u32 rdt_min_closid = 32;
/* Compute rdt_min_closid across all resources */
list_for_each_entry(s, &resctrl_schema_all, list)
@@ -2134,7 +2134,7 @@ static int schemata_list_create(void)
s->res = r;
s->conf_type = resctrl_to_arch_res(r)->conf_type;
- s->num_closid = resctrl_to_arch_res(r)->num_closid;
+ s->num_closid = resctrl_arch_get_num_closid(r);
INIT_LIST_HEAD(&s->list);
list_add(&s->list, &resctrl_schema_all);
diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
index 8ac1311fab66..f49b9817fd68 100644
--- a/include/linux/resctrl.h
+++ b/include/linux/resctrl.h
@@ -180,6 +180,10 @@ struct resctrl_schema {
struct list_head list;
enum resctrl_conf_type conf_type;
struct rdt_resource *res;
- int num_closid;
+ u32 num_closid;
};
+
+/* The number of closid supported by this resource regardless of CDP */
+u32 resctrl_arch_get_num_closid(struct rdt_resource *r);
+
#endif /* _RESCTRL_H */
--
2.30.2
next prev parent reply other threads:[~2021-06-17 17:59 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-06-17 17:57 [PATCH v5 00/24] x86/resctrl: Merge the CDP resources James Morse
2021-06-17 17:57 ` [PATCH v5 01/24] x86/resctrl: Split struct rdt_resource James Morse
2021-06-17 17:57 ` [PATCH v5 02/24] x86/resctrl: Split struct rdt_domain James Morse
2021-06-17 17:57 ` [PATCH v5 03/24] x86/resctrl: Add a separate schema list for resctrl James Morse
2021-06-17 17:58 ` [PATCH v5 04/24] x86/resctrl: Pass the schema in info dir's private pointer James Morse
2021-06-17 17:58 ` [PATCH v5 05/24] x86/resctrl: Label the resources with their configuration type James Morse
2021-06-17 17:58 ` [PATCH v5 06/24] x86/resctrl: Walk the resctrl schema list instead of an arch list James Morse
2021-06-17 17:58 ` [PATCH v5 07/24] x86/resctrl: Store the effective num_closid in the schema James Morse
2021-06-17 17:58 ` James Morse [this message]
2021-06-17 17:58 ` [PATCH v5 09/24] x86/resctrl: Pass the schema to resctrl filesystem functions James Morse
2021-06-17 17:58 ` [PATCH v5 10/24] x86/resctrl: Swizzle rdt_resource and resctrl_schema in pseudo_lock_region James Morse
2021-06-17 17:58 ` [PATCH v5 11/24] x86/resctrl: Add a helper to read/set the CDP configuration James Morse
2021-06-17 17:58 ` [PATCH v5 12/24] x86/resctrl: Move the schemata names into struct resctrl_schema James Morse
2021-06-17 17:58 ` [PATCH v5 13/24] x86/resctrl: Group staged configuration into a separate struct James Morse
2021-06-17 17:58 ` [PATCH v5 14/24] x86/resctrl: Allow different CODE/DATA configurations to be staged James Morse
2021-06-17 17:58 ` [PATCH v5 15/24] x86/resctrl: Rename update_domains() resctrl_arch_update_domains() James Morse
2021-06-17 17:58 ` [PATCH v5 16/24] x86/resctrl: Add a helper to read a closid's configuration James Morse
2021-06-17 17:58 ` [PATCH v5 17/24] x86/resctrl: Pass configuration type to resctrl_arch_get_config() James Morse
2021-06-17 17:58 ` [PATCH v5 18/24] x86/resctrl: Make ctrlval arrays the same size James Morse
2021-06-17 17:58 ` [PATCH v5 19/24] x86/resctrl: Apply offset correction when config is staged James Morse
2021-06-17 17:58 ` [PATCH v5 20/24] x86/resctrl: Calculate the index from the configuration type James Morse
2021-06-17 17:58 ` [PATCH v5 21/24] x86/resctrl: Merge the ctrl_val arrays James Morse
2021-06-17 17:58 ` [PATCH v5 22/24] x86/resctrl: Remove rdt_cdp_peer_get() James Morse
2021-06-17 17:58 ` [PATCH v5 23/24] x86/resctrl: Expand resctrl_arch_update_domains()'s msr_param range James Morse
2021-06-17 17:58 ` [PATCH v5 24/24] x86/resctrl: Merge the CDP resources James Morse
2021-06-21 20:42 ` [PATCH v5 00/24] " Reinette Chatre
2021-06-22 15:47 ` Babu Moger
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20210617175820.24037-9-james.morse@arm.com \
--to=james.morse@arm.com \
--cc=Babu.Moger@amd.com \
--cc=bp@alien8.de \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=jamie@nuviainc.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=reinette.chatre@intel.com \
--cc=scott@os.amperecomputing.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®