From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.2 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS, USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 5965DC48BE5 for ; Wed, 23 Jun 2021 14:19:10 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 2F1A66101D for ; Wed, 23 Jun 2021 14:19:10 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S231201AbhFWOV0 (ORCPT ); Wed, 23 Jun 2021 10:21:26 -0400 Received: from netrider.rowland.org ([192.131.102.5]:49737 "HELO netrider.rowland.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with SMTP id S230498AbhFWOVZ (ORCPT ); Wed, 23 Jun 2021 10:21:25 -0400 Received: (qmail 493616 invoked by uid 1000); 23 Jun 2021 10:19:07 -0400 Date: Wed, 23 Jun 2021 10:19:07 -0400 From: Alan Stern To: Claudiu.Beznea@microchip.com Cc: gregkh@linuxfoundation.org, Nicolas.Ferre@microchip.com, alexandre.belloni@bootlin.com, Ludovic.Desroches@microchip.com, Cristian.Birsan@microchip.com, linux-usb@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] usb: host: ohci-at91: suspend/resume ports after/before OHCI accesses Message-ID: <20210623141907.GC491169@rowland.harvard.edu> References: <20210609121027.70951-1-claudiu.beznea@microchip.com> <20210609230735.GA1861855@rowland.harvard.edu> <0621eaba-db4d-a174-1b15-535e804b52ac@microchip.com> <20210623135915.GB491169@rowland.harvard.edu> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.10.1 (2018-07-13) Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jun 23, 2021 at 02:09:16PM +0000, Claudiu.Beznea@microchip.com wrote: > On 23.06.2021 16:59, Alan Stern wrote: > > One thing you might consider changing: The name of the > > ohci_at91_port_suspend routine is misleading. It doesn't really > > handle suspending the port; instead it handles the clocks that drive > > the entire OHCI controller. Right? > > It does both as far as I can tell at the moment. But the name suggests that it only handles suspending a port. That's misleading. And the way it is used in the SetPortFeature(USB_PORT_FEAT_SUSPEND) case in ohci_at91_hub_control is just plain wrong. It won't merely suspend a single port; it will disable the entire OHCI controller. Alan Stern