From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-5.2 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_NONE, URIBL_BLOCKED,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 84EFCC4338F for ; Fri, 13 Aug 2021 19:55:29 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 6C46C610CF for ; Fri, 13 Aug 2021 19:55:29 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S233986AbhHMTzy (ORCPT ); Fri, 13 Aug 2021 15:55:54 -0400 Received: from jabberwock.ucw.cz ([46.255.230.98]:52266 "EHLO jabberwock.ucw.cz" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S233716AbhHMTzv (ORCPT ); Fri, 13 Aug 2021 15:55:51 -0400 Received: by jabberwock.ucw.cz (Postfix, from userid 1017) id 8FCF81C0B76; Fri, 13 Aug 2021 21:55:23 +0200 (CEST) Date: Fri, 13 Aug 2021 21:55:23 +0200 From: Pavel Machek To: Greg Kroah-Hartman Cc: linux-kernel@vger.kernel.org, stable@vger.kernel.org, Daniel Borkmann , Andrii Nakryiko Subject: Re: [PATCH 5.10 04/19] bpf: Add _kernel suffix to internal lockdown_bpf_read Message-ID: <20210813195523.GA4577@duo.ucw.cz> References: <20210813150522.623322501@linuxfoundation.org> <20210813150522.774143311@linuxfoundation.org> MIME-Version: 1.0 Content-Type: multipart/signed; micalg=pgp-sha1; protocol="application/pgp-signature"; boundary="VbJkn9YxBvnuCH5J" Content-Disposition: inline In-Reply-To: <20210813150522.774143311@linuxfoundation.org> User-Agent: Mutt/1.10.1 (2018-07-13) Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org --VbJkn9YxBvnuCH5J Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Content-Transfer-Encoding: quoted-printable Hi! > From: Daniel Borkmann >=20 > commit 71330842ff93ae67a066c1fa68d75672527312fa upstream. >=20 > Rename LOCKDOWN_BPF_READ into LOCKDOWN_BPF_READ_KERNEL so we have naming > more consistent with a LOCKDOWN_BPF_WRITE_USER option that we are > adding. As far as I can tell, next bpf patch does not depend on this one and we don't need it in 5.10. (Likely same situation with 5.13). Best regards, Pavel --=20 http://www.livejournal.com/~pavelmachek --VbJkn9YxBvnuCH5J Content-Type: application/pgp-signature; name="signature.asc" -----BEGIN PGP SIGNATURE----- iF0EABECAB0WIQRPfPO7r0eAhk010v0w5/Bqldv68gUCYRbOKwAKCRAw5/Bqldv6 8rkbAKC8/UThc601ypMAptZLgZZZswLUzACghlIN4L2iQoOTHHEeyDKqsZPQnvE= =Yxs9 -----END PGP SIGNATURE----- --VbJkn9YxBvnuCH5J--