From: Steven Rostedt <rostedt@goodmis.org>
To: Chris Down <chris@chrisdown.name>
Cc: Arnd Bergmann <arnd@kernel.org>, Petr Mladek <pmladek@suse.com>,
Sergey Senozhatsky <senozhatsky@chromium.org>,
Andy Shevchenko <andy.shevchenko@gmail.com>,
Jessica Yu <jeyu@kernel.org>, Arnd Bergmann <arnd@arndb.de>,
John Ogness <john.ogness@linutronix.de>,
Nathan Chancellor <nathan@kernel.org>,
Nick Desaulniers <ndesaulniers@google.com>,
YueHaibing <yuehaibing@huawei.com>,
linux-kernel@vger.kernel.org, llvm@lists.linux.dev
Subject: Re: [PATCH] printk: avoid -Wsometimes-uninitialized warning
Date: Mon, 27 Sep 2021 12:21:38 -0400 [thread overview]
Message-ID: <20210927122138.56cb1d8e@oasis.local.home> (raw)
In-Reply-To: <YVHE1qclD6ZyjvvD@chrisdown.name>
On Mon, 27 Sep 2021 14:19:18 +0100
Chris Down <chris@chrisdown.name> wrote:
> Having IS_ENABLED and then an #ifdef seems to hurt code readability to me.
I agree.
Would this be a better solution?
-- Steve
diff --git a/kernel/printk/index.c b/kernel/printk/index.c
index d3709408debe..ce3a0c8c5770 100644
--- a/kernel/printk/index.c
+++ b/kernel/printk/index.c
@@ -26,10 +26,10 @@ static struct pi_entry *pi_get_entry(const struct module *mod, loff_t pos)
if (mod) {
entries = mod->printk_index_start;
nr_entries = mod->printk_index_size;
- }
+ } else
#endif
+ {
- if (!mod) {
/* vmlinux, comes from linker symbols */
entries = __start_printk_index;
nr_entries = __stop_printk_index - __start_printk_index;
next prev parent reply other threads:[~2021-09-27 16:21 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-09-27 12:49 Arnd Bergmann
2021-09-27 13:19 ` Chris Down
2021-09-27 13:28 ` Arnd Bergmann
2021-09-27 13:33 ` Chris Down
2021-09-27 13:38 ` Chris Down
2021-09-27 16:21 ` Steven Rostedt [this message]
2021-09-27 18:32 ` Arnd Bergmann
2021-09-27 21:58 ` Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20210927122138.56cb1d8e@oasis.local.home \
--to=rostedt@goodmis.org \
--cc=andy.shevchenko@gmail.com \
--cc=arnd@arndb.de \
--cc=arnd@kernel.org \
--cc=chris@chrisdown.name \
--cc=jeyu@kernel.org \
--cc=john.ogness@linutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=llvm@lists.linux.dev \
--cc=nathan@kernel.org \
--cc=ndesaulniers@google.com \
--cc=pmladek@suse.com \
--cc=senozhatsky@chromium.org \
--cc=yuehaibing@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®