From: Mark Rutland <mark.rutland@arm.com>
To: Pingfan Liu <kernelfans@gmail.com>
Cc: linux-kernel@vger.kernel.org,
Thomas Gleixner <tglx@linutronix.de>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will@kernel.org>, Marc Zyngier <maz@kernel.org>,
Joey Gouly <joey.gouly@arm.com>,
Sami Tolvanen <samitolvanen@google.com>,
Julien Thierry <julien.thierry@arm.com>,
Yuichi Ito <ito-yuichi@fujitsu.com>,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCHv2 3/5] kernel/irq: make irq_{enter,exit}() in handle_domain_irq() arch optional
Date: Tue, 28 Sep 2021 09:55:00 +0100 [thread overview]
Message-ID: <20210928085500.GC1924@C02TD0UTHF1T.local> (raw)
In-Reply-To: <20210924132837.45994-4-kernelfans@gmail.com>
On Fri, Sep 24, 2021 at 09:28:35PM +0800, Pingfan Liu wrote:
> handle_domain_irq() contains two major parts:
> -1. irq_enter()/irq_exit(), which serves as hooks for rcu and trace etc.
> -2. irq mapping and dispatching
>
> After the introduction of irqentry_enter()/irqentry_exit() and arch
> specific counterpart (e.g. arm64), roughly speaking, rcu_irq_enter() has
> already been called. Hence here comes requirement to move
> irq_enter/irq_exit out of handle_domain_irq(). And arches should handle
> about irq_enter_rcu()/irq_exit_rcu() by themself.
>
> Since there is still arches, which does not adopt irqentry_enter(), let
> irq_enter()/irq_exit() arch optional in handle_domain_irq().
The patch below looks good to me, but the commit message is a little
hard to follow. How about:
When an IRQ is taken, some accounting needs to be performed to enter
and exit IRQ context around the IRQ handler. Historically arch code
would leave this to the irqchip or core IRQ code, but these days we
want this to happen in exception entry code, and architectures such as
arm64 do this.
Currently handle_domain_irq() performs this entry/exit accounting, and
if used on an architecture where the entry code also does this, the
entry/exit accounting will be performed twice per IRQ. This is
problematic as core RCU code such as rcu_is_cpu_rrupt_from_idle()
depends on this happening once per IRQ, and will not detect quescent
periods correctly, leading to stall warnings.
As irqchip drivers which use handle_domain_irq() need to work on
architectures with or without their own entry/exit accounting, this
patch makes handle_domain_irq() conditionally perform the entry
accounting depending on a new HAVE_ARCH_IRQENTRY Kconfig symbol that
architectures can select if they perform this entry accounting
themselves.
For architectures which do not select the symbol. there should be no
functional change as a result of this patch.
With that commit message:
Reviewed-by: Mark Rutland <mark.rutland@arm.com>
Mark.
> Signed-off-by: Pingfan Liu <kernelfans@gmail.com>
> Cc: Thomas Gleixner <tglx@linutronix.de>
> Cc: Catalin Marinas <catalin.marinas@arm.com>
> Cc: Will Deacon <will@kernel.org>
> Cc: Mark Rutland <mark.rutland@arm.com>
> Cc: Marc Zyngier <maz@kernel.org>
> Cc: Joey Gouly <joey.gouly@arm.com>
> Cc: Sami Tolvanen <samitolvanen@google.com>
> Cc: Julien Thierry <julien.thierry@arm.com>
> Cc: Yuichi Ito <ito-yuichi@fujitsu.com>
> Cc: linux-arm-kernel@lists.infradead.org
> To: linux-kernel@vger.kernel.org
> ---
> kernel/irq/Kconfig | 3 +++
> kernel/irq/irqdesc.c | 4 ++++
> 2 files changed, 7 insertions(+)
>
> diff --git a/kernel/irq/Kconfig b/kernel/irq/Kconfig
> index fbc54c2a7f23..defa1db2d664 100644
> --- a/kernel/irq/Kconfig
> +++ b/kernel/irq/Kconfig
> @@ -100,6 +100,9 @@ config IRQ_MSI_IOMMU
> config HANDLE_DOMAIN_IRQ
> bool
>
> +config HAVE_ARCH_IRQENTRY
> + bool
> +
> config IRQ_TIMINGS
> bool
>
> diff --git a/kernel/irq/irqdesc.c b/kernel/irq/irqdesc.c
> index 4e3c29bb603c..fd5dd9d278b5 100644
> --- a/kernel/irq/irqdesc.c
> +++ b/kernel/irq/irqdesc.c
> @@ -693,7 +693,9 @@ int handle_domain_irq(struct irq_domain *domain,
> struct irq_desc *desc;
> int ret = 0;
>
> +#ifndef CONFIG_HAVE_ARCH_IRQENTRY
> irq_enter();
> +#endif
>
> /* The irqdomain code provides boundary checks */
> desc = irq_resolve_mapping(domain, hwirq);
> @@ -702,7 +704,9 @@ int handle_domain_irq(struct irq_domain *domain,
> else
> ret = -EINVAL;
>
> +#ifndef CONFIG_HAVE_ARCH_IRQENTRY
> irq_exit();
> +#endif
> set_irq_regs(old_regs);
> return ret;
> }
> --
> 2.31.1
>
next prev parent reply other threads:[~2021-09-28 8:55 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-09-24 13:28 [PATCHv2 0/5] arm64/irqentry: remove duplicate housekeeping of Pingfan Liu
2021-09-24 13:28 ` [PATCHv2 1/5] arm64/entry-common: push the judgement of nmi ahead Pingfan Liu
2021-09-24 17:53 ` Mark Rutland
2021-09-25 15:39 ` Pingfan Liu
2021-09-30 13:32 ` Mark Rutland
2021-10-08 4:01 ` Pingfan Liu
2021-10-08 14:55 ` Pingfan Liu
2021-10-08 17:25 ` Mark Rutland
2021-10-09 3:49 ` Pingfan Liu
2021-10-08 15:45 ` Paul E. McKenney
2021-10-09 4:14 ` Pingfan Liu
2021-09-24 13:28 ` [PATCHv2 2/5] irqchip/GICv3: expose handle_nmi() directly Pingfan Liu
2021-09-24 13:28 ` [PATCHv2 3/5] kernel/irq: make irq_{enter,exit}() in handle_domain_irq() arch optional Pingfan Liu
2021-09-28 8:55 ` Mark Rutland [this message]
2021-09-29 3:15 ` Pingfan Liu
2021-09-24 13:28 ` [PATCHv2 4/5] irqchip/GICv3: let gic_handle_irq() utilize irqentry on arm64 Pingfan Liu
2021-09-28 9:10 ` Mark Rutland
2021-09-29 3:10 ` Pingfan Liu
2021-09-29 7:20 ` Marc Zyngier
2021-09-29 8:27 ` Pingfan Liu
2021-09-29 9:23 ` Mark Rutland
2021-09-29 11:40 ` Pingfan Liu
2021-09-29 14:29 ` Pingfan Liu
2021-09-29 17:41 ` Mark Rutland
2021-09-24 13:28 ` [PATCHv2 5/5] irqchip/GICv3: make reschedule-ipi light weight Pingfan Liu
2021-09-29 7:24 ` Marc Zyngier
2021-09-29 8:32 ` Pingfan Liu
2021-09-24 17:36 ` [PATCHv2 0/5] arm64/irqentry: remove duplicate housekeeping of Mark Rutland
2021-09-24 22:59 ` Paul E. McKenney
2021-09-27 9:23 ` Mark Rutland
2021-09-28 0:09 ` Paul E. McKenney
2021-09-28 8:32 ` Mark Rutland
2021-09-28 8:35 ` Mark Rutland
2021-09-28 9:52 ` Sven Schnelle
2021-09-28 10:26 ` Mark Rutland
2021-09-28 13:55 ` Paul E. McKenney
2021-09-25 15:12 ` Pingfan Liu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20210928085500.GC1924@C02TD0UTHF1T.local \
--to=mark.rutland@arm.com \
--cc=catalin.marinas@arm.com \
--cc=ito-yuichi@fujitsu.com \
--cc=joey.gouly@arm.com \
--cc=julien.thierry@arm.com \
--cc=kernelfans@gmail.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maz@kernel.org \
--cc=samitolvanen@google.com \
--cc=tglx@linutronix.de \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®