From: Steven Rostedt <rostedt@goodmis.org>
To: linux-kernel@vger.kernel.org
Cc: Ingo Molnar <mingo@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Jiri Olsa <jolsa@kernel.org>
Subject: [for-next][PATCH 29/40] ftrace/samples: Add multi direct interface test module
Date: Fri, 22 Oct 2021 16:48:25 -0400 [thread overview]
Message-ID: <20211022204843.538283379@goodmis.org> (raw)
In-Reply-To: <20211022204756.099054287@goodmis.org>
From: Jiri Olsa <jolsa@redhat.com>
Adding simple module that uses multi direct interface:
register_ftrace_direct_multi
unregister_ftrace_direct_multi
The init function registers trampoline for 2 functions,
and exit function unregisters them.
Link: https://lkml.kernel.org/r/20211008091336.33616-9-jolsa@kernel.org
Signed-off-by: Jiri Olsa <jolsa@kernel.org>
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
---
samples/ftrace/Makefile | 1 +
samples/ftrace/ftrace-direct-multi.c | 52 ++++++++++++++++++++++++++++
2 files changed, 53 insertions(+)
create mode 100644 samples/ftrace/ftrace-direct-multi.c
diff --git a/samples/ftrace/Makefile b/samples/ftrace/Makefile
index 4ce896e10b2e..ab1d1c05c288 100644
--- a/samples/ftrace/Makefile
+++ b/samples/ftrace/Makefile
@@ -3,6 +3,7 @@
obj-$(CONFIG_SAMPLE_FTRACE_DIRECT) += ftrace-direct.o
obj-$(CONFIG_SAMPLE_FTRACE_DIRECT) += ftrace-direct-too.o
obj-$(CONFIG_SAMPLE_FTRACE_DIRECT) += ftrace-direct-modify.o
+obj-$(CONFIG_SAMPLE_FTRACE_DIRECT) += ftrace-direct-multi.o
CFLAGS_sample-trace-array.o := -I$(src)
obj-$(CONFIG_SAMPLE_TRACE_ARRAY) += sample-trace-array.o
diff --git a/samples/ftrace/ftrace-direct-multi.c b/samples/ftrace/ftrace-direct-multi.c
new file mode 100644
index 000000000000..2a5b1fb7ac14
--- /dev/null
+++ b/samples/ftrace/ftrace-direct-multi.c
@@ -0,0 +1,52 @@
+// SPDX-License-Identifier: GPL-2.0-only
+#include <linux/module.h>
+
+#include <linux/mm.h> /* for handle_mm_fault() */
+#include <linux/ftrace.h>
+#include <linux/sched/stat.h>
+
+void my_direct_func(unsigned long ip)
+{
+ trace_printk("ip %lx\n", ip);
+}
+
+extern void my_tramp(void *);
+
+asm (
+" .pushsection .text, \"ax\", @progbits\n"
+" .type my_tramp, @function\n"
+" .globl my_tramp\n"
+" my_tramp:"
+" pushq %rbp\n"
+" movq %rsp, %rbp\n"
+" pushq %rdi\n"
+" movq 8(%rbp), %rdi\n"
+" call my_direct_func\n"
+" popq %rdi\n"
+" leave\n"
+" ret\n"
+" .size my_tramp, .-my_tramp\n"
+" .popsection\n"
+);
+
+static struct ftrace_ops direct;
+
+static int __init ftrace_direct_multi_init(void)
+{
+ ftrace_set_filter_ip(&direct, (unsigned long) wake_up_process, 0, 0);
+ ftrace_set_filter_ip(&direct, (unsigned long) schedule, 0, 0);
+
+ return register_ftrace_direct_multi(&direct, (unsigned long) my_tramp);
+}
+
+static void __exit ftrace_direct_multi_exit(void)
+{
+ unregister_ftrace_direct_multi(&direct, (unsigned long) my_tramp);
+}
+
+module_init(ftrace_direct_multi_init);
+module_exit(ftrace_direct_multi_exit);
+
+MODULE_AUTHOR("Jiri Olsa");
+MODULE_DESCRIPTION("Example use case of using register_ftrace_direct_multi()");
+MODULE_LICENSE("GPL");
--
2.33.0
next prev parent reply other threads:[~2021-10-22 20:50 UTC|newest]
Thread overview: 41+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-10-22 20:47 [for-next][PATCH 00/40] tracing: Updates for 5.16 Steven Rostedt
2021-10-22 20:47 ` [for-next][PATCH 01/40] tracing: Initialize upper and lower vars in pid_list_refill_irq() Steven Rostedt
2021-10-22 20:47 ` [for-next][PATCH 02/40] tracefs: Have tracefs directories not set OTH permission bits by default Steven Rostedt
2021-10-22 20:47 ` [for-next][PATCH 03/40] tracing: Disable "other" permission bits in the tracefs files Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 04/40] ftrace: Cleanup ftrace_dyn_arch_init() Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 05/40] bootconfig: Allocate xbc_data inside xbc_init() Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 06/40] bootconfig: Add xbc_get_info() for the node information Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 07/40] tools/bootconfig: Run test script when build all Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 08/40] bootconfig: Rename xbc_destroy_all() to xbc_exit() Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 09/40] bootconfig: Split parse-tree part from xbc_init Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 10/40] bootconfig: Remove unused debug function Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 11/40] tools/bootconfig: Print all error message in stderr Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 12/40] bootconfig: Replace u16 and u32 with uint16_t and uint32_t Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 13/40] bootconfig: Cleanup dummy headers in tools/bootconfig Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 14/40] ftrace: Add unit test for removing trace function Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 15/40] tracing: in_irq() cleanup Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 16/40] tracing: Use linker magic instead of recasting ftrace_ops_list_func() Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 17/40] tracing/cfi: Fix cmp_entries_* functions signature mismatch Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 18/40] tracing: Reuse logic from perfs get_recursion_context() Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 19/40] tracing/perf: Add interrupt_context_level() helper Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 20/40] x86/ftrace: Remove extra orig rax move Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 21/40] x86/ftrace: Remove fault protection code in prepare_ftrace_return Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 22/40] ftrace/x86_64: Have function graph tracer depend on DYNAMIC_FTRACE Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 23/40] x86/ftrace: Make function graph use ftrace directly Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 24/40] tracing: Add trampoline/graph selftest Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 25/40] tracing: Fix selftest config check for function graph start up test Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 26/40] ftrace: Add ftrace_add_rec_direct function Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 27/40] ftrace: Add multi direct register/unregister interface Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 28/40] ftrace: Add multi direct modify interface Steven Rostedt
2021-10-22 20:48 ` Steven Rostedt [this message]
2021-10-22 20:48 ` [for-next][PATCH 30/40] ftrace/direct: Do not disable when switching direct callers Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 31/40] tracing: Explain the trace recursion transition bit better Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 32/40] tracing: use %ps format string to print symbols Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 33/40] kprobes: convert tests to kunit Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 34/40] x86/unwind: Compile kretprobe fixup code only if CONFIG_KRETPROBES=y Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 35/40] arm64: kprobes: Record frame pointer with kretprobe instance Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 36/40] arm64: kprobes: Make a frame pointer on __kretprobe_trampoline Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 37/40] arm64: Recover kretprobe modified return address in stacktrace Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 38/40] ARM: clang: Do not rely on lr register for stacktrace Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 39/40] ARM: kprobes: Make a frame pointer on __kretprobe_trampoline Steven Rostedt
2021-10-22 20:48 ` [for-next][PATCH 40/40] ARM: Recover kretprobe modified return address in stacktrace Steven Rostedt
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211022204843.538283379@goodmis.org \
--to=rostedt@goodmis.org \
--cc=akpm@linux-foundation.org \
--cc=jolsa@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®