mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Jani Nikula <jani.nikula@linux.intel.com>,
	Joonas Lahtinen <joonas.lahtinen@linux.intel.com>,
	Rodrigo Vivi <rodrigo.vivi@intel.com>,
	Zhenyu Wang <zhenyuw@linux.intel.com>,
	Zhi Wang <zhi.a.wang@intel.com>
Cc: Jason Gunthorpe <jgg@nvidia.com>,
	intel-gfx@lists.freedesktop.org,
	intel-gvt-dev@lists.freedesktop.org,
	dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: [PATCH 05/29] drm/i915/gvt: rename intel_vgpu_ops to intel_vgpu_mdev_ops
Date: Tue,  2 Nov 2021 08:05:37 +0100	[thread overview]
Message-ID: <20211102070601.155501-6-hch@lst.de> (raw)
In-Reply-To: <20211102070601.155501-1-hch@lst.de>

Free the intel_vgpu_ops symbol name for something that fits better.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 drivers/gpu/drm/i915/gvt/kvmgt.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/i915/gvt/kvmgt.c b/drivers/gpu/drm/i915/gvt/kvmgt.c
index 904f9a31bd3a9..80809866cf743 100644
--- a/drivers/gpu/drm/i915/gvt/kvmgt.c
+++ b/drivers/gpu/drm/i915/gvt/kvmgt.c
@@ -1748,7 +1748,7 @@ static const struct attribute_group *intel_vgpu_groups[] = {
 	NULL,
 };
 
-static struct mdev_parent_ops intel_vgpu_ops = {
+static struct mdev_parent_ops intel_vgpu_mdev_ops = {
 	.mdev_attr_groups       = intel_vgpu_groups,
 	.create			= intel_vgpu_create,
 	.remove			= intel_vgpu_remove,
@@ -1771,9 +1771,9 @@ static int kvmgt_host_init(struct device *dev, void *gvt, const void *ops)
 		return ret;
 
 	intel_gvt_ops = ops;
-	intel_vgpu_ops.supported_type_groups = gvt_vgpu_type_groups;
+	intel_vgpu_mdev_ops.supported_type_groups = gvt_vgpu_type_groups;
 
-	ret = mdev_register_device(dev, &intel_vgpu_ops);
+	ret = mdev_register_device(dev, &intel_vgpu_mdev_ops);
 	if (ret)
 		intel_gvt_cleanup_vgpu_type_groups((struct intel_gvt *)gvt);
 
-- 
2.30.2


  parent reply	other threads:[~2021-11-02  7:06 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-02  7:05 refactor the i915 GVT support and move to the modern mdev API v2 Christoph Hellwig
2021-11-02  7:05 ` [PATCH 01/29] drm/i915/gvt: undef TRACE_INCLUDE_FILE in i915_trace.h Christoph Hellwig
2021-11-02  7:05 ` [PATCH 02/29] drm/i915/gvt: integrate into the main Makefile Christoph Hellwig
2021-11-02 13:56   ` Jason Gunthorpe
2021-11-02 14:55   ` Jani Nikula
2021-11-04 12:30   ` Joonas Lahtinen
2021-11-04 12:32     ` Jason Gunthorpe
2021-11-09  7:56       ` Christoph Hellwig
2021-11-09  7:55     ` Christoph Hellwig
2021-11-02  7:05 ` [PATCH 03/29] drm/i915/gvt: remove module refcounting in intel_gvt_{,un}register_hypervisor Christoph Hellwig
2021-11-02 15:36   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 04/29] drm/i915/gvt: remove enum hypervisor_type Christoph Hellwig
2021-11-02 15:37   ` Jason Gunthorpe
2021-11-02  7:05 ` Christoph Hellwig [this message]
2021-11-02 15:37   ` [PATCH 05/29] drm/i915/gvt: rename intel_vgpu_ops to intel_vgpu_mdev_ops Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 06/29] drm/i915/gvt: move the gvt code into kvmgt.ko Christoph Hellwig
2021-11-02  7:05 ` [PATCH 07/29] drm/i915/gvt: remove intel_gvt_ops Christoph Hellwig
2021-11-02 16:03   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 08/29] drm/i915/gvt: remove the map_gfn_to_mfn and set_trap_area ops Christoph Hellwig
2021-11-02 16:04   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 09/29] drm/i915/gvt: remove the unused from_virt_to_mfn op Christoph Hellwig
2021-11-02 16:04   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 10/29] drm/i915/gvt: merge struct kvmgt_vdev into struct intel_vgpu Christoph Hellwig
2021-11-02 16:05   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 11/29] drm/i915/gvt: merge struct kvmgt_guest_info into strut intel_vgpu Christoph Hellwig
2021-11-02 16:06   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 12/29] drm/i915/gvt: remove vgpu->handle Christoph Hellwig
2021-11-02 16:07   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 13/29] drm/i915/gvt: devirtualize ->{read,write}_gpa Christoph Hellwig
2021-11-02 16:08   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 14/29] drm/i915/gvt: devirtualize ->{get,put}_vfio_device Christoph Hellwig
2021-11-02 16:12   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 15/29] drm/i915/gvt: devirtualize ->set_edid and ->set_opregion Christoph Hellwig
2021-11-02 16:12   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 16/29] drm/i915/gvt: devirtualize ->detach_vgpu Christoph Hellwig
2021-11-02 16:13   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 17/29] drm/i915/gvt: devirtualize ->inject_msi Christoph Hellwig
2021-11-02 16:13   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 18/29] drm/i915/gvt: devirtualize ->is_valid_gfn Christoph Hellwig
2021-11-02 16:14   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 19/29] drm/i915/gvt: devirtualize ->gfn_to_mfn Christoph Hellwig
2021-11-02 16:14   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 20/29] drm/i915/gvt: devirtualize ->{enable,disable}_page_track Christoph Hellwig
2021-11-02 16:15   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 21/29] drm/i915/gvt: devirtualize ->dma_{,un}map_guest_page Christoph Hellwig
2021-11-02 16:17   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 22/29] drm/i915/gvt: devirtualize dma_pin_guest_page Christoph Hellwig
2021-11-02 16:17   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 23/29] drm/i915/gvt: remove struct intel_gvt_mpt Christoph Hellwig
2021-11-02 16:18   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 24/29] drm/i915/gvt: remove the extra vfio_device refcounting for dmabufs Christoph Hellwig
2021-11-02 16:19   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 25/29] drm/i915/gvt: streamline intel_vgpu_create Christoph Hellwig
2021-11-02 16:19   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 26/29] drm/i915/gvt: pass a struct intel_vgpu to the vfio read/write helpers Christoph Hellwig
2021-11-02 16:20   ` Jason Gunthorpe
2021-11-02  7:05 ` [PATCH 27/29] drm/i915/gvt: remove kvmgt_guest_{init,exit} Christoph Hellwig
2021-11-02 16:36   ` Jason Gunthorpe
2021-11-02  7:06 ` [PATCH 28/29] drm/i915/gvt: convert to use vfio_register_group_dev() Christoph Hellwig
2021-11-02 16:41   ` Jason Gunthorpe
2021-11-03  6:40     ` Christoph Hellwig
2021-11-02  7:06 ` [PATCH 29/29] drm/i915/gvt: merge gvt.c into kvmgvt.c Christoph Hellwig
2021-11-02 16:42   ` Jason Gunthorpe
2021-11-04 12:59 ` refactor the i915 GVT support and move to the modern mdev API v2 Joonas Lahtinen
2021-11-04 14:51   ` Wang, Zhi A
2021-11-09  8:01     ` Christoph Hellwig
2021-11-09  7:59   ` Christoph Hellwig
2021-11-10 13:49     ` Joonas Lahtinen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211102070601.155501-6-hch@lst.de \
    --to=hch@lst.de \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=intel-gvt-dev@lists.freedesktop.org \
    --cc=jani.nikula@linux.intel.com \
    --cc=jgg@nvidia.com \
    --cc=joonas.lahtinen@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rodrigo.vivi@intel.com \
    --cc=zhenyuw@linux.intel.com \
    --cc=zhi.a.wang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®