mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Longpeng(Mike)" <longpeng2@huawei.com>
To: <andraprs@amazon.com>, <lexnv@amazon.com>, <alcioa@amazon.com>
Cc: <arei.gonglei@huawei.com>, <gregkh@linuxfoundation.org>,
	<kamal@canonical.com>, <pbonzini@redhat.com>,
	<sgarzare@redhat.com>, <stefanha@redhat.com>,
	<vkuznets@redhat.com>, <linux-kernel@vger.kernel.org>,
	<ne-devel-upstream@amazon.com>, Longpeng <longpeng2@huawei.com>
Subject: [PATCH v4 0/4] Merge contiguous physical memory regions
Date: Wed, 3 Nov 2021 22:00:31 +0800	[thread overview]
Message-ID: <20211103140035.2001-1-longpeng2@huawei.com> (raw)

From: Longpeng <longpeng2@huawei.com>

Hi guys,

This patchset try to merge the contiguous physical memory regions when
set user memory regions, you can see message in PATCH 1 for details.
Please review when you free, thank!

Changes v3 -> v4:
  Patch 1:
    - move "#include <linux/range.h>" according to the alphabetical order. [Andra]
    - rename several variables, parameters, structures and functions.  [Andra]
    - add missing "Context" in the comments.  [Andra]
    - some other changes to makes the code much neater.  [Andra]
  Patch 2:
    - add missing "Context" in the comments.  [Andra]
    - move the comment in ne_merge_phys_contig_memory_regions() before
      the "if (...)". [Andra]
  Patch 3:
    - Nitro enclaves -> Nitro Enclaves   [Andra]
    - check the return code of "ne_misc_dev_test_init()"  [Andra]
    - GPL-2.0-or-later -> GPL-2.0  [Andra]
  Patch 4:
    - "int expect_num" -> "unsigned long  expect_num"  [Andra]
    - rename several variables and structures  [Andra]
    - invoke "kunit_kfree" to free the "regions"  [Andra]

Changes v2 -> v3:
  Patch 1:
    - update the commit title and commit message.  [Andra]
    - use 'struct range' to instead of 'struct phys_mem_region'.  [Andra, Greg KH]
    - add comments before the function definition.  [Andra]
    - rename several variables, parameters and function.  [Andra]
  Patch 2:
    - update the commit title and commit message.  [Andra]
    - add comments before the function definition.  [Andra]
    - remove 'inline' attribute of ne_sanity_check_phys_mem_region. [Andra]
    - leave a blank line before return.  [Andra]
    - move sanity check in ne_merge_phys_contig_memory_regions to
      the beginning of the function.  [Andra]
    - double sanity checking after the merge of physical contiguous
      memory regions has been completed.  [Andra]
  Patch 3:
    - update the commit title and commit message.  [Andra]
    - use "misc_dev"/"misc device"/"MISC_DEV" to be more specific.  [Andra]
  Patch 4:
    - update the commit title and commit message.  [Andra]
    - align the fileds in 'struct phys_regions_test'.  [Andra]
    - rename 'phys_regions_testcases' to 'phys_regions_test_cases'.  [Andra]
    - add comments before each test cases.  [Andra]
    - initialize the variables in ne_misc_dev_test_merge_phys_contig_memory_regions.  [Andra]

Changes v1 -> v2:
  - update the commit message as Andra's suggestion  [Andra]
  - remove TODO completely in ne_set_user_memory_region_ioctl  [Andra]
  - extract the physical memory regions setup into individual
    function
  - add kunit tests  [Andra]


Longpeng (4):
  nitro_enclaves: Merge contiguous physical memory regions
  nitro_enclaves: Sanity check physical memory regions during merging
  nitro_enclaves: Add KUnit tests setup for the misc device
    functionality
  nitro_enclaves: Add KUnit tests for contiguous physical memory regions
    merging

 drivers/virt/nitro_enclaves/Kconfig            |   9 ++
 drivers/virt/nitro_enclaves/ne_misc_dev.c      | 173 ++++++++++++++++++-------
 drivers/virt/nitro_enclaves/ne_misc_dev_test.c | 156 ++++++++++++++++++++++
 3 files changed, 294 insertions(+), 44 deletions(-)
 create mode 100644 drivers/virt/nitro_enclaves/ne_misc_dev_test.c

-- 
1.8.3.1


             reply	other threads:[~2021-11-03 14:00 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-03 14:00 Longpeng(Mike) [this message]
2021-11-03 14:00 ` [PATCH v4 1/4] nitro_enclaves: " Longpeng(Mike)
2021-11-07 12:56   ` Paraschiv, Andra-Irina
2021-11-03 14:00 ` [PATCH v4 2/4] nitro_enclaves: Sanity check physical memory regions during merging Longpeng(Mike)
2021-11-07 13:07   ` Paraschiv, Andra-Irina
2021-11-03 14:00 ` [PATCH v4 3/4] nitro_enclaves: Add KUnit tests setup for the misc device functionality Longpeng(Mike)
2021-11-07 13:12   ` Paraschiv, Andra-Irina
2021-11-03 14:00 ` [PATCH v4 4/4] nitro_enclaves: Add KUnit tests for contiguous physical memory regions merging Longpeng(Mike)
2021-11-07 13:19   ` Paraschiv, Andra-Irina
2021-11-07 13:22     ` Longpeng (Mike, Cloud Infrastructure Service Product Dept.)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211103140035.2001-1-longpeng2@huawei.com \
    --to=longpeng2@huawei.com \
    --cc=alcioa@amazon.com \
    --cc=andraprs@amazon.com \
    --cc=arei.gonglei@huawei.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=kamal@canonical.com \
    --cc=lexnv@amazon.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ne-devel-upstream@amazon.com \
    --cc=pbonzini@redhat.com \
    --cc=sgarzare@redhat.com \
    --cc=stefanha@redhat.com \
    --cc=vkuznets@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome