mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@oracle.com>
To: davidcomponentone@gmail.com
Cc: zbr@ioremap.net, gregkh@linuxfoundation.org,
	ivan.zaentsev@wirenboard.ru, yangyingliang@huawei.com,
	unixbhaskar@gmail.com, yang.guang5@zte.com.cn,
	linux-kernel@vger.kernel.org, Zeal Robot <zealci@zte.com.cn>
Subject: Re: [PATCH] w1: w1_therm: use swap() to make code cleaner
Date: Thu, 4 Nov 2021 14:09:00 +0300	[thread overview]
Message-ID: <20211104110900.GB3164@kadam> (raw)
In-Reply-To: <20211104011123.1027524-1-yang.guang5@zte.com.cn>

On Thu, Nov 04, 2021 at 09:11:23AM +0800, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
> 
> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> ---

I'm confused by the signed-off-by list.  Are you Yang Guang and David is
your "English name"?  If so then this is fine, but if you are different
people then everyone who handles the patch needs to add their own
signed-off-by.


> @@ -1837,7 +1837,7 @@ static ssize_t alarms_store(struct device *device,
>  
>  	/* Reorder if required th and tl */
>  	if (tl > th) {
> -		tt = tl; tl = th; th = tt;
> +		swap(tl, th);
>  	}

Remove the curly {} braces as well because they are no longer required.

regards,
dan carpenter


  reply	other threads:[~2021-11-04 11:09 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-04  1:11 davidcomponentone
2021-11-04 11:09 ` Dan Carpenter [this message]
2021-11-05  7:32   ` [PATCH v2] " davidcomponentone
2021-11-05  7:37     ` Greg KH
2021-12-18  1:58 [PATCH] " davidcomponentone
2021-12-18  9:54 ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211104110900.GB3164@kadam \
    --to=dan.carpenter@oracle.com \
    --cc=davidcomponentone@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=ivan.zaentsev@wirenboard.ru \
    --cc=linux-kernel@vger.kernel.org \
    --cc=unixbhaskar@gmail.com \
    --cc=yang.guang5@zte.com.cn \
    --cc=yangyingliang@huawei.com \
    --cc=zbr@ioremap.net \
    --cc=zealci@zte.com.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®