mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: Xiaoming Ni <nixiaoming@huawei.com>
Cc: <linux-kernel@vger.kernel.org>, <mcgrof@kernel.org>,
	<viro@zeniv.linux.org.uk>, <ebiederm@xmission.com>,
	<keescook@chromium.org>, <jlayton@kernel.org>,
	<bfields@fieldses.org>, <yzaikin@google.com>,
	<wangle6@huawei.com>, Joe Perches <joe@perches.com>
Subject: Re: [PATCH] sysctl: Add a group of macro functions to initcall the sysctl table of each feature
Date: Mon, 6 Dec 2021 17:38:42 -0800	[thread overview]
Message-ID: <20211206173842.72c76379adbf8005bfa66e26@linux-foundation.org> (raw)
In-Reply-To: <20211207011320.100102-1-nixiaoming@huawei.com>

On Tue, 7 Dec 2021 09:13:20 +0800 Xiaoming Ni <nixiaoming@huawei.com> wrote:

> To avoid duplicated code, add a set of macro functions to initialize the
> sysctl table for each feature.
> 
> The system initialization process is as follows:
> 
> 	start_kernel () {
> 		...
> 		/* init proc and sysctl base,
> 		 * proc_root_init()-->proc_sys_init()-->sysctl_init_bases()
> 		 */
> 		proc_root_init(); /* init proc and sysctl base */
> 		...
> 		arch_call_rest_init();
> 	}
> 
> 	arch_call_rest_init()-->rest_init()-->kernel_init()
> 	kernel_init() {
> 		...
> 		kernel_init_freeable(); /* do all initcalls */
> 		...
> 		do_sysctl_args(); /* Process the sysctl parameter: sysctl.*= */
> 	}
> 
> 	kernel_init_freeable()--->do_basic_setup()-->do_initcalls()
> 	do_initcalls() {
> 		for (level = 0; level < ARRAY_SIZE(initcall_levels) - 1; level++) {
> 			do_initcall_level
> 	}
> 
> The sysctl interface of each subfeature should be registered after
> sysctl_init_bases() and before do_sysctl_args(). It seems that the sysctl
> interface does not depend on initcall_levels. To prevent the sysctl
> interface from being initialized before the feature itself. The
> lowest-level late_initcall() is used as the common sysctl interface
> registration level.

I'm not normally a fan of wrapping commonly-used code sequences into
magical macros, but this one does seem to make sense.

I wonder if it is possible to cook up a checkpatch rule to tell people
to henceforth use the magic macros rather than to open-code things in
the old way.  Sounds hard.

> --- a/fs/coredump.c
> +++ b/fs/coredump.c
> @@ -943,12 +943,7 @@ static struct ctl_table coredump_sysctls[] = {
>  	{ }
>  };
>  
> -static int __init init_fs_coredump_sysctls(void)
> -{
> -	register_sysctl_init("kernel", coredump_sysctls);
> -	return 0;
> -}
> -fs_initcall(init_fs_coredump_sysctls);
> +kernel_sysctl_initcall(coredump_sysctls);

But this and several like it are functional changes.

>  #endif /* CONFIG_SYSCTL */
>
> ...
>
> --- a/fs/inode.c
> +++ b/fs/inode.c
> @@ -132,12 +132,7 @@ static struct ctl_table inodes_sysctls[] = {
>  	{ }
>  };
>  
> -static int __init init_fs_inode_sysctls(void)
> -{
> -	register_sysctl_init("fs", inodes_sysctls);
> -	return 0;
> -}
> -early_initcall(init_fs_inode_sysctls);
> +fs_sysctl_initcall(inodes_sysctls);
>  #endif

Here's another, of many.

Someone made the decision to use early_initcall() here (why?) and this
patch switches it to late_initcall()!  Worrisome.  Each such stealth
conversion should be explained and justified, shouldn't it?



  reply	other threads:[~2021-12-07  1:38 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-07  1:13 Xiaoming Ni
2021-12-07  1:38 ` Andrew Morton [this message]
2021-12-07  1:50   ` Joe Perches
2021-12-07  6:25     ` Xiaoming Ni
2021-12-07  6:30     ` Julia Lawall
2021-12-07  3:09   ` Xiaoming Ni
2021-12-07 20:18   ` Luis Chamberlain
2021-12-07 21:08     ` Eric W. Biederman
2021-12-07 22:39       ` Luis Chamberlain
2021-12-08  2:10         ` Xiaoming Ni
2021-12-08  2:44           ` Luis Chamberlain
2021-12-08 12:34             ` Xiaoming Ni
2021-12-08 20:05               ` Luis Chamberlain
2021-12-10  8:58                 ` [PATCH v2] " Xiaoming Ni
2021-12-10 17:20                   ` Luis Chamberlain
2021-12-12  9:58                     ` Xiaoming Ni
2021-12-13  3:31                   ` [PATCH v3] " Xiaoming Ni
2021-12-19 21:32                     ` Luis Chamberlain
2021-12-13 16:04         ` [PATCH] " Eric W. Biederman
2021-12-13 21:29           ` Luis Chamberlain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20211206173842.72c76379adbf8005bfa66e26@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=bfields@fieldses.org \
    --cc=ebiederm@xmission.com \
    --cc=jlayton@kernel.org \
    --cc=joe@perches.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcgrof@kernel.org \
    --cc=nixiaoming@huawei.com \
    --cc=viro@zeniv.linux.org.uk \
    --cc=wangle6@huawei.com \
    --cc=yzaikin@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®