From: Ian Rogers <irogers@google.com>
To: Andi Kleen <ak@linux.intel.com>, Jiri Olsa <jolsa@redhat.com>,
Namhyung Kim <namhyung@kernel.org>,
John Garry <john.garry@huawei.com>,
Kajol Jain <kjain@linux.ibm.com>,
"Paul A . Clarke" <pc@us.ibm.com>,
Arnaldo Carvalho de Melo <acme@kernel.org>,
Riccardo Mancini <rickyman7@gmail.com>,
Kan Liang <kan.liang@linux.intel.com>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@redhat.com>,
Mark Rutland <mark.rutland@arm.com>,
Alexander Shishkin <alexander.shishkin@linux.intel.com>,
linux-perf-users@vger.kernel.org, linux-kernel@vger.kernel.org,
Vineet Singh <vineet.singh@intel.com>,
James Clark <james.clark@arm.com>,
Mathieu Poirier <mathieu.poirier@linaro.org>,
Suzuki K Poulose <suzuki.poulose@arm.com>,
Mike Leach <mike.leach@linaro.org>, Leo Yan <leo.yan@linaro.org>,
coresight@lists.linaro.org, linux-arm-kernel@lists.infradead.org
Cc: eranian@google.com, Ian Rogers <irogers@google.com>
Subject: [PATCH v2 40/48] perf test: Use perf_cpu_map__for_each_cpu
Date: Wed, 22 Dec 2021 23:45:33 -0800 [thread overview]
Message-ID: <20211223074541.3318938-41-irogers@google.com> (raw)
In-Reply-To: <20211223074541.3318938-1-irogers@google.com>
Clean up variable naming to make cpu and index clearer.
Signed-off-by: Ian Rogers <irogers@google.com>
---
tools/perf/tests/openat-syscall-all-cpus.c | 28 +++++++++++-----------
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/tools/perf/tests/openat-syscall-all-cpus.c b/tools/perf/tests/openat-syscall-all-cpus.c
index 544db0839b3b..ca0a50e92839 100644
--- a/tools/perf/tests/openat-syscall-all-cpus.c
+++ b/tools/perf/tests/openat-syscall-all-cpus.c
@@ -22,7 +22,7 @@
static int test__openat_syscall_event_on_all_cpus(struct test_suite *test __maybe_unused,
int subtest __maybe_unused)
{
- int err = -1, fd, cpu;
+ int err = -1, fd, idx, cpu;
struct perf_cpu_map *cpus;
struct evsel *evsel;
unsigned int nr_openat_calls = 111, i;
@@ -58,23 +58,23 @@ static int test__openat_syscall_event_on_all_cpus(struct test_suite *test __mayb
goto out_evsel_delete;
}
- for (cpu = 0; cpu < cpus->nr; ++cpu) {
- unsigned int ncalls = nr_openat_calls + cpu;
+ perf_cpu_map__for_each_cpu(cpu, idx, cpus) {
+ unsigned int ncalls = nr_openat_calls + idx;
/*
* XXX eventually lift this restriction in a way that
* keeps perf building on older glibc installations
* without CPU_ALLOC. 1024 cpus in 2010 still seems
* a reasonable upper limit tho :-)
*/
- if (cpus->map[cpu] >= CPU_SETSIZE) {
- pr_debug("Ignoring CPU %d\n", cpus->map[cpu]);
+ if (cpu >= CPU_SETSIZE) {
+ pr_debug("Ignoring CPU %d\n", cpu);
continue;
}
- CPU_SET(cpus->map[cpu], &cpu_set);
+ CPU_SET(cpu, &cpu_set);
if (sched_setaffinity(0, sizeof(cpu_set), &cpu_set) < 0) {
pr_debug("sched_setaffinity() failed on CPU %d: %s ",
- cpus->map[cpu],
+ cpu,
str_error_r(errno, sbuf, sizeof(sbuf)));
goto out_close_fd;
}
@@ -82,29 +82,29 @@ static int test__openat_syscall_event_on_all_cpus(struct test_suite *test __mayb
fd = openat(0, "/etc/passwd", O_RDONLY);
close(fd);
}
- CPU_CLR(cpus->map[cpu], &cpu_set);
+ CPU_CLR(cpu, &cpu_set);
}
evsel->core.cpus = perf_cpu_map__get(cpus);
err = 0;
- for (cpu = 0; cpu < cpus->nr; ++cpu) {
+ perf_cpu_map__for_each_cpu(cpu, idx, cpus) {
unsigned int expected;
- if (cpus->map[cpu] >= CPU_SETSIZE)
+ if (cpu >= CPU_SETSIZE)
continue;
- if (evsel__read_on_cpu(evsel, cpu, 0) < 0) {
+ if (evsel__read_on_cpu(evsel, idx, 0) < 0) {
pr_debug("evsel__read_on_cpu\n");
err = -1;
break;
}
- expected = nr_openat_calls + cpu;
- if (perf_counts(evsel->counts, cpu, 0)->val != expected) {
+ expected = nr_openat_calls + idx;
+ if (perf_counts(evsel->counts, idx, 0)->val != expected) {
pr_debug("evsel__read_on_cpu: expected to intercept %d calls on cpu %d, got %" PRIu64 "\n",
- expected, cpus->map[cpu], perf_counts(evsel->counts, cpu, 0)->val);
+ expected, cpu, perf_counts(evsel->counts, idx, 0)->val);
err = -1;
}
}
--
2.34.1.307.g9b7440fafd-goog
next prev parent reply other threads:[~2021-12-23 7:49 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-12-23 7:44 [PATCH v2 00/48] Refactor perf cpumap Ian Rogers
2021-12-23 7:44 ` [PATCH v2 01/48] libperf: Add comments to perf_cpu_map Ian Rogers
2021-12-23 7:44 ` [PATCH v2 02/48] perf stat: Add aggr creators that are passed a cpu Ian Rogers
2021-12-23 7:44 ` [PATCH v2 03/48] perf stat: Correct aggregation CPU map Ian Rogers
2021-12-23 7:44 ` [PATCH v2 04/48] perf stat: Switch aggregation to use for_each loop Ian Rogers
2021-12-23 7:44 ` [PATCH v2 05/48] perf stat: Switch to cpu version of cpu_map__get Ian Rogers
2021-12-23 7:44 ` [PATCH v2 06/48] perf cpumap: Switch cpu_map__build_map to cpu function Ian Rogers
2021-12-23 7:45 ` [PATCH v2 07/48] perf cpumap: Remove map+index get_socket Ian Rogers
2021-12-23 7:45 ` [PATCH v2 08/48] perf cpumap: Remove map+index get_die Ian Rogers
2021-12-23 7:45 ` [PATCH v2 09/48] perf cpumap: Remove map+index get_core Ian Rogers
2021-12-23 7:45 ` [PATCH v2 10/48] perf cpumap: Remove map+index get_node Ian Rogers
2021-12-23 7:45 ` [PATCH v2 11/48] perf cpumap: Add comments to aggr_cpu_id Ian Rogers
2021-12-23 7:45 ` [PATCH v2 12/48] perf cpumap: Remove unused cpu_map__socket Ian Rogers
2021-12-23 7:45 ` [PATCH v2 13/48] perf cpumap: Simplify equal function name Ian Rogers
2021-12-23 7:45 ` [PATCH v2 14/48] perf cpumap: Rename empty functions Ian Rogers
2021-12-23 7:45 ` [PATCH v2 15/48] perf cpumap: Document cpu__get_node and remove redundant function Ian Rogers
2021-12-23 7:45 ` [PATCH v2 16/48] perf cpumap: Remove map from function names that don't use a map Ian Rogers
2021-12-23 7:45 ` [PATCH v2 17/48] perf cpumap: Remove cpu_map__cpu, use libperf function Ian Rogers
2021-12-23 7:45 ` [PATCH v2 18/48] perf cpumap: Refactor cpu_map__build_map Ian Rogers
2021-12-23 7:45 ` [PATCH v2 19/48] perf cpumap: Rename cpu_map__get_X_aggr_by_cpu functions Ian Rogers
2021-12-23 7:45 ` [PATCH v2 20/48] perf cpumap: Move 'has' function to libperf Ian Rogers
2021-12-28 23:48 ` Namhyung Kim
2021-12-23 7:45 ` [PATCH v2 21/48] perf cpumap: Add some comments to cpu_aggr_map Ian Rogers
2021-12-23 7:45 ` [PATCH v2 22/48] perf cpumap: Trim the cpu_aggr_map Ian Rogers
2021-12-28 23:54 ` Namhyung Kim
2021-12-23 7:45 ` [PATCH v2 23/48] perf stat: Fix memory leak in check_per_pkg Ian Rogers
2021-12-23 7:45 ` [PATCH v2 24/48] perf cpumap: Add CPU to aggr_cpu_id Ian Rogers
2021-12-29 0:02 ` Namhyung Kim
2021-12-23 7:45 ` [PATCH v2 25/48] perf stat-display: Avoid use of core for CPU Ian Rogers
2021-12-29 0:09 ` Namhyung Kim
2021-12-30 6:22 ` Ian Rogers
2021-12-23 7:45 ` [PATCH v2 26/48] perf evsel: Derive CPUs and threads in alloc_counts Ian Rogers
2021-12-29 0:18 ` Namhyung Kim
2021-12-23 7:45 ` [PATCH v2 27/48] libperf: Switch cpu to more accurate cpu_map_idx Ian Rogers
2021-12-23 7:45 ` [PATCH v2 28/48] libperf: Use cpu not index for evsel mmap Ian Rogers
2021-12-23 7:45 ` [PATCH v2 29/48] perf counts: Switch name cpu to cpu_map_idx Ian Rogers
2021-12-23 7:45 ` [PATCH v2 30/48] perf stat: Rename aggr_data cpu to imply it's an index Ian Rogers
2021-12-29 0:36 ` Namhyung Kim
2021-12-23 7:45 ` [PATCH v2 31/48] perf stat: Use perf_cpu_map__for_each_cpu Ian Rogers
2021-12-23 7:45 ` [PATCH v2 32/48] perf script: Use for each cpu to aid readability Ian Rogers
2021-12-23 7:45 ` [PATCH v2 33/48] libperf: Allow NULL in perf_cpu_map__idx Ian Rogers
2021-12-23 7:45 ` [PATCH v2 34/48] perf evlist: Refactor evlist__for_each_cpu Ian Rogers
2021-12-29 0:58 ` Namhyung Kim
2021-12-30 16:10 ` Ian Rogers
2021-12-23 7:45 ` [PATCH v2 35/48] perf evsel: Pass cpu not cpu map index to synthesize Ian Rogers
2021-12-23 7:45 ` [PATCH v2 36/48] perf stat: Correct variable name for read counter Ian Rogers
2021-12-23 7:45 ` [PATCH v2 37/48] perf evsel: Rename CPU around get_group_fd Ian Rogers
2021-12-23 7:45 ` [PATCH v2 38/48] perf evsel: Reduce scope of evsel__ignore_missing_thread Ian Rogers
2021-12-23 7:45 ` [PATCH v2 39/48] perf evsel: Rename variable cpu to index Ian Rogers
2021-12-23 7:45 ` Ian Rogers [this message]
2021-12-23 7:45 ` [PATCH v2 41/48] perf stat: Correct check_per_pkg cpu Ian Rogers
2021-12-23 7:45 ` [PATCH v2 42/48] perf stat: Swap variable name cpu to index Ian Rogers
2021-12-23 7:45 ` [PATCH v2 43/48] libperf: Sync evsel documentation Ian Rogers
2021-12-23 7:45 ` [PATCH v2 44/48] perf bpf: Rename cpu to cpu_map_idx Ian Rogers
2021-12-23 7:45 ` [PATCH v2 45/48] perf c2c: Use more intention revealing iterator Ian Rogers
2021-12-23 7:45 ` [PATCH v2 46/48] perf script: Fix flipped index and cpu Ian Rogers
2021-12-23 7:45 ` [PATCH v2 47/48] perf stat: Correct first_shadow_cpu to return index Ian Rogers
2021-12-23 7:45 ` [PATCH v2 48/48] perf cpumap: Give CPUs their own type Ian Rogers
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211223074541.3318938-41-irogers@google.com \
--to=irogers@google.com \
--cc=acme@kernel.org \
--cc=ak@linux.intel.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=coresight@lists.linaro.org \
--cc=eranian@google.com \
--cc=james.clark@arm.com \
--cc=john.garry@huawei.com \
--cc=jolsa@redhat.com \
--cc=kan.liang@linux.intel.com \
--cc=kjain@linux.ibm.com \
--cc=leo.yan@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-perf-users@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mathieu.poirier@linaro.org \
--cc=mike.leach@linaro.org \
--cc=mingo@redhat.com \
--cc=namhyung@kernel.org \
--cc=pc@us.ibm.com \
--cc=peterz@infradead.org \
--cc=rickyman7@gmail.com \
--cc=suzuki.poulose@arm.com \
--cc=vineet.singh@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®