mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Junwen Wu <wudaemon@163.com>
To: jirislaby@kernel.org
Cc: gregkh@linuxfoundation.org, linux-kernel@vger.kernel.org,
	wudaemon@163.com
Subject: Re: [PATCH v1] tty/sysrq: change the definition of sysrq_key_table's element to make it more readable
Date: Sun, 10 Apr 2022 08:01:31 +0000	[thread overview]
Message-ID: <20220410080131.124738-1-wudaemon@163.com> (raw)
In-Reply-To: <19e11d77-1f81-c5a8-8a72-4fb7616438bf@kernel.org>

Dear Jiri
     Sorry ,sysrq_showallcpus_op etc. are  not massive,but confused.  "CONFIG_TRACING" make the definition of the sysrq_ftrace_dump outside sysrq_key_table
but "CONFIG_SMP" make the definition of the sysrq_showallcpus_op inside sysrq_key_table. so unitify the code will make code more readable.
wujunwen is realy my name,Junwen Wu is better.

Jiri, I plan to modify the commit message as follow:
Subject: [PATCH v1] tty/sysrq: change the definition of sysrq_key_table's element to make it more readable

The definition of sysrq_key_table's elements, like sysrq_thaw_op and
sysrq_showallcpus_op are not consistent with sysrq_ftrace_dump_op, Consistency makes code more readable.

Signed-off-by: Junwen Wu <wudaemon@163.com>

Is this ok?

beside,if this commit message is ok,the subject will comment PATCH v2 ?

Thanks


      reply	other threads:[~2022-04-10  8:02 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-05 15:36 wujunwen
2022-04-06  9:57 ` Jiri Slaby
2022-04-10  8:01   ` Junwen Wu [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220410080131.124738-1-wudaemon@163.com \
    --to=wudaemon@163.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jirislaby@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®