mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ulf Hansson <ulf.hansson@linaro.org>
To: "Rafael J . Wysocki" <rafael@kernel.org>, linux-pm@vger.kernel.org
Cc: "Rafael J . Wysocki" <rjw@rjwysocki.net>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	Maulik Shah <quic_mkshah@quicinc.com>,
	Gabriel Fernandez <gabriel.fernandez@foss.st.com>,
	Alexandre Torgue <alexandre.torgue@foss.st.com>,
	Dmitry Osipenko <digetx@gmail.com>,
	Kevin Hilman <khilman@kernel.org>,
	Ulf Hansson <ulf.hansson@linaro.org>,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: [PATCH 04/14] PM: domains: Rename irq_safe_dev_in_no_sleep_domain() in genpd
Date: Wed, 11 May 2022 16:56:54 +0200	[thread overview]
Message-ID: <20220511145704.698189-5-ulf.hansson@linaro.org> (raw)
In-Reply-To: <20220511145704.698189-1-ulf.hansson@linaro.org>

The name "irq_safe_dev_in_no_sleep_domain", doesn't really match the
conditions that are being checked in the function, hence the code becomes a
bit confusing to read.

Let's clarify this by renaming it into "irq_safe_dev_in_sleep_domain" and
let's also take the opportunity to clarify a corresponding comment in the
code.

Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org>
---
 drivers/base/power/domain.c | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/drivers/base/power/domain.c b/drivers/base/power/domain.c
index 5059c5d2e64a..269bfa3d2303 100644
--- a/drivers/base/power/domain.c
+++ b/drivers/base/power/domain.c
@@ -131,7 +131,7 @@ static const struct genpd_lock_ops genpd_spin_ops = {
 #define genpd_is_cpu_domain(genpd)	(genpd->flags & GENPD_FLAG_CPU_DOMAIN)
 #define genpd_is_rpm_always_on(genpd)	(genpd->flags & GENPD_FLAG_RPM_ALWAYS_ON)
 
-static inline bool irq_safe_dev_in_no_sleep_domain(struct device *dev,
+static inline bool irq_safe_dev_in_sleep_domain(struct device *dev,
 		const struct generic_pm_domain *genpd)
 {
 	bool ret;
@@ -139,9 +139,9 @@ static inline bool irq_safe_dev_in_no_sleep_domain(struct device *dev,
 	ret = pm_runtime_is_irq_safe(dev) && !genpd_is_irq_safe(genpd);
 
 	/*
-	 * Warn once if an IRQ safe device is attached to a no sleep domain, as
-	 * to indicate a suboptimal configuration for PM. For an always on
-	 * domain this isn't case, thus don't warn.
+	 * Warn once if an IRQ safe device is attached to a domain, which
+	 * callbacks are allowed to sleep. This indicates a suboptimal
+	 * configuration for PM, but it doesn't matter for an always on domain.
 	 */
 	if (ret && !genpd_is_always_on(genpd))
 		dev_warn_once(dev, "PM domain %s will not be powered off\n",
@@ -653,7 +653,7 @@ static int genpd_power_off(struct generic_pm_domain *genpd, bool one_dev_on,
 		 * device is part of a non-IRQ safe domain.
 		 */
 		if (!pm_runtime_suspended(pdd->dev) ||
-			irq_safe_dev_in_no_sleep_domain(pdd->dev, genpd))
+			irq_safe_dev_in_sleep_domain(pdd->dev, genpd))
 			not_suspended++;
 	}
 
@@ -925,7 +925,7 @@ static int genpd_runtime_suspend(struct device *dev)
 	 * If power.irq_safe is set, this routine may be run with
 	 * IRQs disabled, so suspend only if the PM domain also is irq_safe.
 	 */
-	if (irq_safe_dev_in_no_sleep_domain(dev, genpd))
+	if (irq_safe_dev_in_sleep_domain(dev, genpd))
 		return 0;
 
 	genpd_lock(genpd);
@@ -965,7 +965,7 @@ static int genpd_runtime_resume(struct device *dev)
 	 * As we don't power off a non IRQ safe domain, which holds
 	 * an IRQ safe device, we don't need to restore power to it.
 	 */
-	if (irq_safe_dev_in_no_sleep_domain(dev, genpd)) {
+	if (irq_safe_dev_in_sleep_domain(dev, genpd)) {
 		timed = false;
 		goto out;
 	}
-- 
2.25.1


  parent reply	other threads:[~2022-05-11 14:58 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-11 14:56 [PATCH 00/14] PM: domains: Various improvements for genpd Ulf Hansson
2022-05-11 14:56 ` [PATCH 01/14] PM: domains: Add GENPD_FLAG_RPM_ALWAYS_ON for the always-on governor Ulf Hansson
2022-05-11 14:56 ` [PATCH 02/14] PM: domains: Drop redundant code for genpd " Ulf Hansson
2022-05-11 14:56 ` [PATCH 03/14] PM: domains: Don't check PM_QOS_FLAG_NO_POWER_OFF in genpd Ulf Hansson
2022-05-11 14:56 ` Ulf Hansson [this message]
2022-05-11 14:56 ` [PATCH 05/14] PM: domains: Skip another warning in irq_safe_dev_in_sleep_domain() Ulf Hansson
2022-05-11 14:56 ` [PATCH 06/14] PM: domains: Allocate gpd_timing_data dynamically based on governor Ulf Hansson
2022-05-11 14:56 ` [PATCH 07/14] PM: domains: Move the next_wakeup variable into the struct gpd_timing_data Ulf Hansson
2022-05-11 14:56 ` [PATCH 08/14] PM: domains: Measure suspend/resume latencies in genpd based on governor Ulf Hansson
2022-05-11 14:56 ` [PATCH 09/14] PM: domains: Fixup QoS latency measurements for IRQ safe devices in genpd Ulf Hansson
2022-05-11 14:57 ` [PATCH 10/14] PM: domains: Fix initialization of genpd's next_wakeup Ulf Hansson
2022-05-11 14:57 ` [PATCH 11/14] PM: domains: Clean up some code in pm_genpd_init() and genpd_remove() Ulf Hansson
2022-05-11 14:57 ` [PATCH 12/14] PM: domains: Allocate governor data dynamically based on a genpd governor Ulf Hansson
2022-05-11 14:57 ` [PATCH 13/14] PM: domains: Measure power-on/off latencies in genpd based on a governor Ulf Hansson
2022-05-11 14:57 ` [PATCH 14/14] PM: domains: Trust domain-idle-states from DT to be correct by genpd Ulf Hansson
2022-05-19 18:37 ` [PATCH 00/14] PM: domains: Various improvements for genpd Rafael J. Wysocki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220511145704.698189-5-ulf.hansson@linaro.org \
    --to=ulf.hansson@linaro.org \
    --cc=alexandre.torgue@foss.st.com \
    --cc=digetx@gmail.com \
    --cc=gabriel.fernandez@foss.st.com \
    --cc=geert+renesas@glider.be \
    --cc=khilman@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=quic_mkshah@quicinc.com \
    --cc=rafael@kernel.org \
    --cc=rjw@rjwysocki.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®