From: Vitaly Rodionov <vitalyr@opensource.cirrus.com>
To: Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
Mark Brown <broonie@kernel.org>
Cc: <alsa-devel@alsa-project.org>, <patches@opensource.cirrus.com>,
<linux-kernel@vger.kernel.org>
Subject: [PATCH v5 00/14] ALSA: hda: cirrus: Add initial DSP support and firmware loading
Date: Mon, 20 Jun 2022 21:54:18 +0100 [thread overview]
Message-ID: <20220620205432.3809-1-vitalyr@opensource.cirrus.com> (raw)
The CS35L41 Amplifier contains a DSP, capable of running firmware.
The firmware can run algorithms such as Speaker Protection, to ensure
that playback at high gains do not harm the speakers.
Adding support for CS35L41 firmware into the CS35L41 HDA driver also
allows us to support several extra features, such as hiberation
and interrupts.
The chain adds support in stages:
- General fixes to improve generalization and code re-use inside
the CS35L41 HDA driver.
- Add support for interrupts into the driver, which is required
for complete support of the firmware.
- Refactor ASoC CS35L41 code which deals with firmware to allow
for code re-use inside the CS35L41 HDA driver.
- Add support for loading firmware and tuning files from file system,
and creating alsa controls to control it.
- Support firmware load paths for different hardware systems.
- Support suspend/resume in the driver when using firmware. The firmware
supports hibernation, which allows the CS35L41 to drop into a low
power mode during suspend.
- Support the ability to unload firmware, swap and reload the firmware.
This is to allow different firmware to run during calibration.
The intended use-case is to load the firmware once on boot, and the driver
autmatically tries to load the firmware after it binds to the HDA driver.
This behaviour can be switched off using a kconfig, if desired.
changes since v4:
- Fully remove tlv remnants from control add apis
- Remove unnecessary debug
- Rename variable to be more generic
- Remove redundent length check from read/write control apis
- Use SNDRV_CTL_ELEM_IFACE_CARD for firmware load controls
- Make kcontrol add/remove synchronous
- Load firmware asynchronous when loading via control
- Used cached controls when reloading firmware; only delete
controls when removing the driver itself
- Improve kcontrol remove
- Fix control write + notify
- Cleanup of unnecessary code
- Fix race condition when loading firmware before playback
- Ensure errors are properly propogated
- Fix include for Module parameters
Stefan Binding (13):
ALSA: hda: hda_cs_dsp_ctl: Add Library to support CS_DSP ALSA controls
ALSA: hda: hda_cs_dsp_ctl: Add apis to write the controls directly
ALSA: hda: cs35l41: Save codec object inside component struct
ALSA: hda: cs35l41: Save Subsystem ID inside CS35L41 Driver
ALSA: hda: cs35l41: Support reading subsystem id from ACPI
ALSA: hda: cs35l41: Support multiple load paths for firmware
ALSA: hda: cs35l41: Support Speaker ID for laptops
ALSA: hda: cs35l41: Support Hibernation during Suspend
ALSA: hda: cs35l41: Read Speaker Calibration data from UEFI variables
ALSA: hda: hda_cs_dsp_ctl: Add fw id strings
ALSA: hda: cs35l41: Add defaulted values into dsp bypass config
sequence
ALSA: hda: cs35l41: Support Firmware switching and reloading
ALSA: hda: cs35l41: Add module parameter to control firmware load
Vitaly Rodionov (1):
ALSA: hda: cs35l41: Add initial DSP support and firmware loading
MAINTAINERS | 1 +
include/sound/cs35l41.h | 4 +
sound/pci/hda/Kconfig | 8 +
sound/pci/hda/Makefile | 2 +
sound/pci/hda/cs35l41_hda.c | 902 +++++++++++++++++++++++++++++++-
sound/pci/hda/cs35l41_hda.h | 39 ++
sound/pci/hda/cs35l41_hda_i2c.c | 1 +
sound/pci/hda/cs35l41_hda_spi.c | 1 +
sound/pci/hda/hda_component.h | 4 +
sound/pci/hda/hda_cs_dsp_ctl.c | 254 +++++++++
sound/pci/hda/hda_cs_dsp_ctl.h | 39 ++
sound/pci/hda/patch_realtek.c | 27 +-
12 files changed, 1277 insertions(+), 5 deletions(-)
create mode 100644 sound/pci/hda/hda_cs_dsp_ctl.c
create mode 100644 sound/pci/hda/hda_cs_dsp_ctl.h
--
2.34.1
next reply other threads:[~2022-06-20 20:56 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-20 20:54 Vitaly Rodionov [this message]
2022-06-20 20:54 ` [PATCH v5 01/14] ALSA: hda: hda_cs_dsp_ctl: Add Library to support CS_DSP ALSA controls Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 02/14] ALSA: hda: hda_cs_dsp_ctl: Add apis to write the controls directly Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 03/14] ALSA: hda: cs35l41: Save codec object inside component struct Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 04/14] ALSA: hda: cs35l41: Add initial DSP support and firmware loading Vitaly Rodionov
2022-06-21 0:52 ` kernel test robot
2022-06-20 20:54 ` [PATCH v5 05/14] ALSA: hda: cs35l41: Save Subsystem ID inside CS35L41 Driver Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 06/14] ALSA: hda: cs35l41: Support reading subsystem id from ACPI Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 07/14] ALSA: hda: cs35l41: Support multiple load paths for firmware Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 08/14] ALSA: hda: cs35l41: Support Speaker ID for laptops Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 09/14] ALSA: hda: cs35l41: Support Hibernation during Suspend Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 10/14] ALSA: hda: cs35l41: Read Speaker Calibration data from UEFI variables Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 11/14] ALSA: hda: hda_cs_dsp_ctl: Add fw id strings Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 12/14] ALSA: hda: cs35l41: Add defaulted values into dsp bypass config sequence Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 13/14] ALSA: hda: cs35l41: Support Firmware switching and reloading Vitaly Rodionov
2022-06-20 20:54 ` [PATCH v5 14/14] ALSA: hda: cs35l41: Add module parameter to control firmware load Vitaly Rodionov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220620205432.3809-1-vitalyr@opensource.cirrus.com \
--to=vitalyr@opensource.cirrus.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=patches@opensource.cirrus.com \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®