From: Sean Christopherson <seanjc@google.com>
To: Sean Christopherson <seanjc@google.com>,
Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH v2 0/7] KVM: x86: Clean up rmap zap helpers
Date: Fri, 15 Jul 2022 22:42:19 +0000 [thread overview]
Message-ID: <20220715224226.3749507-1-seanjc@google.com> (raw)
Clean up the rmap helpers (mostly renames) to yield a more coherent set of
APIs, and to purge the irritating and inconsistent "rmapp" (p is for pointer)
nomenclature.
Patch 1 is a tangentially related fix for a benign bug.
v2:
- Split up patches into smaller, more related chunks. [Paolo]
- Reorder patches to put all renames at the end. [Paolo]
- Avoid quadruple underscores and use more consistent names. [Paolo]
v1: https://lore.kernel.org/all/20220712015558.1247978-1-seanjc@google.com
Sean Christopherson (7):
KVM: x86/mmu: Return a u64 (the old SPTE) from
mmu_spte_clear_track_bits()
KVM: x86/mmu: Directly "destroy" PTE list when recycling rmaps
KVM: x86/mmu: Drop the "p is for pointer" from rmap helpers
KVM: x86/mmu: Rename __kvm_zap_rmaps() to align with other
nomenclature
KVM: x86/mmu: Rename rmap zap helpers to eliminate "unmap" wrapper
KVM: x86/mmu: Rename pte_list_{destroy,remove}() to show they zap
SPTEs
KVM: x86/mmu: Remove underscores from __pte_list_remove()
arch/x86/kvm/mmu/mmu.c | 74 +++++++++++++++++++++---------------------
1 file changed, 37 insertions(+), 37 deletions(-)
base-commit: 8031d87aa9953ddeb047a5356ebd0b240c30f233
--
2.37.0.170.g444d1eabd0-goog
next reply other threads:[~2022-07-15 22:42 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-15 22:42 Sean Christopherson [this message]
2022-07-15 22:42 ` [PATCH v2 1/7] KVM: x86/mmu: Return a u64 (the old SPTE) from mmu_spte_clear_track_bits() Sean Christopherson
2022-07-15 22:42 ` [PATCH v2 2/7] KVM: x86/mmu: Directly "destroy" PTE list when recycling rmaps Sean Christopherson
2022-07-15 22:42 ` [PATCH v2 3/7] KVM: x86/mmu: Drop the "p is for pointer" from rmap helpers Sean Christopherson
2022-07-15 22:42 ` [PATCH v2 4/7] KVM: x86/mmu: Rename __kvm_zap_rmaps() to align with other nomenclature Sean Christopherson
2022-07-15 22:42 ` [PATCH v2 5/7] KVM: x86/mmu: Rename rmap zap helpers to eliminate "unmap" wrapper Sean Christopherson
2022-07-15 22:42 ` [PATCH v2 6/7] KVM: x86/mmu: Rename pte_list_{destroy,remove}() to show they zap SPTEs Sean Christopherson
2022-07-15 22:42 ` [PATCH v2 7/7] KVM: x86/mmu: Remove underscores from __pte_list_remove() Sean Christopherson
2022-07-19 13:15 ` [PATCH v2 0/7] KVM: x86: Clean up rmap zap helpers Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220715224226.3749507-1-seanjc@google.com \
--to=seanjc@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®