mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Maxime Ripard <maxime@cerno.tech>
To: Thomas Zimmermann <tzimmermann@suse.de>
Cc: "Jernej Skrabec" <jernej.skrabec@gmail.com>,
	"Rodrigo Vivi" <rodrigo.vivi@intel.com>,
	"Ben Skeggs" <bskeggs@redhat.com>,
	"David Airlie" <airlied@linux.ie>,
	"Joonas Lahtinen" <joonas.lahtinen@linux.intel.com>,
	"Emma Anholt" <emma@anholt.net>,
	"Karol Herbst" <kherbst@redhat.com>,
	"Samuel Holland" <samuel@sholland.org>,
	"Jani Nikula" <jani.nikula@linux.intel.com>,
	"Daniel Vetter" <daniel@ffwll.ch>,
	"Lyude Paul" <lyude@redhat.com>,
	"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
	"Tvrtko Ursulin" <tvrtko.ursulin@linux.intel.com>,
	"Chen-Yu Tsai" <wens@csie.org>,
	"Dom Cobley" <dom@raspberrypi.com>,
	"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
	nouveau@lists.freedesktop.org, intel-gfx@lists.freedesktop.org,
	linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org,
	linux-sunxi@lists.linux.dev,
	"Hans de Goede" <hdegoede@redhat.com>,
	"Noralf Trønnes" <noralf@tronnes.org>,
	"Geert Uytterhoeven" <geert@linux-m68k.org>,
	"Mateusz Kwiatkowski" <kfyatek+publicgit@gmail.com>,
	"Phil Elwell" <phil@raspberrypi.com>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v2 06/33] drm/connector: Rename legacy TV property
Date: Mon, 26 Sep 2022 11:50:31 +0200	[thread overview]
Message-ID: <20220926095031.vlwsw7willi36yd4@houat> (raw)
In-Reply-To: <fa71ae1c-f9ca-167c-7993-b698ea3473a0@suse.de>

[-- Attachment #1: Type: text/plain, Size: 991 bytes --]

Hi Thomas,

On Fri, Sep 23, 2022 at 10:19:08AM +0200, Thomas Zimmermann wrote:
> Hi
> 
> Am 22.09.22 um 16:25 schrieb Maxime Ripard:
> > The current tv_mode has driver-specific values that don't allow to
> > easily share code using it, either at the userspace or kernel level.
> > 
> > Since we're going to introduce a new, generic, property that fit the
> > same purpose, let's rename this one to legacy_tv_mode to make it
> > obvious we should move away from it.
> > 
> > Signed-off-by: Maxime Ripard <maxime@cerno.tech>
> 
> It's not wrong, but 'legacy' is already overloaded with meaning. If you can,
> maybe name it 'driver_tv_mode_property' or 'custom_tv_mode_property'
> instead.
> 
> Acked-by: Thomas Zimmermann <tzimmermann@suse.de>

I'd really like to point out that new drivers shouldn't be using this.
If we're using either of your proposals then writers might get the
impression that this is ok to us.

Would you prefer deprecated to legacy?

Maxime

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

  reply	other threads:[~2022-09-26  9:51 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20220728-rpi-analog-tv-properties-v2-0-f733a0ed9f90@cerno.tech>
2022-09-22 14:31 ` [PATCH v2 00/33] drm: Analog TV Improvements Maxime Ripard
     [not found] ` <20220728-rpi-analog-tv-properties-v2-3-f733a0ed9f90@cerno.tech>
2022-09-23  8:09   ` [PATCH v2 03/33] drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity Thomas Zimmermann
     [not found] ` <20220728-rpi-analog-tv-properties-v2-4-f733a0ed9f90@cerno.tech>
2022-09-23  8:14   ` [PATCH v2 04/33] drm/connector: Rename subconnector state variable Thomas Zimmermann
     [not found] ` <20220728-rpi-analog-tv-properties-v2-10-f733a0ed9f90@cerno.tech>
2022-09-23  9:05   ` [PATCH v2 10/33] drm/modes: Add a function to generate analog display modes Thomas Zimmermann
2022-09-23  9:18     ` Jani Nikula
2022-09-23 10:16       ` Thomas Zimmermann
2022-09-26 10:18         ` Maxime Ripard
2022-09-26 10:55           ` Thomas Zimmermann
2022-09-26 10:17     ` Maxime Ripard
2022-09-26 10:34       ` Geert Uytterhoeven
2022-09-26 11:17         ` Thomas Zimmermann
2022-09-26 12:42           ` Maxime Ripard
2022-09-26 13:02             ` Thomas Zimmermann
     [not found] ` <20220728-rpi-analog-tv-properties-v2-13-f733a0ed9f90@cerno.tech>
2022-09-23  9:15   ` [PATCH v2 13/33] drm/client: Add some tests for drm_connector_pick_cmdline_mode() Thomas Zimmermann
2022-09-23  9:26     ` Javier Martinez Canillas
2022-09-23 10:30       ` Thomas Zimmermann
2022-09-23 11:01         ` Javier Martinez Canillas
2022-09-23 11:14         ` Maxime Ripard
2022-09-23 11:59   ` Jani Nikula
     [not found] ` <20220728-rpi-analog-tv-properties-v2-6-f733a0ed9f90@cerno.tech>
2022-09-22 20:44   ` [PATCH v2 06/33] drm/connector: Rename legacy TV property Lyude Paul
2022-09-23  8:19   ` Thomas Zimmermann
2022-09-26  9:50     ` Maxime Ripard [this message]
2022-09-26 12:34       ` Thomas Zimmermann
2022-09-24 15:38   ` Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-8-f733a0ed9f90@cerno.tech>
2022-09-22 20:45   ` [PATCH v2 08/33] drm/connector: Rename drm_mode_create_tv_properties Lyude Paul
2022-09-24 15:43   ` Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-9-f733a0ed9f90@cerno.tech>
2022-09-24 15:52   ` [PATCH v2 09/33] drm/connector: Add TV standard property Noralf Trønnes
2022-09-26 10:01     ` Maxime Ripard
2022-09-26 12:59       ` Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-27-f733a0ed9f90@cerno.tech>
2022-09-24 15:58   ` [PATCH v2 27/33] drm/atomic-helper: Add an analog TV atomic_check implementation Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-28-f733a0ed9f90@cerno.tech>
2022-09-24 15:59   ` [PATCH v2 28/33] drm/vc4: vec: Fix definition of PAL-M mode Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-30-f733a0ed9f90@cerno.tech>
2022-09-24 16:00   ` [PATCH v2 30/33] drm/vc4: vec: Check for VEC output constraints Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-31-f733a0ed9f90@cerno.tech>
2022-09-24 17:09   ` [PATCH v2 31/33] drm/vc4: vec: Convert to the new TV mode property Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-32-f733a0ed9f90@cerno.tech>
2022-09-24 17:12   ` [PATCH v2 32/33] drm/vc4: vec: Add support for more analog TV standards Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-1-f733a0ed9f90@cerno.tech>
2022-09-23  8:06   ` [PATCH v2 01/33] drm/tests: Order Kunit tests in Makefile Thomas Zimmermann
2022-09-24 17:33   ` Noralf Trønnes
     [not found] ` <20220728-rpi-analog-tv-properties-v2-2-f733a0ed9f90@cerno.tech>
2022-09-24 17:56   ` [PATCH v2 02/33] drm/tests: Add Kunit Helpers Noralf Trønnes
2022-09-24 18:06     ` Noralf Trønnes
2022-09-26  9:36       ` Maxime Ripard
2022-09-26 12:15         ` Noralf Trønnes
2022-09-25 15:58 ` [PATCH v2 00/33] drm: Analog TV Improvements Noralf Trønnes

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220926095031.vlwsw7willi36yd4@houat \
    --to=maxime@cerno.tech \
    --cc=airlied@linux.ie \
    --cc=bskeggs@redhat.com \
    --cc=daniel@ffwll.ch \
    --cc=dave.stevenson@raspberrypi.com \
    --cc=dom@raspberrypi.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=emma@anholt.net \
    --cc=geert@linux-m68k.org \
    --cc=hdegoede@redhat.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jani.nikula@linux.intel.com \
    --cc=jernej.skrabec@gmail.com \
    --cc=joonas.lahtinen@linux.intel.com \
    --cc=kfyatek+publicgit@gmail.com \
    --cc=kherbst@redhat.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-sunxi@lists.linux.dev \
    --cc=lyude@redhat.com \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=noralf@tronnes.org \
    --cc=nouveau@lists.freedesktop.org \
    --cc=phil@raspberrypi.com \
    --cc=rodrigo.vivi@intel.com \
    --cc=samuel@sholland.org \
    --cc=tvrtko.ursulin@linux.intel.com \
    --cc=tzimmermann@suse.de \
    --cc=wens@csie.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®