mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Qais Yousef <qyousef@layalina.io>
To: John Stultz <jstultz@google.com>
Cc: Alexander Gordeev <agordeev@linux.ibm.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Connor O'Brien <connoro@google.com>,
	John Dias <joaodias@google.com>, Rick Yiu <rickyiu@google.com>,
	John Kacur <jkacur@redhat.com>, Qais Yousef <qais.yousef@arm.com>,
	Chris Redpath <chris.redpath@arm.com>,
	Abhijeet Dharmapurikar <adharmap@quicinc.com>,
	Peter Zijlstra <peterz@infradead.org>,
	Ingo Molnar <mingo@redhat.com>,
	Juri Lelli <juri.lelli@redhat.com>,
	Vincent Guittot <vincent.guittot@linaro.org>,
	Dietmar Eggemann <dietmar.eggemann@arm.com>,
	Steven Rostedt <rostedt@goodmis.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	kernel-team@android.com, "J . Avila" <elavila@google.com>
Subject: Re: [PATCH RFC v4 2/3] sched: Avoid placing RT threads on cores handling long softirqs
Date: Wed, 19 Oct 2022 12:23:15 +0100	[thread overview]
Message-ID: <20221019112315.7d6wyc7d7dgzwsch@airbuntu> (raw)
In-Reply-To: <CANDhNCoTGNANDnOQ6touhreG_UEn1-N4T4BktWFxpLPSWVfrdA@mail.gmail.com>

On 10/17/22 20:42, John Stultz wrote:

> > > +     return ret;
> > > +}
> > > +#else
> > > +#define __use_softirq_opt 0
> > > +static bool cpu_busy_with_softirqs(int cpu)
> > > +{
> > > +     return false;
> > > +}
> > > +#endif /* CONFIG_RT_SOFTIRQ_OPTIMIZATION */
> > > +
> > > +static bool rt_task_fits_cpu(struct task_struct *p, int cpu)
> >
> > To me, the new name is unfortunate, since it strips a notion
> > of the reason. Instead, "CPU un/fits, because of capacity" it
> > reads as "CPU un/fits, because of ..." what?
> 
> As with all complicated questions: "It depends" :) On the kernel
> config specifically.
> 
> The earlier version of the patch had:
> rt_task_fits_capacity_and_may_preempt() but Qais suggested it be
> switched to the generic "fits_cpu" as it would depend on the kernel
> config as to which aspect of "fit" was being considered.
> 
> I guess it could be  rt_task_fits_capacity_and_softirq_free() ?

My line of thinking is that we have multiple reasons which could potentially
come and go. Having a simple generic name is future proof to the details of the
reason.

For example, in the future we might find a better way to handle the softirq
conflict and remove this reason; or we might find a new 'reason' is required.
Documenting that in the function header (if required, I see the one line
implementation is self descriptive so far) rather than in name made more sense
to me, hence the suggestion.

I am already aware of another new reason required to handle thermal pressure
when checking for capacity [1]. The discussion has stalled, but the problem is
still there and we'd need to address it. So I expect this code will be massaged
somewhat in the near future.

Sticking to rt_task_fits_cpu() will reduce the churn IMHO. But if you really
prefer something else, works for me :-)

[1] https://lore.kernel.org/lkml/20220514235513.jm7ul2y6uddj6eh2@airbuntu/


Cheers

--
Qais Yousef

  parent reply	other threads:[~2022-10-19 11:45 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-10-03 23:20 [RFC PATCH v4 0/3] Softirq -rt Optimizations John Stultz
2022-10-03 23:20 ` [RFC PATCH v4 1/3] softirq: Add generic accessor to percpu softirq_pending data John Stultz
2022-10-03 23:20 ` [RFC PATCH v4 2/3] sched: Avoid placing RT threads on cores handling long softirqs John Stultz
     [not found]   ` <20221004013611.1822-1-hdanton@sina.com>
2022-10-04  2:29     ` John Stultz
     [not found]       ` <20221005002149.1876-1-hdanton@sina.com>
2022-10-05  1:13         ` John Stultz
     [not found]         ` <20221005060155.1571-1-hdanton@sina.com>
2022-10-10 15:42           ` Qais Yousef
     [not found]             ` <20221011111846.284-1-hdanton@sina.com>
2022-10-12 14:10               ` Qais Yousef
2022-10-17 12:40   ` [PATCH RFC " Alexander Gordeev
2022-10-18  3:42     ` John Stultz
2022-10-18  3:59       ` John Stultz
2022-10-18  5:32       ` John Stultz
2022-10-19  9:11       ` Alexander Gordeev
2022-10-19 22:09         ` John Stultz
2022-10-20  0:15           ` Qais Yousef
2022-10-20 12:47           ` Alexander Gordeev
2022-10-22 18:34             ` Joel Fernandes
2022-10-23  7:45               ` Alexander Gordeev
2022-11-15  7:08                 ` John Stultz
2022-11-15 12:55                   ` Alexander Gordeev
2022-10-19 11:23       ` Qais Yousef [this message]
2022-10-22 18:28   ` [RFC PATCH " Joel Fernandes
2022-11-15 21:36     ` John Stultz
2022-10-03 23:20 ` [RFC PATCH v4 3/3] softirq: defer softirq processing to ksoftirqd if CPU is busy with RT John Stultz
2022-10-04 10:45   ` David Laight
2022-10-04 19:19     ` John Stultz
2022-10-10 16:09   ` Qais Yousef
2022-10-17 14:44     ` Qais Yousef
2022-10-18  0:04       ` John Stultz
2022-10-19 11:01         ` Qais Yousef

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20221019112315.7d6wyc7d7dgzwsch@airbuntu \
    --to=qyousef@layalina.io \
    --cc=adharmap@quicinc.com \
    --cc=agordeev@linux.ibm.com \
    --cc=chris.redpath@arm.com \
    --cc=connoro@google.com \
    --cc=dietmar.eggemann@arm.com \
    --cc=elavila@google.com \
    --cc=jkacur@redhat.com \
    --cc=joaodias@google.com \
    --cc=jstultz@google.com \
    --cc=juri.lelli@redhat.com \
    --cc=kernel-team@android.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=qais.yousef@arm.com \
    --cc=rickyiu@google.com \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    --cc=vincent.guittot@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®