From: Syed Saba Kareem <Syed.SabaKareem@amd.com>
To: <broonie@kernel.org>, <alsa-devel@alsa-project.org>
Cc: <Vijendar.Mukunda@amd.com>, <Basavaraj.Hiregoudar@amd.com>,
<Sunil-kumar.Dommati@amd.com>, <mario.limonciello@amd.com>,
Syed Saba Kareem <Syed.SabaKareem@amd.com>,
Liam Girdwood <lgirdwood@gmail.com>,
"Jaroslav Kysela" <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
open list <linux-kernel@vger.kernel.org>
Subject: [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention
Date: Wed, 16 Nov 2022 16:29:22 +0530 [thread overview]
Message-ID: <20221116105938.762550-1-Syed.SabaKareem@amd.com> (raw)
Update macros using ps platform naming convention.
Signed-off-by: Syed Saba Kareem <Syed.SabaKareem@amd.com>
---
sound/soc/amd/ps/acp63.h | 8 ++++----
sound/soc/amd/ps/pci-ps.c | 14 +++++++-------
2 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/sound/soc/amd/ps/acp63.h b/sound/soc/amd/ps/acp63.h
index 85f869c2229f..a90ba3b20dc7 100644
--- a/sound/soc/amd/ps/acp63.h
+++ b/sound/soc/amd/ps/acp63.h
@@ -8,10 +8,10 @@
#include <sound/acp63_chip_offset_byte.h>
#define ACP_DEVICE_ID 0x15E2
-#define ACP6x_REG_START 0x1240000
-#define ACP6x_REG_END 0x1250200
-#define ACP6x_DEVS 3
-#define ACP6x_PDM_MODE 1
+#define ACP63_REG_START 0x1240000
+#define ACP63_REG_END 0x1250200
+#define ACP63_DEVS 3
+#define ACP63_PDM_MODE 1
#define ACP_SOFT_RESET_SOFTRESET_AUDDONE_MASK 0x00010001
#define ACP_PGFSM_CNTL_POWER_ON_MASK 1
diff --git a/sound/soc/amd/ps/pci-ps.c b/sound/soc/amd/ps/pci-ps.c
index 08c4b9bef055..98dddd1a0cf4 100644
--- a/sound/soc/amd/ps/pci-ps.c
+++ b/sound/soc/amd/ps/pci-ps.c
@@ -21,7 +21,7 @@ struct acp63_dev_data {
void __iomem *acp63_base;
struct resource *res;
bool acp63_audio_mode;
- struct platform_device *pdev[ACP6x_DEVS];
+ struct platform_device *pdev[ACP63_DEVS];
};
static int acp63_power_on(void __iomem *acp_base)
@@ -143,7 +143,7 @@ static int snd_acp63_probe(struct pci_dev *pci,
const struct pci_device_id *pci_id)
{
struct acp63_dev_data *adata;
- struct platform_device_info pdevinfo[ACP6x_DEVS];
+ struct platform_device_info pdevinfo[ACP63_DEVS];
int index, ret;
int val = 0x00;
struct acpi_device *adev;
@@ -219,8 +219,8 @@ static int snd_acp63_probe(struct pci_dev *pci,
adata->res->name = "acp_iomem";
adata->res->flags = IORESOURCE_MEM;
adata->res->start = addr;
- adata->res->end = addr + (ACP6x_REG_END - ACP6x_REG_START);
- adata->acp63_audio_mode = ACP6x_PDM_MODE;
+ adata->res->end = addr + (ACP63_REG_END - ACP63_REG_START);
+ adata->acp63_audio_mode = ACP63_PDM_MODE;
memset(&pdevinfo, 0, sizeof(pdevinfo));
pdevinfo[0].name = "acp_ps_pdm_dma";
@@ -237,7 +237,7 @@ static int snd_acp63_probe(struct pci_dev *pci,
pdevinfo[2].id = 0;
pdevinfo[2].parent = &pci->dev;
- for (index = 0; index < ACP6x_DEVS; index++) {
+ for (index = 0; index < ACP63_DEVS; index++) {
adata->pdev[index] =
platform_device_register_full(&pdevinfo[index]);
@@ -312,8 +312,8 @@ static void snd_acp63_remove(struct pci_dev *pci)
int ret, index;
adata = pci_get_drvdata(pci);
- if (adata->acp63_audio_mode == ACP6x_PDM_MODE) {
- for (index = 0; index < ACP6x_DEVS; index++)
+ if (adata->acp63_audio_mode == ACP63_PDM_MODE) {
+ for (index = 0; index < ACP63_DEVS; index++)
platform_device_unregister(adata->pdev[index]);
}
ret = acp63_deinit(adata->acp63_base, &pci->dev);
--
2.25.1
next reply other threads:[~2022-11-16 11:16 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-11-16 10:59 Syed Saba Kareem [this message]
2022-11-16 10:59 ` [PATCH 2/2] ASoC: amd: ps: Move acp63_dev_data strcture from PCI driver Syed Saba Kareem
2022-11-16 14:45 ` [PATCH 1/2] ASoC: amd: ps: update macros with ps platform naming convention Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20221116105938.762550-1-Syed.SabaKareem@amd.com \
--to=syed.sabakareem@amd.com \
--cc=Basavaraj.Hiregoudar@amd.com \
--cc=Sunil-kumar.Dommati@amd.com \
--cc=Vijendar.Mukunda@amd.com \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mario.limonciello@amd.com \
--cc=perex@perex.cz \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®