From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id F3DAAEB64D7 for ; Fri, 23 Jun 2023 16:53:08 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S232453AbjFWQxG (ORCPT ); Fri, 23 Jun 2023 12:53:06 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:55988 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229611AbjFWQxB (ORCPT ); Fri, 23 Jun 2023 12:53:01 -0400 Received: from perceval.ideasonboard.com (perceval.ideasonboard.com [213.167.242.64]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 401182727; Fri, 23 Jun 2023 09:53:00 -0700 (PDT) Received: from pendragon.ideasonboard.com (213-243-189-158.bb.dnainternet.fi [213.243.189.158]) by perceval.ideasonboard.com (Postfix) with ESMTPSA id 4428B440; Fri, 23 Jun 2023 18:52:22 +0200 (CEST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=ideasonboard.com; s=mail; t=1687539142; bh=YJ3yOXbzBwOA7XqInoA3P8Y2N6ErXUdW7tXjVgzSU1s=; h=Date:From:To:Cc:Subject:References:In-Reply-To:From; b=IlRE08XWEpA/3WiAtLmtr4QhSVqBYLWSFmgG8O8tIu1gA8lbdcqLoEfZYLQUQkuDM 1FKORhiqQdMEHgUTb97uS8t0makkemU6wWVH687RHzZGiVMn/YQyaMFoIUyGoNZIrE dSz3wANBci0ADTqsJzAZWa8ATef1rhUUmZ8Qi8yg= Date: Fri, 23 Jun 2023 19:52:57 +0300 From: Laurent Pinchart To: Geert Uytterhoeven Cc: Kieran Bingham , David Airlie , Daniel Vetter , Thomas Zimmermann , Magnus Damm , dri-devel@lists.freedesktop.org, linux-renesas-soc@vger.kernel.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 27/39] drm: renesas: shmobile: Rename shmob_drm_plane.plane Message-ID: <20230623165257.GE2112@pendragon.ideasonboard.com> References: MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Geert, Thank you for the patch. On Thu, Jun 22, 2023 at 11:21:39AM +0200, Geert Uytterhoeven wrote: > Rename the "plane" member of the shmob_drm_plane subclass structure to > "base", to improve readability. > > Signed-off-by: Geert Uytterhoeven Reviewed-by: Laurent Pinchart > --- > drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c b/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c > index 63886015baaebfc0..e300e5c0de70a9b1 100644 > --- a/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c > +++ b/drivers/gpu/drm/renesas/shmobile/shmob_drm_plane.c > @@ -20,7 +20,7 @@ > #include "shmob_drm_regs.h" > > struct shmob_drm_plane { > - struct drm_plane plane; > + struct drm_plane base; > unsigned int index; > unsigned int alpha; > > @@ -37,7 +37,7 @@ struct shmob_drm_plane { > > static inline struct shmob_drm_plane *to_shmob_plane(struct drm_plane *plane) > { > - return container_of(plane, struct shmob_drm_plane, plane); > + return container_of(plane, struct shmob_drm_plane, base); > } > > static void shmob_drm_plane_compute_base(struct shmob_drm_plane *splane, > @@ -64,7 +64,7 @@ static void shmob_drm_plane_compute_base(struct shmob_drm_plane *splane, > static void __shmob_drm_plane_setup(struct shmob_drm_plane *splane, > struct drm_framebuffer *fb) > { > - struct shmob_drm_device *sdev = to_shmob_device(splane->plane.dev); > + struct shmob_drm_device *sdev = to_shmob_device(splane->base.dev); > unsigned int ovl_idx = splane->index - 1; > u32 format; > > @@ -221,7 +221,7 @@ struct drm_plane *shmob_drm_plane_create(struct shmob_drm_device *sdev, > } > > splane = drmm_universal_plane_alloc(&sdev->ddev, > - struct shmob_drm_plane, plane, 1, > + struct shmob_drm_plane, base, 1, > funcs, formats, > ARRAY_SIZE(formats), NULL, type, > NULL); > @@ -231,5 +231,5 @@ struct drm_plane *shmob_drm_plane_create(struct shmob_drm_device *sdev, > splane->index = index; > splane->alpha = 255; > > - return &splane->plane; > + return &splane->base; > } -- Regards, Laurent Pinchart