From: Konrad Dybcio <konrad.dybcio@linaro.org>
To: Stanimir Varbanov <stanimir.k.varbanov@gmail.com>,
Vikash Garodia <quic_vgarodia@quicinc.com>,
Bryan O'Donoghue <bryan.odonoghue@linaro.org>,
Andy Gross <agross@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Dikshita Agarwal <quic_dikshita@quicinc.com>,
Philipp Zabel <p.zabel@pengutronix.de>
Cc: Marijn Suijten <marijn.suijten@somainline.org>,
Stanimir Varbanov <stanimir.varbanov@linaro.org>,
Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
linux-media@vger.kernel.org, linux-arm-msm@vger.kernel.org,
linux-kernel@vger.kernel.org,
Konrad Dybcio <konrad.dybcio@linaro.org>
Subject: [PATCH RFT 02/20] media: venus: pm_helpers: Rename core_clks_get to venus_clks_get
Date: Mon, 11 Sep 2023 17:10:16 +0200 [thread overview]
Message-ID: <20230911-topic-mars-v1-2-a7d38bf87bdb@linaro.org> (raw)
In-Reply-To: <20230911-topic-mars-v1-0-a7d38bf87bdb@linaro.org>
"core" is used in multiple contexts when talking about Venus, rename
the function to save on confusion.
Signed-off-by: Konrad Dybcio <konrad.dybcio@linaro.org>
---
drivers/media/platform/qcom/venus/pm_helpers.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/media/platform/qcom/venus/pm_helpers.c b/drivers/media/platform/qcom/venus/pm_helpers.c
index 2bd9c63d0253..e2aec0b46126 100644
--- a/drivers/media/platform/qcom/venus/pm_helpers.c
+++ b/drivers/media/platform/qcom/venus/pm_helpers.c
@@ -23,7 +23,7 @@
static bool legacy_binding;
-static int core_clks_get(struct venus_core *core)
+static int venus_clks_get(struct venus_core *core)
{
const struct venus_resources *res = core->res;
struct device *dev = core->dev;
@@ -294,7 +294,7 @@ static int core_get_v1(struct venus_core *core)
{
int ret;
- ret = core_clks_get(core);
+ ret = venus_clks_get(core);
if (ret)
return ret;
@@ -978,7 +978,7 @@ static int core_get_v4(struct venus_core *core)
const struct venus_resources *res = core->res;
int ret;
- ret = core_clks_get(core);
+ ret = venus_clks_get(core);
if (ret)
return ret;
--
2.42.0
next prev parent reply other threads:[~2023-09-11 21:49 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-09-11 15:10 [PATCH RFT 00/20] Venus cleanups Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 01/20] media: venus: pm_helpers: Only set rate of the core clock in core_clks_enable Konrad Dybcio
2023-09-11 15:10 ` Konrad Dybcio [this message]
2023-09-11 15:10 ` [PATCH RFT 03/20] media: venus: pm_helpers: Add kerneldoc to venus_clks_get() Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 04/20] media: venus: core: Set OPP clkname in a common code path Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 05/20] media: venus: pm_helpers: Kill dead code Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 06/20] media: venus: pm_helpers: Move reset acquisition to common code Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 07/20] media: venus: pm_helpers: Use reset_bulk API Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 08/20] media: venus: core: Constify all members of the resource struct Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 09/20] media: venus: core: Deduplicate OPP genpd names Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 10/20] media: venus: core: Get rid of vcodec_num Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 11/20] media: venus: core: Drop cache properties in resource struct Konrad Dybcio
2023-09-11 23:53 ` kernel test robot
2023-09-11 15:10 ` [PATCH RFT 12/20] media: venus: core: Use GENMASK for dma_mask Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 13/20] media: venus: core: Remove cp_start Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 14/20] media: venus: pm_helpers: Commonize core_power Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 15/20] media: venus: pm_helpers: Remove pm_ops->core_put Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 16/20] media: venus: core: Define a pointer to core->res Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 17/20] media: venus: pm_helpers: Simplify vcodec clock handling Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 18/20] media: venus: pm_helpers: Commonize getting clocks and GenPDs Konrad Dybcio
2023-09-11 15:10 ` [PATCH RFT 19/20] media: venus: pm_helpers: Commonize vdec_get() Konrad Dybcio
2023-09-13 3:52 ` kernel test robot
2023-09-11 15:10 ` [PATCH RFT 20/20] media: venus: pm_helpers: Commonize venc_get() Konrad Dybcio
2023-09-13 11:24 ` kernel test robot
2023-09-12 6:19 ` [PATCH RFT 00/20] Venus cleanups Bryan O'Donoghue
2023-09-13 12:03 ` Konrad Dybcio
2023-09-13 12:26 ` Bryan O'Donoghue
2023-09-15 14:13 ` Bryan O'Donoghue
2023-09-15 14:15 ` Konrad Dybcio
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230911-topic-mars-v1-2-a7d38bf87bdb@linaro.org \
--to=konrad.dybcio@linaro.org \
--cc=agross@kernel.org \
--cc=andersson@kernel.org \
--cc=bryan.odonoghue@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=marijn.suijten@somainline.org \
--cc=mchehab+huawei@kernel.org \
--cc=mchehab@kernel.org \
--cc=p.zabel@pengutronix.de \
--cc=quic_dikshita@quicinc.com \
--cc=quic_vgarodia@quicinc.com \
--cc=stanimir.k.varbanov@gmail.com \
--cc=stanimir.varbanov@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome