mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Jiri Slaby (SUSE)" <jirislaby@kernel.org>
To: gregkh@linuxfoundation.org
Cc: linux-serial@vger.kernel.org, linux-kernel@vger.kernel.org,
	"Jiri Slaby (SUSE)" <jirislaby@kernel.org>
Subject: [PATCH 21/22] tty: vt: use ASCII enum constants in vt_console_print()
Date: Fri,  2 Feb 2024 07:56:07 +0100	[thread overview]
Message-ID: <20240202065608.14019-22-jirislaby@kernel.org> (raw)
In-Reply-To: <20240202065608.14019-1-jirislaby@kernel.org>

There are still numbers used for ASCII characters in vt_console_print().
As we have an ASCII enum now, use the constant names from the enum
instead.

Signed-off-by: Jiri Slaby (SUSE) <jirislaby@kernel.org>
---
 drivers/tty/vt/vt.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/drivers/tty/vt/vt.c b/drivers/tty/vt/vt.c
index b3c61ec92df9..e35f7a31a7bd 100644
--- a/drivers/tty/vt/vt.c
+++ b/drivers/tty/vt/vt.c
@@ -3240,22 +3240,23 @@ static void vt_console_print(struct console *co, const char *b, unsigned count)
 	cnt = 0;
 	while (count--) {
 		c = *b++;
-		if (c == 10 || c == 13 || c == 8 || vc->vc_need_wrap) {
+		if (c == ASCII_LINEFEED || c == ASCII_CAR_RET ||
+		    c == ASCII_BACKSPACE || vc->vc_need_wrap) {
 			if (cnt && con_is_visible(vc))
 				vc->vc_sw->con_putcs(vc, start, cnt, vc->state.y, start_x);
 			cnt = 0;
-			if (c == 8) {		/* backspace */
+			if (c == ASCII_BACKSPACE) {
 				bs(vc);
 				start = (ushort *)vc->vc_pos;
 				start_x = vc->state.x;
 				continue;
 			}
-			if (c != 13)
+			if (c != ASCII_CAR_RET)
 				lf(vc);
 			cr(vc);
 			start = (ushort *)vc->vc_pos;
 			start_x = vc->state.x;
-			if (c == 10 || c == 13)
+			if (c == ASCII_LINEFEED || c == ASCII_CAR_RET)
 				continue;
 		}
 		vc_uniscr_putc(vc, c);
-- 
2.43.0


  parent reply	other threads:[~2024-02-02  6:56 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-02  6:55 [PATCH 00/22] tty: vt: cleanup ESC sequences handling Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 01/22] tty: vt: make rgb_from_256() slighly more comprehensible Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 02/22] tty: vt: define enums for CSI+h/l codes Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 03/22] tty: vt: rename set_mode() to csi_hl() Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 04/22] tty: vt: split DEC CSI+h/l handling into csi_DEC_hl() Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 05/22] tty: vt: remove unneeded assignment of EPecma to vc_priv Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 06/22] tty: vt: move CSI+n handling along to other ECMA CSIs Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 07/22] tty: vt: define an enum for CSI+] codes Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 08/22] tty: vt: rename setterm_command() to csi_RSB() Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 09/22] tty: vt: put cases on separate lines Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 10/22] tty: vt: accept u8 in do_con_trol() and vc_setGx() Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 11/22] tty: vt: extract ascii handling to handle_ascii() Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 12/22] tty: vt: separate ESesc state handling into handle_esc() Jiri Slaby (SUSE)
2024-02-02  6:55 ` [PATCH 13/22] tty: vt: move CSI DEC handling to a separate function Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 14/22] tty: vt: move CSI ECMA " Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 15/22] tty: vt: name, reflow and document enum vc_ctl_state Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 16/22] tty: vt: simplify ansi_control_string() Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 17/22] tty: vt: handle CSI+[ inside preexisting switch-case Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 18/22] tty: vt: add new helper for reseting vc parameters Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 19/22] tty: vt: use switch+case in the ESnonstd case Jiri Slaby (SUSE)
2024-02-02  6:56 ` [PATCH 20/22] tty: vt: use switch+case in the ESgetpars case Jiri Slaby (SUSE)
2024-02-02  6:56 ` Jiri Slaby (SUSE) [this message]
2024-02-02  6:56 ` [PATCH 22/22] tty: vt: decrypt magic constants in vc_is_control() Jiri Slaby (SUSE)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240202065608.14019-22-jirislaby@kernel.org \
    --to=jirislaby@kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®