From: Pekka Paalanen <pekka.paalanen@collabora.com>
To: Louis Chauvet <louis.chauvet@bootlin.com>
Cc: "Rodrigo Siqueira" <rodrigosiqueiramelo@gmail.com>,
"Melissa Wen" <melissa.srw@gmail.com>,
"Maíra Canal" <mairacanal@riseup.net>,
"Haneen Mohammed" <hamohammed.sa@gmail.com>,
"Daniel Vetter" <daniel@ffwll.ch>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"David Airlie" <airlied@gmail.com>,
rdunlap@infradead.org, arthurgrillo@riseup.net,
"Jonathan Corbet" <corbet@lwn.net>,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
jeremie.dautheribes@bootlin.com, miquel.raynal@bootlin.com,
thomas.petazzoni@bootlin.com, seanpaul@google.com,
marcheu@google.com, nicolejadeyee@google.com
Subject: Re: [PATCH v6 09/17] drm/vkms: Introduce pixel_read_direction enum
Date: Mon, 22 Apr 2024 14:39:18 +0300 [thread overview]
Message-ID: <20240422143918.098d3d09.pekka.paalanen@collabora.com> (raw)
In-Reply-To: <20240409-yuv-v6-9-de1c5728fd70@bootlin.com>
[-- Attachment #1: Type: text/plain, Size: 6027 bytes --]
On Tue, 09 Apr 2024 15:25:27 +0200
Louis Chauvet <louis.chauvet@bootlin.com> wrote:
> The pixel_read_direction enum is useful to describe the reading direction
> in a plane. It avoids using the rotation property of DRM, which not
> practical to know the direction of reading.
> This patch also introduce two helpers, one to compute the
> pixel_read_direction from the DRM rotation property, and one to compute
> the step, in byte, between two successive pixel in a specific direction.
>
> Signed-off-by: Louis Chauvet <louis.chauvet@bootlin.com>
> ---
> drivers/gpu/drm/vkms/vkms_composer.c | 42 ++++++++++++++++++++++++++++++++++++
> drivers/gpu/drm/vkms/vkms_drv.h | 11 ++++++++++
> drivers/gpu/drm/vkms/vkms_formats.c | 30 ++++++++++++++++++++++++++
> 3 files changed, 83 insertions(+)
>
> diff --git a/drivers/gpu/drm/vkms/vkms_composer.c b/drivers/gpu/drm/vkms/vkms_composer.c
> index 45b111c74884..7c2e328c9510 100644
> --- a/drivers/gpu/drm/vkms/vkms_composer.c
> +++ b/drivers/gpu/drm/vkms/vkms_composer.c
> @@ -159,6 +159,48 @@ static void apply_lut(const struct vkms_crtc_state *crtc_state, struct line_buff
> }
> }
>
> +/**
> + * direction_for_rotation() - Get the correct reading direction for a given rotation
> + *
> + * @rotation: Rotation to analyze. It correspond the field @frame_info.rotation.
> + *
> + * This function will use the @rotation setting of a source plane to compute the reading
> + * direction in this plane which correspond to a "left to right writing" in the CRTC.
> + * For example, if the buffer is reflected on X axis, the pixel must be read from right to left
> + * to be written from left to right on the CRTC.
> + */
> +static enum pixel_read_direction direction_for_rotation(unsigned int rotation)
> +{
> + struct drm_rect tmp_a, tmp_b;
> + int x, y;
> +
> + /*
> + * The direction is computed by rotating the vector AB (top-left to top-right) in a
> + * 1x1 square.
Points A and B are depicted as zero-size rectangles on the CRTC.
The CRTC writing direction is from A to B. The plane reading direction
is discovered by inverse-transforming A and B.
(If you want, you can add that to the comment.)
> + */
> +
> + tmp_a = DRM_RECT_INIT(0, 0, 0, 0);
> + tmp_b = DRM_RECT_INIT(1, 0, 0, 0);
> + drm_rect_rotate_inv(&tmp_a, 1, 1, rotation);
> + drm_rect_rotate_inv(&tmp_b, 1, 1, rotation);
> +
> + x = tmp_b.x1 - tmp_a.x1;
> + y = tmp_b.y1 - tmp_a.y1;
> +
> + if (x == 1)
> + return READ_LEFT_TO_RIGHT;
> + else if (x == -1)
> + return READ_RIGHT_TO_LEFT;
> + else if (y == 1)
> + return READ_TOP_TO_BOTTOM;
> + else if (y == -1)
> + return READ_BOTTOM_TO_TOP;
I find this code practically obvious. Excellent!
If you want to be more strict, each condition could also require the
other component to be zero.
> +
> +
> + WARN_ONCE(true, "The inverse of the rotation gives an incorrect direction.");
> + return READ_LEFT_TO_RIGHT;
> +}
> +
> /**
> * blend - blend the pixels from all planes and compute crc
> * @wb: The writeback frame buffer metadata
> diff --git a/drivers/gpu/drm/vkms/vkms_drv.h b/drivers/gpu/drm/vkms/vkms_drv.h
> index 2e1a1b824a3c..16317b063c20 100644
> --- a/drivers/gpu/drm/vkms/vkms_drv.h
> +++ b/drivers/gpu/drm/vkms/vkms_drv.h
> @@ -69,6 +69,17 @@ struct vkms_writeback_job {
> pixel_write_t pixel_write;
> };
>
> +/**
> + * enum pixel_read_direction - Enum used internaly by VKMS to represent a reading direction in a
> + * plane.
> + */
> +enum pixel_read_direction {
> + READ_BOTTOM_TO_TOP,
> + READ_TOP_TO_BOTTOM,
> + READ_RIGHT_TO_LEFT,
> + READ_LEFT_TO_RIGHT
> +};
> +
> /**
> * typedef pixel_read_t - These functions are used to read a pixel in the source frame,
> * convert it to `struct pixel_argb_u16` and write it to @out_pixel.
> diff --git a/drivers/gpu/drm/vkms/vkms_formats.c b/drivers/gpu/drm/vkms/vkms_formats.c
> index 9a1400ad4db6..f76944874fe7 100644
> --- a/drivers/gpu/drm/vkms/vkms_formats.c
> +++ b/drivers/gpu/drm/vkms/vkms_formats.c
> @@ -75,6 +75,36 @@ static void packed_pixels_addr(const struct vkms_frame_info *frame_info,
> *addr = (u8 *)frame_info->map[0].vaddr + offset;
> }
>
> +/**
> + * get_block_step_byte() - Common helper to compute the correct step value between each pixel block
This should be called get_block_step_bytes(). "Byte" sounds like it
returns a single byte.
> + * to read in a certain direction.
> + *
> + * @fb: Framebuffer to iter on
> + * @direction: Direction of the reading
> + * @plane_index: Plane to get the step from
> + *
> + * As the returned offset is the number of bytes between two consecutive blocks in a direction,
I'd call it "returned count" rather than "returned offset".
> + * the caller may have to read multiple pixel before using the next one (for example, to read from
...multiple pixels before using the next block
> + * left to right in a DRM_FORMAT_R1 plane, each block contains 8 pixels, so the step must be used
> + * only every 8 pixels.
Close parenthesis.
> + */
> +static int get_block_step_byte(struct drm_framebuffer *fb, enum pixel_read_direction direction,
> + int plane_index)
> +{
> + switch (direction) {
> + case READ_LEFT_TO_RIGHT:
> + return fb->format->char_per_block[plane_index];
> + case READ_RIGHT_TO_LEFT:
> + return -fb->format->char_per_block[plane_index];
> + case READ_TOP_TO_BOTTOM:
> + return (int)fb->pitches[plane_index];
> + case READ_BOTTOM_TO_TOP:
> + return -(int)fb->pitches[plane_index];
I'm not sure if this is correct for formats with block_h > 1.
If a pitch is the theoretical count of bytes per line, then this should
return block_h * pitch. But I'm not exactly sure what is correct here.
Aside from this problem, looks good.
Thanks,
pq
> + }
> +
> + return 0;
> +}
> +
> /**
> * packed_pixels_addr_1x1() - Get the pointer to the block containing the pixel at the given
> * coordinates
>
[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 833 bytes --]
next prev parent reply other threads:[~2024-04-22 11:39 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-09 13:25 [PATCH v6 00/17] drm/vkms: Reimplement line-per-line pixel conversion for plane reading Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 01/17] drm/vkms: Code formatting Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 02/17] drm/vkms: Use drm_frame directly Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 03/17] drm/vkms: write/update the documentation for pixel conversion and pixel write functions Louis Chauvet
2024-04-22 10:33 ` Pekka Paalanen
2024-05-13 6:31 ` Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 04/17] drm/vkms: Add typedef and documentation for pixel_read and pixel_write functions Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 05/17] drm/vkms: Add dummy pixel_read/pixel_write callbacks to avoid NULL pointers Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 06/17] drm/vkms: Use const for input pointers in pixel_read an pixel_write functions Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 07/17] drm/vkms: Update pixels accessor to support packed and multi-plane formats Louis Chauvet
2024-04-22 11:07 ` Pekka Paalanen
2024-05-13 7:15 ` Louis Chauvet
2024-05-13 11:14 ` Pekka Paalanen
2024-04-09 13:25 ` [PATCH v6 08/17] drm/vkms: Avoid computing blending limits inside pre_mul_alpha_blend Louis Chauvet
2024-04-22 11:12 ` Pekka Paalanen
2024-04-09 13:25 ` [PATCH v6 09/17] drm/vkms: Introduce pixel_read_direction enum Louis Chauvet
2024-04-22 11:39 ` Pekka Paalanen [this message]
2024-05-13 7:15 ` Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 10/17] drm/vkms: Re-introduce line-per-line composition algorithm Louis Chauvet
2024-04-22 12:38 ` Pekka Paalanen
2024-04-09 13:25 ` [PATCH v6 11/17] drm/vkms: Remove useless drm_rotation_simplify Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 12/17] drm/vkms: Add YUV support Louis Chauvet
2024-04-22 14:47 ` Pekka Paalanen
2024-04-09 13:25 ` [PATCH v6 13/17] drm/vkms: Add range and encoding properties to the plane Louis Chauvet
2024-04-22 14:49 ` Pekka Paalanen
2024-04-09 13:25 ` [PATCH v6 14/17] drm/vkms: Drop YUV formats TODO Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 15/17] drm/vkms: Create KUnit tests for YUV conversions Louis Chauvet
2024-04-23 13:29 ` Pekka Paalanen
2024-04-09 13:25 ` [PATCH v6 16/17] drm/vkms: Add how to run the Kunit tests Louis Chauvet
2024-04-09 13:25 ` [PATCH v6 17/17] drm/vkms: Add support for DRM_FORMAT_R* Louis Chauvet
2024-04-23 14:26 ` Pekka Paalanen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240422143918.098d3d09.pekka.paalanen@collabora.com \
--to=pekka.paalanen@collabora.com \
--cc=airlied@gmail.com \
--cc=arthurgrillo@riseup.net \
--cc=corbet@lwn.net \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=hamohammed.sa@gmail.com \
--cc=jeremie.dautheribes@bootlin.com \
--cc=linux-kernel@vger.kernel.org \
--cc=louis.chauvet@bootlin.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mairacanal@riseup.net \
--cc=marcheu@google.com \
--cc=melissa.srw@gmail.com \
--cc=miquel.raynal@bootlin.com \
--cc=mripard@kernel.org \
--cc=nicolejadeyee@google.com \
--cc=rdunlap@infradead.org \
--cc=rodrigosiqueiramelo@gmail.com \
--cc=seanpaul@google.com \
--cc=thomas.petazzoni@bootlin.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®