From: Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
To: <peterz@infradead.org>, <mingo@redhat.com>, <acme@kernel.org>,
<namhyung@kernel.org>, <mark.rutland@arm.com>,
<alexander.shishkin@linux.intel.com>, <jolsa@kernel.org>,
<irogers@google.com>, <adrian.hunter@intel.com>,
<kan.liang@linux.intel.com>, <tglx@linutronix.de>, <bp@alien8.de>,
<dave.hansen@linux.intel.com>, <x86@kernel.org>,
<kees@kernel.org>, <gustavoars@kernel.org>, <rui.zhang@intel.com>,
<oleksandr@natalenko.name>
Cc: <linux-perf-users@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <linux-hardening@vger.kernel.org>,
<ananth.narayan@amd.com>, <gautham.shenoy@amd.com>,
<kprateek.nayak@amd.com>, <ravi.bangoria@amd.com>,
<sandipan.das@amd.com>, <linux-pm@vger.kernel.org>,
Dhananjay Ugwekar <Dhananjay.Ugwekar@amd.com>
Subject: [PATCH v2 0/9] Add per-core RAPL energy counter support for AMD CPUs
Date: Thu, 20 Jun 2024 12:56:54 +0000 [thread overview]
Message-ID: <20240620125703.3297-1-Dhananjay.Ugwekar@amd.com> (raw)
Currently the energy-cores event in the power PMU aggregates energy
consumption data at a package level. On the other hand the core energy
RAPL counter in AMD CPUs has a core scope (which means the energy
consumption is recorded separately for each core). Earlier efforts to add
the core event in the power PMU had failed [1], due to the difference in
the scope of these two events. Hence, there is a need for a new core scope
PMU.
This patchset adds a new "power_per_core" PMU alongside the existing
"power" PMU, which will be responsible for collecting the new
"energy-per-core" event.
Tested the package level and core level PMU counters with workloads
pinned to different CPUs.
Results with workload pinned to CPU 1 in Core 1 on an AMD Zen4 Genoa
machine:
$ perf stat -a --per-core -e power_per_core/energy-per-core/ sleep 1
Performance counter stats for 'system wide':
S0-D0-C0 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C1 1 5.72 Joules power_per_core/energy-per-core/
S0-D0-C2 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C3 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C4 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C5 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C6 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C7 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C8 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C9 1 0.02 Joules power_per_core/energy-per-core/
S0-D0-C10 1 0.02 Joules power_per_core/energy-per-core/
[1]: https://lore.kernel.org/lkml/3e766f0e-37d4-0f82-3868-31b14228868d@linux.intel.com/
This patchset applies cleanly on top of v6.10-rc4 as well as latest
tip/master.
v2 changes:
* Patches 6,7,8 added to split some changes out of the last patch
* Use container_of to get the rapl_pmus from event variable (Rui)
* Set PERF_EV_CAP_READ_ACTIVE_PKG flag only for pkg scope PMU (Rui)
* Use event id 0x1 for energy-per-core event (Rui)
* Use PERF_RAPL_PER_CORE bit instead of adding a new flag to check for
per-core counter hw support (Rui)
Dhananjay Ugwekar (9):
perf/x86/rapl: Fix the energy-pkg event for AMD CPUs
perf/x86/rapl: Rename rapl_pmu variables
perf/x86/rapl: Make rapl_model struct global
perf/x86/rapl: Move cpumask variable to rapl_pmus struct
perf/x86/rapl: Add wrapper for online/offline functions
perf/x86/rapl: Add an argument to the cleanup and init functions
perf/x86/rapl: Modify the generic variable names to *_pkg*
perf/x86/rapl: Remove the global variable rapl_msrs
perf/x86/rapl: Add per-core energy counter support for AMD CPUs
arch/x86/events/rapl.c | 418 +++++++++++++++++++++++++++++------------
1 file changed, 297 insertions(+), 121 deletions(-)
--
2.34.1
next reply other threads:[~2024-06-20 12:57 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-06-20 12:56 Dhananjay Ugwekar [this message]
2024-06-20 12:56 ` [PATCH v2 1/9] perf/x86/rapl: Fix the energy-pkg event " Dhananjay Ugwekar
2024-06-20 12:56 ` [PATCH v2 2/9] perf/x86/rapl: Rename rapl_pmu variables Dhananjay Ugwekar
2024-06-20 12:56 ` [PATCH v2 3/9] perf/x86/rapl: Make rapl_model struct global Dhananjay Ugwekar
2024-06-20 12:56 ` [PATCH v2 4/9] perf/x86/rapl: Move cpumask variable to rapl_pmus struct Dhananjay Ugwekar
2024-06-20 12:56 ` [PATCH v2 5/9] perf/x86/rapl: Add wrapper for online/offline functions Dhananjay Ugwekar
2024-06-20 12:57 ` [PATCH v2 6/9] perf/x86/rapl: Add an argument to the cleanup and init functions Dhananjay Ugwekar
2024-06-20 12:57 ` [PATCH v2 7/9] perf/x86/rapl: Modify the generic variable names to *_pkg* Dhananjay Ugwekar
2024-06-20 12:57 ` [PATCH v2 8/9] perf/x86/rapl: Remove the global variable rapl_msrs Dhananjay Ugwekar
2024-06-20 12:57 ` [PATCH v2 9/9] perf/x86/rapl: Add per-core energy counter support for AMD CPUs Dhananjay Ugwekar
2024-06-21 8:24 ` [PATCH v2 0/9] Add per-core RAPL " K Prateek Nayak
2024-06-21 8:49 ` Dhananjay Ugwekar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240620125703.3297-1-Dhananjay.Ugwekar@amd.com \
--to=dhananjay.ugwekar@amd.com \
--cc=acme@kernel.org \
--cc=adrian.hunter@intel.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=ananth.narayan@amd.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=gautham.shenoy@amd.com \
--cc=gustavoars@kernel.org \
--cc=irogers@google.com \
--cc=jolsa@kernel.org \
--cc=kan.liang@linux.intel.com \
--cc=kees@kernel.org \
--cc=kprateek.nayak@amd.com \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-perf-users@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mingo@redhat.com \
--cc=namhyung@kernel.org \
--cc=oleksandr@natalenko.name \
--cc=peterz@infradead.org \
--cc=ravi.bangoria@amd.com \
--cc=rui.zhang@intel.com \
--cc=sandipan.das@amd.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®