On Tue, Jul 09, 2024 at 11:21:08AM -1000, Tejun Heo wrote: > task_linked_on_dsq() exists as a helper becauase it used to test both the > rbtree and list nodes. It now only tests the list node and the list node > will soon be used for something else too. The helper doesn't improve > anything materially and the naming will become confusing. Open-code the list > node testing and remove task_linked_on_dsq() > > Signed-off-by: Tejun Heo > Cc: David Vernet Acked-by: David Vernet