From: Louis Chauvet <louis.chauvet@bootlin.com>
To: "Rodrigo Siqueira" <rodrigosiqueiramelo@gmail.com>,
"Melissa Wen" <melissa.srw@gmail.com>,
"Maíra Canal" <mairacanal@riseup.net>,
"Haneen Mohammed" <hamohammed.sa@gmail.com>,
"Daniel Vetter" <daniel@ffwll.ch>,
"Maarten Lankhorst" <maarten.lankhorst@linux.intel.com>,
"Maxime Ripard" <mripard@kernel.org>,
"Thomas Zimmermann" <tzimmermann@suse.de>,
"David Airlie" <airlied@gmail.com>
Cc: dri-devel@lists.freedesktop.org, arthurgrillo@riseup.net,
linux-kernel@vger.kernel.org, jeremie.dautheribes@bootlin.com,
miquel.raynal@bootlin.com, thomas.petazzoni@bootlin.com,
seanpaul@google.com, nicolejadeyee@google.com,
Louis Chauvet <louis.chauvet@bootlin.com>
Subject: [PATCH v2 0/6] drm/vkms: Switch all vkms object to DRM managed objects
Date: Tue, 27 Aug 2024 11:57:35 +0200 [thread overview]
Message-ID: <20240827-google-vkms-managed-v2-0-f41104553aeb@bootlin.com> (raw)
To simplify the memory managment this series replace all allocation by
drm-managed one. This way the VKMS code don't have to manage it directly
and the DRM core will handle the object destruction.
No functional changes are intended in this series.
PATCH 1/6: Migrate connector managment to drm
PATCH 2/6: Migrate encoder managment to drm
PATCH 3/6: Rename vkms_output to vkms_crtc
PATCH 4/6: Rename to_vkms_crtc_state
PATCH 5/6: Migrate connector management to drm
PATCH 6/6: Add missing check in CRTC initialization
This series have conflicts with [1], which adds documentation for the
vkms_output/vkms_crtc structure. when one of those series is merged, I
will rebase the other.
[1]: https://lore.kernel.org/all/20240826-google-clarifications-v2-1-2574655b0b91@bootlin.com/
Signed-off-by: Louis Chauvet <louis.chauvet@bootlin.com>
---
Changes in v2:
- Applied comments from José
- Extract the rename vkms_output -> vkms_crtc to avoid useless changes in
the last commit
- Extract the rename to_vkms_crtc_state to
drm_crtc_state_to_vkms_crtc_state to avoid useless changes in last
commit
- Extract the drm_mode_crtc_set_gamma_size result check in its own commit
- Rebased on drm-misc/drm-misc-next
- Link to v1: https://lore.kernel.org/r/20240814-google-vkms-managed-v1-0-7ab8b8921103@bootlin.com
---
Louis Chauvet (6):
drm/vkms: Switch to managed for connector
drm/vkms: Switch to managed for encoder
drm/vkms: Rename vkms_output to vkms_crtc
drm/vkms: rename to_vkms_crtc_state to drm_crtc_state_to_vkms_crtc_state to avoid confusion
drm/vkms: Switch to managed for CRTC
drm/vkms: Add missing check for CRTC initialization
drivers/gpu/drm/vkms/vkms_composer.c | 30 +++++-----
drivers/gpu/drm/vkms/vkms_crtc.c | 97 ++++++++++++++++++--------------
drivers/gpu/drm/vkms/vkms_drv.c | 11 +---
drivers/gpu/drm/vkms/vkms_drv.h | 21 +++----
drivers/gpu/drm/vkms/vkms_output.c | 101 ++++++++++++++++------------------
drivers/gpu/drm/vkms/vkms_writeback.c | 22 ++++----
6 files changed, 138 insertions(+), 144 deletions(-)
---
base-commit: 071d583e01c88272f6ff216d4f867f8f35e94d7d
change-id: 20240521-google-vkms-managed-4aec99461a77
Best regards,
--
Louis Chauvet <louis.chauvet@bootlin.com>
next reply other threads:[~2024-08-27 10:01 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-27 9:57 Louis Chauvet [this message]
2024-08-27 9:57 ` [PATCH v2 1/6] drm/vkms: Switch to managed for connector Louis Chauvet
2024-08-27 13:15 ` Maxime Ripard
2024-08-27 13:24 ` Louis Chauvet
2024-08-27 14:39 ` Maxime Ripard
2024-08-27 15:08 ` Louis Chauvet
2024-08-27 16:42 ` Maxime Ripard
2024-08-27 9:57 ` [PATCH v2 2/6] drm/vkms: Switch to managed for encoder Louis Chauvet
2024-08-27 13:16 ` Maxime Ripard
2024-08-27 9:57 ` [PATCH v2 3/6] drm/vkms: Rename vkms_output to vkms_crtc Louis Chauvet
2024-08-27 9:57 ` [PATCH v2 4/6] drm/vkms: rename to_vkms_crtc_state to drm_crtc_state_to_vkms_crtc_state to avoid confusion Louis Chauvet
2024-08-27 9:57 ` [PATCH v2 5/6] drm/vkms: Switch to managed for CRTC Louis Chauvet
2024-08-30 21:37 ` kernel test robot
2024-08-30 23:09 ` kernel test robot
2024-08-27 9:57 ` [PATCH v2 6/6] drm/vkms: Add missing check for CRTC initialization Louis Chauvet
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240827-google-vkms-managed-v2-0-f41104553aeb@bootlin.com \
--to=louis.chauvet@bootlin.com \
--cc=airlied@gmail.com \
--cc=arthurgrillo@riseup.net \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=hamohammed.sa@gmail.com \
--cc=jeremie.dautheribes@bootlin.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mairacanal@riseup.net \
--cc=melissa.srw@gmail.com \
--cc=miquel.raynal@bootlin.com \
--cc=mripard@kernel.org \
--cc=nicolejadeyee@google.com \
--cc=rodrigosiqueiramelo@gmail.com \
--cc=seanpaul@google.com \
--cc=thomas.petazzoni@bootlin.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®