From: Ankur Arora <ankur.a.arora@oracle.com>
To: linux-pm@vger.kernel.org, kvm@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org
Cc: catalin.marinas@arm.com, will@kernel.org, tglx@linutronix.de,
mingo@redhat.com, bp@alien8.de, dave.hansen@linux.intel.com,
x86@kernel.org, hpa@zytor.com, pbonzini@redhat.com,
wanpengli@tencent.com, vkuznets@redhat.com, rafael@kernel.org,
daniel.lezcano@linaro.org, peterz@infradead.org, arnd@arndb.de,
lenb@kernel.org, mark.rutland@arm.com, harisokn@amazon.com,
mtosatti@redhat.com, sudeep.holla@arm.com, cl@gentwo.org,
misono.tomohiro@fujitsu.com, maobibo@loongson.cn,
joao.m.martins@oracle.com, boris.ostrovsky@oracle.com,
konrad.wilk@oracle.com
Subject: [PATCH v8 00/11] Enable haltpoll on arm64
Date: Wed, 25 Sep 2024 16:24:14 -0700 [thread overview]
Message-ID: <20240925232425.2763385-1-ankur.a.arora@oracle.com> (raw)
This patchset enables the cpuidle-haltpoll driver and its namesake
governor on arm64. This is specifically interesting for KVM guests by
reducing IPC latencies.
Comparing idle switching latencies on an arm64 KVM guest with
perf bench sched pipe:
usecs/op %stdev
no haltpoll (baseline) 13.48 +- 5.19%
with haltpoll 6.84 +- 22.07%
No change in performance for a similar test on x86:
usecs/op %stdev
haltpoll w/ cpu_relax() (baseline) 4.75 +- 1.76%
haltpoll w/ smp_cond_load_relaxed() 4.78 +- 2.31%
Both sets of tests were on otherwise idle systems with guest VCPUs
pinned to specific PCPUs. One reason for the higher stdev on arm64
is that trapping of the WFE instruction by the host KVM is contingent
on the number of tasks on the runqueue.
Tomohiro Misono and Haris Okanovic also report similar latency
improvements on Grace and Graviton systems (for v7) [1] [2].
The patch series is organized in three parts:
- patch 1, reorganizes the poll_idle() loop, switching to
smp_cond_load_relaxed() in the polling loop.
Relatedly patches 2, 3 mangle the config option ARCH_HAS_CPU_RELAX,
renaming it to ARCH_HAS_OPTIMIZED_POLL.
- patches 4-6 reorganize the haltpoll selection and init logic
to allow architecture code to select it.
- and finally, patches 7-11 add the bits for arm64 support.
What is still missing: this series largely completes the haltpoll side
of functionality for arm64. There are, however, a few related areas
that still need to be threshed out:
- WFET support: WFE on arm64 does not guarantee that poll_idle()
would terminate in halt_poll_ns. Using WFET would address this.
- KVM_NO_POLL support on arm64
- KVM TWED support on arm64: allow the host to limit time spent in
WFE.
Changelog:
v8: No logic changes. Largely respin of v7, with changes
noted below:
- move selection of ARCH_HAS_OPTIMIZED_POLL on arm64 to its
own patch.
(patch-9 "arm64: select ARCH_HAS_OPTIMIZED_POLL")
- address comments simplifying arm64 support (Will Deacon)
(patch-11 "arm64: support cpuidle-haltpoll")
v7: No significant logic changes. Mostly a respin of v6.
- minor cleanup in poll_idle() (Christoph Lameter)
- fixes conflicts due to code movement in arch/arm64/kernel/cpuidle.c
(Tomohiro Misono)
v6:
- reordered the patches to keep poll_idle() and ARCH_HAS_OPTIMIZED_POLL
changes together (comment from Christoph Lameter)
- threshes out the commit messages a bit more (comments from Christoph
Lameter, Sudeep Holla)
- also rework selection of cpuidle-haltpoll. Now selected based
on the architectural selection of ARCH_CPUIDLE_HALTPOLL.
- moved back to arch_haltpoll_want() (comment from Joao Martins)
Also, arch_haltpoll_want() now takes the force parameter and is
now responsible for the complete selection (or not) of haltpoll.
- fixes the build breakage on i386
- fixes the cpuidle-haltpoll module breakage on arm64 (comment from
Tomohiro Misono, Haris Okanovic)
v5:
- rework the poll_idle() loop around smp_cond_load_relaxed() (review
comment from Tomohiro Misono.)
- also rework selection of cpuidle-haltpoll. Now selected based
on the architectural selection of ARCH_CPUIDLE_HALTPOLL.
- arch_haltpoll_supported() (renamed from arch_haltpoll_want()) on
arm64 now depends on the event-stream being enabled.
- limit POLL_IDLE_RELAX_COUNT on arm64 (review comment from Haris Okanovic)
- ARCH_HAS_CPU_RELAX is now renamed to ARCH_HAS_OPTIMIZED_POLL.
v4 changes from v3:
- change 7/8 per Rafael input: drop the parens and use ret for the final check
- add 8/8 which renames the guard for building poll_state
v3 changes from v2:
- fix 1/7 per Petr Mladek - remove ARCH_HAS_CPU_RELAX from arch/x86/Kconfig
- add Ack-by from Rafael Wysocki on 2/7
v2 changes from v1:
- added patch 7 where we change cpu_relax with smp_cond_load_relaxed per PeterZ
(this improves by 50% at least the CPU cycles consumed in the tests above:
10,716,881,137 now vs 14,503,014,257 before)
- removed the ifdef from patch 1 per RafaelW
Please review.
[1] https://lore.kernel.org/lkml/TY3PR01MB111481E9B0AF263ACC8EA5D4AE5BA2@TY3PR01MB11148.jpnprd01.prod.outlook.com/
[2] https://lore.kernel.org/lkml/104d0ec31cb45477e27273e089402d4205ee4042.camel@amazon.com/
Ankur Arora (6):
cpuidle: rename ARCH_HAS_CPU_RELAX to ARCH_HAS_OPTIMIZED_POLL
cpuidle-haltpoll: condition on ARCH_CPUIDLE_HALTPOLL
arm64: idle: export arch_cpu_idle
arm64: select ARCH_HAS_OPTIMIZED_POLL
cpuidle/poll_state: limit POLL_IDLE_RELAX_COUNT on arm64
arm64: support cpuidle-haltpoll
Joao Martins (4):
Kconfig: move ARCH_HAS_OPTIMIZED_POLL to arch/Kconfig
cpuidle-haltpoll: define arch_haltpoll_want()
governors/haltpoll: drop kvm_para_available() check
arm64: define TIF_POLLING_NRFLAG
Mihai Carabas (1):
cpuidle/poll_state: poll via smp_cond_load_relaxed()
arch/Kconfig | 3 +++
arch/arm64/Kconfig | 7 +++++++
arch/arm64/include/asm/cpuidle_haltpoll.h | 24 +++++++++++++++++++++++
arch/arm64/include/asm/thread_info.h | 2 ++
arch/arm64/kernel/idle.c | 1 +
arch/x86/Kconfig | 5 ++---
arch/x86/include/asm/cpuidle_haltpoll.h | 1 +
arch/x86/kernel/kvm.c | 13 ++++++++++++
drivers/acpi/processor_idle.c | 4 ++--
drivers/cpuidle/Kconfig | 5 ++---
drivers/cpuidle/Makefile | 2 +-
drivers/cpuidle/cpuidle-haltpoll.c | 12 +-----------
drivers/cpuidle/governors/haltpoll.c | 6 +-----
drivers/cpuidle/poll_state.c | 22 +++++++++++++++------
drivers/idle/Kconfig | 1 +
include/linux/cpuidle.h | 2 +-
include/linux/cpuidle_haltpoll.h | 5 +++++
17 files changed, 83 insertions(+), 32 deletions(-)
create mode 100644 arch/arm64/include/asm/cpuidle_haltpoll.h
--
2.43.5
next reply other threads:[~2024-09-25 23:25 UTC|newest]
Thread overview: 74+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-25 23:24 Ankur Arora [this message]
2024-09-25 23:24 ` [PATCH v8 01/11] cpuidle/poll_state: poll via smp_cond_load_relaxed() Ankur Arora
2024-10-15 12:04 ` Catalin Marinas
2024-10-15 16:42 ` Christoph Lameter (Ampere)
2024-10-15 16:50 ` Catalin Marinas
2024-10-15 17:17 ` Christoph Lameter (Ampere)
2024-10-15 17:40 ` Catalin Marinas
2024-10-15 21:53 ` Ankur Arora
2024-10-15 22:28 ` Christoph Lameter (Ampere)
2024-10-16 7:06 ` Ankur Arora
2024-10-17 16:54 ` Christoph Lameter (Ampere)
2024-10-17 18:36 ` Ankur Arora
2024-10-15 22:40 ` Christoph Lameter (Ampere)
2024-10-16 9:54 ` Catalin Marinas
2024-10-17 16:56 ` Christoph Lameter (Ampere)
2024-10-17 18:15 ` Catalin Marinas
2024-10-17 19:34 ` Ankur Arora
2024-10-15 21:32 ` Ankur Arora
2024-10-16 6:20 ` maobibo
2024-10-16 10:06 ` Catalin Marinas
2024-10-16 15:13 ` Okanovic, Haris
2024-10-16 17:04 ` Ankur Arora
2024-10-16 18:04 ` Okanovic, Haris
2024-10-17 14:01 ` Catalin Marinas
2024-10-17 22:47 ` Ankur Arora
2024-10-18 11:05 ` Catalin Marinas
2024-10-18 19:00 ` Ankur Arora
2024-10-21 12:02 ` Catalin Marinas
2024-09-25 23:24 ` [PATCH v8 02/11] cpuidle: rename ARCH_HAS_CPU_RELAX to ARCH_HAS_OPTIMIZED_POLL Ankur Arora
2024-09-25 23:24 ` [PATCH v8 03/11] Kconfig: move ARCH_HAS_OPTIMIZED_POLL to arch/Kconfig Ankur Arora
2024-09-25 23:24 ` [PATCH v8 04/11] cpuidle-haltpoll: define arch_haltpoll_want() Ankur Arora
2024-09-25 23:24 ` [PATCH v8 05/11] governors/haltpoll: drop kvm_para_available() check Ankur Arora
2024-09-25 23:24 ` [PATCH v8 06/11] cpuidle-haltpoll: condition on ARCH_CPUIDLE_HALTPOLL Ankur Arora
2024-09-25 23:24 ` [PATCH v8 07/11] arm64: define TIF_POLLING_NRFLAG Ankur Arora
2024-09-25 23:24 ` [PATCH v8 08/11] arm64: idle: export arch_cpu_idle Ankur Arora
2024-09-25 23:24 ` [PATCH v8 09/11] arm64: select ARCH_HAS_OPTIMIZED_POLL Ankur Arora
2024-09-25 23:24 ` [PATCH v8 10/11] cpuidle/poll_state: limit POLL_IDLE_RELAX_COUNT on arm64 Ankur Arora
2024-09-25 23:24 ` [PATCH v8 11/11] arm64: support cpuidle-haltpoll Ankur Arora
2024-10-02 22:42 ` Okanovic, Haris
2024-10-03 3:29 ` Ankur Arora
2024-10-16 15:13 ` Okanovic, Haris
2024-10-09 2:37 ` [PATCH v8 00/11] Enable haltpoll on arm64 zhenglifeng (A)
2024-10-15 1:53 ` Ankur Arora
2024-10-14 22:54 ` Christoph Lameter (Ampere)
2024-10-15 12:36 ` Marc Zyngier
2024-10-16 21:55 ` Ankur Arora
2024-10-17 8:19 ` Marc Zyngier
2024-10-17 18:35 ` Ankur Arora
2024-10-22 22:01 ` Ankur Arora
2024-11-05 18:30 ` Haris Okanovic
2024-11-05 18:30 ` [PATCH 1/5] asm-generic: add smp_vcond_load_relaxed() Haris Okanovic
2024-11-05 19:36 ` Christoph Lameter (Ampere)
2024-11-06 17:06 ` Okanovic, Haris
2024-11-06 11:08 ` Catalin Marinas
2024-11-06 18:13 ` Okanovic, Haris
2024-11-06 19:55 ` Catalin Marinas
2024-11-06 20:31 ` Okanovic, Haris
2024-11-06 11:39 ` Will Deacon
2024-11-06 17:18 ` Okanovic, Haris
2024-11-05 18:30 ` [PATCH 2/5] arm64: add __READ_ONCE_EX() Haris Okanovic
2024-11-05 19:39 ` Christoph Lameter (Ampere)
2024-11-06 17:37 ` Okanovic, Haris
2024-11-06 11:43 ` Will Deacon
2024-11-06 17:09 ` Okanovic, Haris
2024-11-09 9:49 ` David Laight
2024-11-05 18:30 ` [PATCH 3/5] arm64: refactor delay() to enable polling for value Haris Okanovic
2024-11-05 19:42 ` Christoph Lameter (Ampere)
2024-11-06 17:42 ` Okanovic, Haris
2024-11-06 9:18 ` Catalin Marinas
2024-11-06 17:38 ` Okanovic, Haris
2024-11-05 18:30 ` [PATCH 4/5] arm64: add smp_vcond_load_relaxed() Haris Okanovic
2024-11-05 18:30 ` [PATCH 5/5] cpuidle: implement poll_idle() using smp_vcond_load_relaxed() Haris Okanovic
2024-11-05 19:45 ` Christoph Lameter (Ampere)
2024-11-05 18:49 ` [PATCH v8 00/11] Enable haltpoll on arm64 Ankur Arora
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240925232425.2763385-1-ankur.a.arora@oracle.com \
--to=ankur.a.arora@oracle.com \
--cc=arnd@arndb.de \
--cc=boris.ostrovsky@oracle.com \
--cc=bp@alien8.de \
--cc=catalin.marinas@arm.com \
--cc=cl@gentwo.org \
--cc=daniel.lezcano@linaro.org \
--cc=dave.hansen@linux.intel.com \
--cc=harisokn@amazon.com \
--cc=hpa@zytor.com \
--cc=joao.m.martins@oracle.com \
--cc=konrad.wilk@oracle.com \
--cc=kvm@vger.kernel.org \
--cc=lenb@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=maobibo@loongson.cn \
--cc=mark.rutland@arm.com \
--cc=mingo@redhat.com \
--cc=misono.tomohiro@fujitsu.com \
--cc=mtosatti@redhat.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=rafael@kernel.org \
--cc=sudeep.holla@arm.com \
--cc=tglx@linutronix.de \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
--cc=will@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®