From: "Kirill A. Shutemov" <kirill.shutemov@linux.intel.com>
To: Andrew Morton <akpm@linux-foundation.org>,
"Matthew Wilcox (Oracle)" <willy@infradead.org>,
Jens Axboe <axboe@kernel.dk>
Cc: "Jason A. Donenfeld" <Jason@zx2c4.com>,
"Kirill A. Shutemov" <kirill.shutemov@linux.intel.com>,
Andi Shyti <andi.shyti@linux.intel.com>,
Chengming Zhou <chengming.zhou@linux.dev>,
Christian Brauner <brauner@kernel.org>,
Christophe Leroy <christophe.leroy@csgroup.eu>,
Dan Carpenter <dan.carpenter@linaro.org>,
David Airlie <airlied@gmail.com>,
David Hildenbrand <david@redhat.com>, Hao Ge <gehao@kylinos.cn>,
Jani Nikula <jani.nikula@linux.intel.com>,
Johannes Weiner <hannes@cmpxchg.org>,
Joonas Lahtinen <joonas.lahtinen@linux.intel.com>,
Josef Bacik <josef@toxicpanda.com>,
Masami Hiramatsu <mhiramat@kernel.org>,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Miklos Szeredi <miklos@szeredi.hu>, Nhat Pham <nphamcs@gmail.com>,
Oscar Salvador <osalvador@suse.de>,
Ran Xiaokai <ran.xiaokai@zte.com.cn>,
Rodrigo Vivi <rodrigo.vivi@intel.com>,
Simona Vetter <simona@ffwll.ch>,
Steven Rostedt <rostedt@goodmis.org>,
Tvrtko Ursulin <tursulin@ursulin.net>,
Vlastimil Babka <vbabka@suse.cz>,
Yosry Ahmed <yosryahmed@google.com>, Yu Zhao <yuzhao@google.com>,
intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org,
linux-mm@kvack.org, linux-trace-kernel@vger.kernel.org
Subject: [PATCHv3 00/11] Get rid of PG_reclaim and rename PG_dropbehind
Date: Thu, 30 Jan 2025 12:00:38 +0200 [thread overview]
Message-ID: <20250130100050.1868208-1-kirill.shutemov@linux.intel.com> (raw)
Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.
After removing PG_relcaim, PG_readahead is exclusive user of the page
flag bit.
Once PG_reclaim is gone, we can rename PG_dropbehind to PG_reclaim.
v3:
- Condition folio_set_dropbehind() call in mapping_try_invalidate() on
!unevictable and !mapped;
- Add Reviewed-by tag by Yu Zhao;
Kirill A. Shutemov (11):
mm/migrate: Transfer PG_dropbehind to the new folio
drm/i915/gem: Convert __shmem_writeback() to folios
drm/i915/gem: Use PG_dropbehind instead of PG_reclaim
mm/zswap: Use PG_dropbehind instead of PG_reclaim
mm/truncate: Use folio_set_dropbehind() instead of
deactivate_file_folio()
mm/vmscan: Use PG_dropbehind instead of PG_reclaim
mm/vmscan: Use PG_dropbehind instead of PG_reclaim in
shrink_folio_list()
mm/mglru: Check PG_dropbehind instead of PG_reclaim in
lru_gen_folio_seq()
mm: Remove PG_reclaim
mm/vmscan: Do not demote PG_dropbehind folios
mm: Rename PG_dropbehind to PG_reclaim
drivers/gpu/drm/i915/gem/i915_gem_shmem.c | 18 ++-
fs/fuse/dev.c | 2 +-
fs/proc/page.c | 2 +-
include/linux/mm_inline.h | 18 +--
include/linux/page-flags.h | 23 ++--
include/linux/pagemap.h | 2 +-
include/trace/events/mmflags.h | 4 +-
include/uapi/linux/kernel-page-flags.h | 2 +-
mm/filemap.c | 46 +++----
mm/internal.h | 1 -
mm/migrate.c | 14 +-
mm/page-writeback.c | 16 +--
mm/page_io.c | 15 +--
mm/readahead.c | 4 +-
mm/swap.c | 153 +---------------------
mm/truncate.c | 5 +-
mm/vmscan.c | 28 +---
mm/zswap.c | 2 +-
tools/mm/page-types.c | 8 +-
19 files changed, 68 insertions(+), 295 deletions(-)
--
2.47.2
next reply other threads:[~2025-01-30 10:02 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-30 10:00 Kirill A. Shutemov [this message]
2025-01-30 10:00 ` [PATCHv3 01/11] mm/migrate: Transfer PG_dropbehind to the new folio Kirill A. Shutemov
2025-01-30 20:36 ` Yu Zhao
2025-01-30 10:00 ` [PATCHv3 02/11] drm/i915/gem: Convert __shmem_writeback() to folios Kirill A. Shutemov
2025-01-31 13:37 ` Andi Shyti
2025-01-31 14:21 ` Matthew Wilcox
2025-01-31 20:27 ` Shakeel Butt
2025-01-30 10:00 ` [PATCHv3 03/11] drm/i915/gem: Use PG_dropbehind instead of PG_reclaim Kirill A. Shutemov
2025-01-31 13:38 ` Andi Shyti
2025-01-30 10:00 ` [PATCHv3 04/11] mm/zswap: " Kirill A. Shutemov
2025-01-30 17:39 ` Nhat Pham
2025-01-30 10:00 ` [PATCHv3 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio() Kirill A. Shutemov
2025-01-30 20:34 ` Yu Zhao
2025-01-30 10:00 ` [PATCHv3 06/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim Kirill A. Shutemov
2025-01-31 21:32 ` Shakeel Butt
2025-02-01 8:01 ` Kairui Song
2025-02-03 7:14 ` Yu Zhao
2025-02-03 8:39 ` Kirill A. Shutemov
2025-02-04 0:47 ` Andrew Morton
2025-02-06 6:34 ` Sergey Senozhatsky
2025-01-30 10:00 ` [PATCHv3 07/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim in shrink_folio_list() Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 08/11] mm/mglru: Check PG_dropbehind instead of PG_reclaim in lru_gen_folio_seq() Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 09/11] mm: Remove PG_reclaim Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 10/11] mm/vmscan: Do not demote PG_dropbehind folios Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 11/11] mm: Rename PG_dropbehind to PG_reclaim Kirill A. Shutemov
2025-01-30 20:38 ` Yu Zhao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250130100050.1868208-1-kirill.shutemov@linux.intel.com \
--to=kirill.shutemov@linux.intel.com \
--cc=Jason@zx2c4.com \
--cc=airlied@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=andi.shyti@linux.intel.com \
--cc=axboe@kernel.dk \
--cc=brauner@kernel.org \
--cc=chengming.zhou@linux.dev \
--cc=christophe.leroy@csgroup.eu \
--cc=dan.carpenter@linaro.org \
--cc=david@redhat.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=gehao@kylinos.cn \
--cc=hannes@cmpxchg.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@linux.intel.com \
--cc=joonas.lahtinen@linux.intel.com \
--cc=josef@toxicpanda.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mhiramat@kernel.org \
--cc=miklos@szeredi.hu \
--cc=nphamcs@gmail.com \
--cc=osalvador@suse.de \
--cc=ran.xiaokai@zte.com.cn \
--cc=rodrigo.vivi@intel.com \
--cc=rostedt@goodmis.org \
--cc=simona@ffwll.ch \
--cc=tursulin@ursulin.net \
--cc=vbabka@suse.cz \
--cc=willy@infradead.org \
--cc=yosryahmed@google.com \
--cc=yuzhao@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®