From: Maxime Ripard <mripard@kernel.org>
To: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>,
Simona Vetter <simona@ffwll.ch>,
Andrzej Hajda <andrzej.hajda@intel.com>,
Neil Armstrong <neil.armstrong@linaro.org>,
Robert Foss <rfoss@kernel.org>,
Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
Jonas Karlman <jonas@kwiboo.se>,
Jernej Skrabec <jernej.skrabec@gmail.com>,
Douglas Anderson <dianders@chromium.org>
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
Maxime Ripard <mripard@kernel.org>
Subject: [PATCH v2 17/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_modeset_enables()
Date: Tue, 04 Feb 2025 15:57:45 +0100 [thread overview]
Message-ID: <20250204-bridge-connector-v2-17-35dd6c834e08@kernel.org> (raw)
In-Reply-To: <20250204-bridge-connector-v2-0-35dd6c834e08@kernel.org>
drm_atomic_helper_commit_modeset_enables() enables all outputs affected
by a new commit. It takes the drm_atomic_state being committed as a
parameter.
However, that parameter name is called (and documented) as old_state,
which is pretty confusing. Let's rename that variable as state.
Signed-off-by: Maxime Ripard <mripard@kernel.org>
---
drivers/gpu/drm/drm_atomic_helper.c | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/gpu/drm/drm_atomic_helper.c b/drivers/gpu/drm/drm_atomic_helper.c
index 9f3cf5df0dd810e3725bf44a02a9574f676f17de..b95e30dee1b4e2ba8991affd1e280a7a36171afd 100644
--- a/drivers/gpu/drm/drm_atomic_helper.c
+++ b/drivers/gpu/drm/drm_atomic_helper.c
@@ -1474,11 +1474,11 @@ static void drm_atomic_helper_commit_writebacks(struct drm_device *dev,
}
/**
* drm_atomic_helper_commit_modeset_enables - modeset commit to enable outputs
* @dev: DRM device
- * @old_state: atomic state object with old state structures
+ * @state: atomic state object being committed
*
* This function enables all the outputs with the new configuration which had to
* be turned off for the update.
*
* For compatibility with legacy CRTC helpers this should be called after
@@ -1486,20 +1486,20 @@ static void drm_atomic_helper_commit_writebacks(struct drm_device *dev,
* does. But drivers with different needs can group the modeset commits together
* and do the plane commits at the end. This is useful for drivers doing runtime
* PM since planes updates then only happen when the CRTC is actually enabled.
*/
void drm_atomic_helper_commit_modeset_enables(struct drm_device *dev,
- struct drm_atomic_state *old_state)
+ struct drm_atomic_state *state)
{
struct drm_crtc *crtc;
struct drm_crtc_state *old_crtc_state;
struct drm_crtc_state *new_crtc_state;
struct drm_connector *connector;
struct drm_connector_state *new_conn_state;
int i;
- for_each_oldnew_crtc_in_state(old_state, crtc, old_crtc_state, new_crtc_state, i) {
+ for_each_oldnew_crtc_in_state(state, crtc, old_crtc_state, new_crtc_state, i) {
const struct drm_crtc_helper_funcs *funcs;
/* Need to filter out CRTCs where only planes change. */
if (!drm_atomic_crtc_needs_modeset(new_crtc_state))
continue;
@@ -1511,17 +1511,17 @@ void drm_atomic_helper_commit_modeset_enables(struct drm_device *dev,
if (new_crtc_state->enable) {
drm_dbg_atomic(dev, "enabling [CRTC:%d:%s]\n",
crtc->base.id, crtc->name);
if (funcs->atomic_enable)
- funcs->atomic_enable(crtc, old_state);
+ funcs->atomic_enable(crtc, state);
else if (funcs->commit)
funcs->commit(crtc);
}
}
- for_each_new_connector_in_state(old_state, connector, new_conn_state, i) {
+ for_each_new_connector_in_state(state, connector, new_conn_state, i) {
const struct drm_encoder_helper_funcs *funcs;
struct drm_encoder *encoder;
struct drm_bridge *bridge;
if (!new_conn_state->best_encoder)
@@ -1540,25 +1540,25 @@ void drm_atomic_helper_commit_modeset_enables(struct drm_device *dev,
/*
* Each encoder has at most one connector (since we always steal
* it away), so we won't call enable hooks twice.
*/
bridge = drm_bridge_chain_get_first_bridge(encoder);
- drm_atomic_bridge_chain_pre_enable(bridge, old_state);
+ drm_atomic_bridge_chain_pre_enable(bridge, state);
if (funcs) {
if (funcs->atomic_enable)
- funcs->atomic_enable(encoder, old_state);
+ funcs->atomic_enable(encoder, state);
else if (funcs->enable)
funcs->enable(encoder);
else if (funcs->commit)
funcs->commit(encoder);
}
- drm_atomic_bridge_chain_enable(bridge, old_state);
+ drm_atomic_bridge_chain_enable(bridge, state);
}
- drm_atomic_helper_commit_writebacks(dev, old_state);
+ drm_atomic_helper_commit_writebacks(dev, state);
}
EXPORT_SYMBOL(drm_atomic_helper_commit_modeset_enables);
/*
* For atomic updates which touch just a single CRTC, calculate the time of the
--
2.48.0
next prev parent reply other threads:[~2025-02-04 14:59 UTC|newest]
Thread overview: 71+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-04 14:57 [PATCH v2 00/35] drm/bridge: Various quality of life improvements Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 01/35] drm/atomic: Document history of drm_atomic_state Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 02/35] drm/bridge: Pass full state to atomic_pre_enable Maxime Ripard
2025-02-05 2:53 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 03/35] drm/bridge: Pass full state to atomic_enable Maxime Ripard
2025-02-05 2:54 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 04/35] drm/bridge: Pass full state to atomic_disable Maxime Ripard
2025-02-05 3:19 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 05/35] drm/bridge: Pass full state to atomic_post_disable Maxime Ripard
2025-02-08 5:19 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 06/35] drm/atomic-helper: Fix commit_tail state variable name Maxime Ripard
2025-02-09 1:20 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 07/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_wait_for_dependencies() Maxime Ripard
2025-02-09 2:01 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 08/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_tail() Maxime Ripard
2025-02-09 2:03 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 09/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_tail_rpm() Maxime Ripard
2025-02-09 2:03 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 10/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_modeset_disables() Maxime Ripard
2025-02-09 2:11 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 11/35] drm/atomic-helper: Change parameter name of disable_outputs() Maxime Ripard
2025-02-09 2:12 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 12/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_disable() Maxime Ripard
2025-02-09 2:45 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 13/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_post_disable() Maxime Ripard
2025-02-08 1:08 ` Doug Anderson
2025-02-04 14:57 ` [PATCH v2 14/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_update_legacy_modeset_state() Maxime Ripard
2025-02-09 5:08 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 15/35] drm/atomic-helper: Change parameter name of crtc_set_mode() Maxime Ripard
2025-02-09 5:08 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 16/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_planes() Maxime Ripard
2025-02-04 14:57 ` Maxime Ripard [this message]
2025-02-04 14:57 ` [PATCH v2 18/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_pre_enable() Maxime Ripard
2025-02-08 1:08 ` Doug Anderson
2025-02-04 14:57 ` [PATCH v2 19/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_enable() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 20/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_writebacks() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 21/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_fake_vblank() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 22/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_hw_done() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 23/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_wait_for_vblanks() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 24/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_cleanup_planes() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 25/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_cleanup_done() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 26/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_wait_for_flip_done() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 27/35] drm/bridge: Add encoder parameter to drm_bridge_funcs.attach Maxime Ripard
2025-02-09 6:18 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 28/35] drm/bridge: Provide a helper to retrieve current bridge state Maxime Ripard
2025-02-09 6:12 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 29/35] drm/bridge: Assume that a bridge is atomic if it has atomic_reset Maxime Ripard
2025-02-09 6:18 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 30/35] drm/bridge: Provide pointers to the connector and crtc in bridge state Maxime Ripard
2025-02-09 7:00 ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 31/35] drm/bridge: Make encoder pointer deprecated Maxime Ripard
2025-02-09 7:01 ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 32/35] drm/bridge: cdns-csi: Switch to atomic helpers Maxime Ripard
2025-02-09 7:06 ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 33/35] drm/bridge: tc358775: Switch to atomic commit Maxime Ripard
2025-02-09 7:07 ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 34/35] drm/bridge: tc358768: Convert to atomic helpers Maxime Ripard
2025-02-09 7:13 ` Dmitry Baryshkov
2025-02-11 14:33 ` Maxime Ripard
2025-02-12 0:38 ` Dmitry Baryshkov
2025-02-12 8:24 ` Maxime Ripard
2025-02-12 10:51 ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 35/35] drm/bridge: ti-sn65dsi86: Use bridge_state crtc pointer Maxime Ripard
2025-02-08 1:44 ` Doug Anderson
2025-02-11 13:14 ` Maxime Ripard
2025-02-11 17:52 ` Doug Anderson
2025-02-11 22:16 ` Doug Anderson
2025-02-12 15:14 ` Doug Anderson
2025-02-09 3:27 ` [PATCH v2 00/35] drm/bridge: Various quality of life improvements Dmitry Baryshkov
2025-02-11 13:17 ` Maxime Ripard
2025-02-12 0:51 ` Dmitry Baryshkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250204-bridge-connector-v2-17-35dd6c834e08@kernel.org \
--to=mripard@kernel.org \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=airlied@gmail.com \
--cc=andrzej.hajda@intel.com \
--cc=dianders@chromium.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=jernej.skrabec@gmail.com \
--cc=jonas@kwiboo.se \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=neil.armstrong@linaro.org \
--cc=rfoss@kernel.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®